4.8 update help

Trying to do this update on my 272, it’s currently running the previous software. My laptop windows 7 cannot see any ports when usb cable is connected to the 272. I know it’s the correct cable as I bought it especially for this purpose when doing previous updates.
Any ideas?

Are you doing it with your laptop in wireless mode, try it with an ethernet cable, also when I had a Superuniti I needed to download something on my laptop, sorry that I can not remember what it was, someone will be along soon who is more knowledgeable than me

Have you followed all the stages that are written ?
I had to choose between 3 or 4 COM ports before finding the right one.

Yes same when I update my UnitiQute 2. 1- use ethernet. 2- select the right com port or the things wont see each other.

There aren’t any com ports showing in the drop down box, using a wired connection.

Have you read the instructions published by Naim?

If so then you will know that you have to load a driver onto your PC before attempting the update. Assuming the driver is loaded and working properly (which you can check, as described in the instructions), then it’s important that you connect the USB cable to the PC and have the other end plugged into the 272, with the 272 switched on, before you start the updater program. It won’t work if you start the program first and then connect the 272 to the PC.

You can do the update with WiFi if you want to or with Ethernet. That’s nothing to do with the com port being selectable or not though.


Sorry maybe it’s not the com port on the drop-down list, it’s something else. The right answer is to read and follow Naim’s instructions precisely. Including installation of the right usb to uart driver thingy.

You must go on the Naim website and then click on download 4.8 update . Then follow each step. On your windows pc, at a certain level, you will see on your screen the options of different COM ports to choose, like COM 1 or 2 …etc

Done all of the above, and have done it previously on updates.
I’ll probably not bother as I don’t use Tidal and thankfully Naim have a more updated platform for their newest streamers.

Is the Nds your main source ? If yes, I strongly advise you to persevere, because the sound quality uplift with that update is really noticeable.

It might be that you need to download the correct USB driver., for some reason, my laptop did not do it automatically when I had this issue, just go to windows update and look through the optional updates and install the USB driver.

Actually you could/should install it via the link in Naim’s instructions. The driver hasn’t been updated so if that PC was used for firmware updates of this type before, then it should still be fine.

I had exactly the same problem updating my ND5 XS using a windows laptop that had worked fine for several previous firmware updates.

I swapped to a mac mini and the update worked first time.

Since I had not changed anything on the windows laptop, I’d guess a windows update has somehow stopped the driver from working.

My PC hadn’t as it was new since the last time I did an update. I followed the Naim instructions exactly and they didn’t work as detailed by Naim in them, hence my comment about needing extra actions.

If the driver installed ok and showed up in device manager as working and you connected everything up and turned the streamer on before launching the updater program (and not just before telling the update to start), then I don’t know what the problem could be. (You maybe needed to tell your PC to enable NET Framework 2. That wasn’t in the Naim instructions but two or three people reporting in the forum did run into the issue with Windows 10 machines where it wasn’t enabled.

NET Framework 2 was enabled etc, but for some reason, the USB driver needed by my laptop did not download automatically as I said, despite the PC telling me it was. Having encountered similar problems before with drivers, I knew it was likely I had to go into windows update to download optional updates as I said in my previous post, which I posted just in case it could have helped the person having problems. Just because you haven’t experienced the issue doesn’t mean it doesn’t happen.

The USB driver never downloads automatically. You have to download the zip from the link Naim gave, extract the files and run the installation of the driver.

Anyway I’m glad you found a way to do it.

It didn’t on my machine for some reason, why do you keep questioning me? I feel that you are accusing me of being a liar with all your comments and patronising attitude, which feels rude and insulting.

I’m not questioning you at all. I think you misunderstand what I am writing. No doubt that is my fault. Sorry about that.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.