Aaargh! ........ network problems

I returned home yesterday, following an extended period away, during which time the system has been shut down and unplugged from the wall power outlets, and the ethernet cable which runs from my router through to the music room disconnected at the Cisco switch.

The setup is basically … TalkTalk router > Apple AirPort Extreme base station, running in “Bridge” mode, and which runs a separate “Dave’s wifi” network for music, which I need to have a decent signal to allow for iPad control in the music room. This feeds a long ethernet cable to a Cisco switch, which has both the HDX server and the ND555 connected.

Since plugging things back in, the Naim app generally finds the streamer as before, but soon after, I’m getting the “streamer not responding” message, and the music then shuts down intermittently. Occasionally, I don’t get that far, as the app is “unable to find rooms”.

I’m assuming that there’s a networking issue going on somewhere, though I’m baffled as to why that might be, as everything has been restored exactly as before.

I’ve done the complete shutdown / restart of everything from the router, the Airport base station, the Cisco and then the HDX and ND 555, and also in the reverse sequence, all to no avail.

I’ve also had a look at similar earlier topics, and took note of a reply from @davidhendon where he suggests a conflict between the actual IP address of the ND555, and the one the app is expecting to see. I can confirm that the streamer’s IP address, per the front screen, agrees with the one shown in Net Analyser, but I can’t get the app to maintain contact with the streamer long enough to be able to see the address for which it is searching.

I’ve attached a couple of screenshots, showing the connection to the HDX, and another showing the status of the separate “Dave’s network”
Has anyone got any suggestions before I start pulling out what little remaining hair I still have?

Have you tried killing and restarting the app, or failing that deleting and reinstalling. Presumably you can play music by starting it direct from the 555 front panel - assuming that’s possible of course.

Have you tried music via the internet radio stations…does it still do the same?

Hi Nigel,

Yes, I’ve both killed and restarted the app, and deleted and reinstalled it, which might not have been the brightest idea, since, of course, it’s the new version thereof.

At the moment, connection between the Naim app and the streamer is still dropping out with the “streamer not responding” message after 30 seconds or so, but, tuned in to Beeb Radio 6 music, the music cuts out, then restores itself within a few seconds.

As the thread title says … Aaargh!

I’ve just reverted to streaming from the HDX, and, whilst there are choons playing at the mo’, the app seems sluggish to respond on my iPad, whether I’m choosing tracks on the “now playing” page, or moving between pages.

However, I’ve just listened to a complete song without drop outs, so just what might be going on. :man_shrugging:

Since the app is maintaining contact with the streamer at the mo’, I’ve been able to compare the IP address of the streamer, and that which the app is looking for, and they agree.

Song number four playing, and no drop outs … how can it have healed itself with no input from yours truly?

I find all this quite worrying.

1 Like

Very odd. I don’t know what’s going on…

It won’t be the new app. I beta tested it and I’m using the release now and discovery is working fine (and did all through beta testing, not just for me but for all the beta testers).

I wonder whether your iPad is on the “wrong” WiFi network and it’s therefore having to find the streamer across both. That should work but these things are always a little odd. Does n-serve find your HDX ok? You may have answered that question already, in which case apologies.



Maybe having a separate network is adding an unnecessary complication. Our extreme and express work together as one, to give really good wifi throughout the house. That maybe an option worth looking at.

Hi David,

Yes, both the nServe app on my iPad and the desktop version are finding the HDX ok.

Meanwhile, the music continues here, though I’m getting the dreaded “streamer not responding” message throughout.

Sounds like you’ve done all the “usual suspects” stuff Dave, aargh indeed.

I’m guessing you have tried “add manually” and used the IP address for your ND555 in the Naim app? You do that in the Rooms screen, via the + (plus) sign at top right, then scrolling down to bottom for “Add Manually or by IP Address”. Perhaps worth a shot, as a way to totally clear any cached IP address from the system config.

There was a mysterious connectivity problem reported by DrBedlo, where his Core and Nova couldn’t be seen from the app… he reverted from wired Nova to wireless, and reported success. I wonder if you could try that as a temporary measure with your ND555? You could power down, remove Ethernet wire, power back up, and establish a wifi connection on the network ssid you use with your iPad… possibly by near-field communication with your iPad (works that way for new Uniti boxes), possibly by manual data entry. If that works, you know something was fishy with the network connection, and then you could power down again, plug wired Ethernet back in to ND555, power back up and let it establish a fresh wired network connection (take note of IP address again, it will almost certainly be different than the one it obtained on wifi since the adapter address / ID is different). Perhaps this might work for you, with the goal of first getting the streamer sorted out.

I have no experience with a Core or HDX or any other Naim server, but similar “reset and start again” steps should apply there also…

Good luck if you try this suggestion!

Regards alan

Resetting an HDX isn’t a thing actually. And anyway as n-serve is seeing it ok, it’s fine. This does seem to be a Naim app issue. Something to do with the wired and wireless networks not being properly integrated maybe.



My original thinking was that the Extreme would provide a wifi signal to the Express, which lives in the music room, which would then allow for iPad control there, all via "David’s wifi network.

Otherwise, if everything is on the TalkTalk network, I don’t have a strong enough wifi signal in there.

Hi again Dave -

I did not understand your comments on the Extreme (in bridge mode) as implying you really have a separate (wifi) network, as HH suggests. It is a bit unlikely, as it’s harder to configure, and you would have left the Extreme in Router mode, rather than innBridge mode.

Can you confirm that it is simply a distinct wifi SSID for the Extreme (acting as a wifi access point), connecting to your (single) intranet (ie everything is happily on the subnet as shown in your HDX app screenshot)? If so, that should not be an issue, as this setup just helps you log into the “best” wifi access point signal for your listening room.

Regards, alan

Once this is all over, you might want to look at updating the firmware on your HDX. It won’t be anything to do with your current issue, but 1.7b which you are running is still trying to see the defunct AMG metadata service which means you get very slow metadata lookups on ripping and it may grind to a halt bogged down by queued lookup tasks that are doomed to fail. If you contact Naim support, they will send you a CD with firmware 1.7c on it. It’s also available unofficially online, but for whatever reason Naim don’t provide 1.7c via their website, so it’s not easy to find online.



Checking the iPad IP address, and possibly also the NDX IP address, to ensure everything is on the subnet where the ND555 is Located would be a useful first check.

In your iPad, in Settings -> WiFi -> Info you will see what it’s using.

Edit to fix subnet address typo…

We have Virgin Media. Their HH (I’ve tried suing them!!) is in modem mode. The Extreme serves as the router and does the WiFi, working with the Express, which is wired, upstairs. This gives a single seamless network. If you have two networks I think it’s over complicated.

Hi Alan,

Here’s the current settings on the Extreme.

As you can see, the Express connects wirelessly with the Extreme, to provide a signal for my iPad at the rear of the house.

Hi again, Nigel,

Are you suggesting that I should change the Extreme settings to have it acting as a router, though I’m not sure how to put the TalkTalk router into modem only mode?

Yes, if you can set it router mode you can then let the Apple stuff take care or everything else. It’s delightfully simple to use.

HI Alan,

Here’s a screenshot of the iPad info.