Airplay Muso-1 iOS


Anyone tried to use Airplay recently on a Muso with iOS?
Naim app v5.13.1
iOS v12.2

Used to work fine for me, just tried it today and my iPhone X won’t show the Muso as an available source.

Have rebooted both the Muso and the iPhone. Still the same.


The first thing I would try is a router restart.

1 Like

Hi, just tried from the Audible app on an IPAD, IOS 12.2, I can see all 3 Qbs, and successfully connected to 2 of them via AirPlay 2.

1 Like

Ok. I was going to do that then I thought well everything else is working ok with the Muso. But sure enough, a router restart has cured the problem. Cheers!

1 Like

I think there will be others who run into this problem sometime and be glad to see the solution provided by Chris in this thread, so I hope Naim leave it alone!

1 Like

Hmmm…strange. It’s gone again and I’ve hard rebooted everything (router, phone, Muso) but this time can’t get it back.

It does seem to be a router issue. After the third time of rebooting it’s now visible again. Not sure why it’s started doing this though.

And now it’s gone again.

I had a similar problem with my Muso in my all wireless network where the Muso would show as connected to my network and was “seen” as a target for sending music to by all of my devices but when you tried to stream music from any local source (iPhone, Mac or Apple TV) there was no audible output from the Muso unless I moved it to the same floor as my core router.

This all started with Muso firmware update v1.7 for me so naturally I blamed the update. I was mistaken though after working with Naim Support (strongly recommended!!). When I substituted my Amplifi HD wifi router mesh system with an old Time Capsule (Apple’s router and back up drive combo sadly discontinued) or a Linksys Velop mesh system I purchased for testing, music cast to my Muso located a floor away where it normally lives immediately became audible again.

I’ve since replaced the Velop system with an eero wifi mesh system as it’s the only wifi system that functions with 100% reliability for general connectivity and AirPlay here but that’s beside the point. I strongly believe your network is the source of your problem but save yourself some time and grief and contact Naim Support to quickly get to the bottom of this.

Best of luck and keep us posted!


1 Like

Thanks for the detailed reply.
Unfortunately I’m not really in a position to change the router at the moment as I’m in temporary accommodation. It’s a standard Vodafone ‘Hub’ so probably not brilliant. (Vodafone are big players in home internet in Valencia and in fact the only company who could do a fibre connection to my flat.)

May just have to live with it as it will only be temporary. I can always connect the phone to the USB socket. Sometimes it’s just easier to Airplay for the odd YouTube video or random app.

In my case I don’t even see the Muso as an available device though.

I fully understand…hopefully you’ll be in better shape once you’re in a permanent location. If it gets frustrating do keep Naim Support in mind though. They are incredible to work with and got to the bottom of my issue quickly.

Apparently AirPlay even with version 2 is very touchy. Apple has already patched all of their device operating systems since AirPlay 2 was introduced due to connectivity issues with third-party wifi speakers. Odd since you’d have expected v2 to be more robust than v1 since it introduced multi-room support.

I don’t know that hub at all, but I assume it’s some sort of modem, router and WiFi access point combined. You may find you can turn off the WiFi and add an external WiFi access point connected to the hub by ethernet. Or maybe turn off the router and add an external router/WiFi access point.

I imagine Vodafone support would be able to advise or presumably there is a vodafone customer forum?



It’s getting worse - cant even find the Muso ‘room’ at all now on the app.

Back up after Muso power off and on but still without Airplay. Leaving it alone now!


If you can’t find a room in the IOS app, you can make the app have another look in places it isn’t expecting by pulling the room screen down (like you pull down the email screen to check for new emails). This should find your Naim room without you having to restart the Naim device.

Also another quick way is to stop the app (by swiping it off from the open apps screen) and then selecting the app again.



I know about the second thing you mentioned - that does usually work but it didn’t this time. It also took two power off and ons to work but seems stable now.

I didn’t really understand your first paragraph.

Something’s a bit screwy somewhere but no more playing about today.

Vodafone support in Spain is notoriously a nightmare. Even my Spanish teacher was pissing herself when I put one of my conversations on speaker phone for her to listen in. I might do some Googling at some point but it’s not a high priority. Thing is the rest of the internet works fine. It’s only the Muso that I have an issue with.

Thanks for all the comments from everyone anyhow.

Ok let me explain again because it’s a real cool feature added by Naim only a few months ago.

To make the app more responsive, Naim makes it remember where the rooms were (by which I mean the IP address or addresses) last time the app was used. But if the IP address changes, because for example you rebooted your router, then when the app looks at the expected IP address, it may find nothing. So “no rooms found”. You can make it look again, not just at expected IP addresses but at any address on your network by refreshing the rooms screen. So if you have a “no rooms found” message or you see some but not all your rooms, then if you pull the message down with your finger and let go, the app starts a more comprehensive look.

This pull down with your finger and let go doesn’t mean swiping from the top of the screen because that will give you notifications screen instead. What you have to do is place your finger 3 or 4 cm below the top of the screen in the centre and leaving it in contact with the screen, move it down about 3 cm and take your finger off. It’s much easier to do than explain it! But it’s the same gesture that you use to refresh the email list in the Apple email app for example.



1 Like

Thanks David. That all sounds clear enough. I’ll try it next time I get the ‘no rooms found’ problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.