Airplay not work on Mu-so 2nd generation

Hi guys,
I have a problem with 2nd generation Mu-so and Airplay on Mac.
Everything is fine with the Naim app, but if I try to play directly from my MacBook on the Qobuz app or (for example) on Youtube I can’t.
I always get the same error message (see attached image): “Cannot connect to Mu-so”.
I tried to reset it and I have the latest version of both the App and BigSur.
Can someone help me?


Doesn’t airplay need a password? Have you set an airplay password on your Muso?

I have not password for Mu-so

1 Like

Does you Muso have very latest firmware?

yes, of course

1 Like

Have you selected Muso in the Airplay section of System Settings?

System settings of Mac OS Big Sur?


Sorry, sound settings, but looks like you have done that.didnt recognise your screenshot…sorry.

Can you AirPlay to other devices from your Mac? If not then maybe you have your Mac connected to a different network to that of the Mu-so.

I have Big Sur and can Airplay to my Unitistar.

Well, the Mac is listen the Muso as available output device, so some network connection must be present. (And assumingely you have enabled the “Airplay input” on the Muso.)

There is a chance, that an Airplay password is set on the Muso (though in this case, the Mac should ask for it, instead of putting up an error).
You can check, when connecting to the device via a browser; just use the IP address in a browser running on the Mac.

Other things to check: disconnect the Mac from the network (plug cable or switch-off WiFi) or reboot it, if not done yet. Also try to use “Music” to connect, which has a different “Airplay implementation”. (E.g. Music/iTunes can connect to multiple Airplay 1/2 devices, the system preferences only allow 1 at a time.)

I tried to connect with “Music” but I can not, I have this message:
"Cannot select Mu-so Airplay device as audio output. Check your network settings and AirPlay configuration or select another device.

If I use Audirvana I can play on Mu-so without problem …

Audirvana will be using UPnP to connect, which is a different protocol to AirPlay.
You have network issue, nothing to do with the Mu-So or macOS.
Reboot your router and Mac. As asked before, is your Mac connected to the same network as your Mu-So?

Yes, same network.

I tried to reboot, ma don’t work.
I don’t understand … I think is a problem with Mu-so connection.
I try to restet Mu-so again, but I’m not sure will be ok.

Not work on AirPlay with iPad and iPhone.
Not work only.

I had a problem in January and received the following reply from Naim Support. I have simply decided as it was a new ISP supplied router and a new ISP for us, I really didn’t want to go down the route of a third party router, which would also mean us losing our IP landline telephone. Multiroom works just fine, just Airplay doesn’t. Therefore, I now simply don’t use Airplay to my Muso QB2, which is a pain to be frank :

"Hi, thank you for your e-mail. I am sorry you are having some issues with your Muso qb 2. From your description the issue sounds like it is related to your router. The Muso qb 2 uses Airplay 2. The 1.8 update added this to the 1st generation Muso’s. Airplay 2. Airplay 2 is much more demanding on the router.

The original Muso only works on the 2.4Ghz. The 2nd generation Muso can work on noth 2.4 and 5 Ghz wifi band.

You can try resetting your router. This can sometimes help resolve issues. You do not mention which router you are using. In our experience the free routers which are supplied by ISP’s a very basic and not up to the job of steaming high quality audio and multiroom.

We would suggest using a router from a known router manufacturer, picking one from the middle to the upper part of their range. We use a Netgear router in our office and do not have any issues with Airplay 2 and multiroom. "

@Blythe Which ISP do you use?
Normally if Fibre to the premises (FTTP) the box the fibres go into has an output for the phone and one for the broadband that connects to a separate router. In the case of cable the ISP cable router can be set to modem mode, allowing you to use a router of your choice, without affecting the phone line.

Telstra in Australia. Fibre Coax Hybrid.
The coax enters the home and plugs into an NBN (National Broadband Network) modem. The NBN modem is plugged into the Telstra supplied router which has pre-determined configuration for the IP landline phone, the details of which Telstra apparently won’t release for third party equipment, so I’m stuck with it :frowning:

Having said that, it is more than two years since we signed up for the NBN and Telstra may now have more up to date equipment or, realise that one size doesn’t fit all.
They might also by now be able to advise how to configure the IP phone on different, third party equipment.

One solution is to use a wireless access point leaving the rest of the setup as it is.

If this is in replying to me, it’s the router that’s the problem, not the wifi access point.