Albums for a give Artist from dbpoweramp Rip

I am not even sure this is a dbpoweramp issue but here goes:

I have ripped 5 CDs of a given Artist and saved the music files to a QNAP TS251 NAS.
I can see the album folders OK when i go directly to the Albums list.

However, when i request to see albums for the artist, i dont see albums by that artist – instead i see all individual tracks by that artist from the albums that i have ripped – which is definitely not what i want.

I hope the question is clear. If so, can anyone advice how i can change my setup so that when i specify an artist, i see albums under that artist – instead of all tracks by that artist!!

Note that in this case i am NOT using Naim Unitiserve - long story.

many thanks

You need to check the metadata has the “Album Artist” tag populated
dBpoweramp rips normally do this without need to check, so it’s strange to have so many with the same problem.

Thanks Mike, i believe thats how i have it set too – i havent messed about with this at all – so i believe i am using the default options.

any further clues — am i looking in the right place – there are a plethora of settings all over the place!!


Mike, or did you mean this? its populated as far as i can see.

Can you talk us through how you’re browsing to get to this view? What options are you selecting?

Hi Ken, its looks like you’ve set it all up for Album Artist OK, but what I had in mind was to check that the metadata has captured the “Album Artist” tag.
The easy way to do this with dBpoweramp is browse the album with your 'pooters ‘Explorer’
Highlight one of the album tracks, right clip on it & a popup window appears which includes a dBpoweramp line “Edit ID-Tag”
Click on that & you get a screen (see pic) & you can see if indeed the Album Artist is actually populated.

The next question is what UPnP media server softaware are you using on your QNAP

Ken, are you using Asset as your upnp server? If you are not, it would be worth doing so. And if you are, your browse tree may be set up differently to normal. You may want to set it to default and then start again.

The Album Artist metadata checks out.

Now what UPnP media server software are you using on your QNAP

please advise on how i get to see the UPnP media s/w. All i can see is this, but i could be looking in the wrong place. i dont really fully understand the innards of this NAS.

I dont believe i am Nigel. I assume this is something i would need to explicitly install?
I was actually pleasantly surprised that i could see my QNAP upnp server from the ios naim application on my iPad – and not only that – that i could actually rip with dbpoweramp and move the ripped fields to the multimedia directory there – and then play the albums!!! i was impressed!!! I want to continue to keep things simple – all i want is a different and more sensible presentation of my albums – so when i browse by artist, i see albums by that artists – and not all individual tracks by that artist – this seems extremely daft to me!!!

thanks for chiming in on this Nigel…

QNAP has a built-in UPnP server, but I don’t think it’s very good. In any case, most people here use Asset or Minimserver, so you are much more likely to get help for these. Asset is a bit simpler to set up, while Minimserver seems to work particularly well with the tags that are often used for classical music, so some people prefer it.

I’d recommend to try Asset first. You can install it as described here (but before that, you have to download the correct package, as mentioned at the start of this page):

OK you have the QNAP software, I’ve not used it as I’m not a QNAP user, but seems its not well regarded.
I would look into trying Asset UPnP, its very simple to install & set up & so versatile & easy to personalise. For me on my Synology NAS, there is nothing better.
Maybe someone who’s a QNAP user with Asset is better able to help & advise than I am.

Miniserve with default settings on QNAP.

Album folders are randomly dropped into Multimedia folder. Media server, miniserve or Asset sorts everything out.

I think Asset has a better user interface than miniserve, but I couldn’t figure out how to stop it from constantly (or so it seemed) scanning the multimedia folder looking for changes???


Are the 5 albums in a single folder, (labelled the artists name). Perhaps you could try getting rid of that folder and have the album folders randomly saved in multimedia.

Its described in the user manual

In your browsing edit screen … there are 2 lines

  1. Detect and Catalogue New Tracks
  2. Forcibly Check for New Tracks Intervals
    (enable only if tracks are not detected automatically)

You can play around with these, or leave them disabled

FWIW I have artist folders with albums inside (it would be a right mess otherwise), and using Asset I have no such issue.

1 Like

Thanks Mike.

I’ll give that a try.

Ken isn’t using asset, he’s using a qnap media server. (I think). Might be worth a try.

I’ve been streaming from a Qnap NAS for 10 years. Every album is randomly dispersed within the multimedia folder, the media server doesn’t care where the album folders are located, it will find them wherever they are.

Rip it, copy to NAS and forget about it. Simple.