App is very slow to find rooms when changing access point

Both of PW42’s WAPs are BT products, so possibly they can be configured as ESSID, but I wonder if the powerline connection will put the kaibosh on it?
Also, the HH3 being older, I believe it doesn’t support 802.11ac as the HH6 does, and while this shouldn’t stop it working, in practice, connections between ac devices seem in my experience to be much more robust. So I wonder if replacing the HH3 with a current BT branded range extender would help. Then if you’re really lucky, it might even connect wirelessly without the powerline adapter, although that might be pushing your luck a bit too far.

In my case, I have a common wifi network name across the router and the secondary AP (an Apple Airport). I am curious as to why the HH6 was nothing but hassle, in case it can help other owners.

The user settings in my BT Smarthub 2 are identical to those in the HH6.

HH6 + Apple Airport = considerable hassle
Apple Airport + Apple airport “just works” (as one would expect)
Smarthub2 + Apple Airport “just works”

There has to be something going on with the Smarthub 2 that is addressing a problem with the HH6 ?

FWIW I also have a common name across the router and secondary AP (as recommended by my dealer and rather grudgingly changed by me to comply!)

It’s possibly because the HH6 is more advanced and carefully manages multicast group control for efficient Wifi and Ethernet host utilisation. Remember the HH6 supports advanced services like multicast IPTV.
So it’s more likely something NOT going on with the old Smarthub that you are seeing.

On your HH6 there are specific settings to aid backwards compatibility with less capable equipment and interconnectivity.

Firstly the ‘Separate Bands’ option should be off, and combined bands should be ideally enabled on other cooperating Wi-fi access points. If you find your clients struggle with this, you can toggle, and effectively disable band optimisation. Again ideally match this to any cooperating access point.

Secondly the HH6 has three modes of Wifi compatibility operation. Mode 1 is the default and provides the most capable Wi-fi performance from the HH6 including power saving, stream aggregation etc. You can setup upto mode three, which progressively disables advanced features to help interworking with older equipment (like the Apple products) but at a cost to performance. Your cooperating Wi-fi access points should match this.

Finally the HH6 has advanced multicast group control (to support more advanced BT internet services). If looking to cooperate with Apple Airport products, I would disable the IGMP snooping on the Apple products and rely on the HH6.

Good luck.


Thanks @Simon-in-Suffolk for the further commentary. Trust me, I explored everything including all the points you make and my HH6 set-up is precisely as you recommend: separate bands is off, I tried all the wifi modes, and IGMP snooping is off on the Apple airport. And yet the HH6 does not work properly when an iPad transfers back from the secondary AP to the HH6. The iPad has wifi/internet just fine, but it does not have device discovery. At first I thought this was an issue with Linn until I realised other client types also lost discovery.

Simply switching the HH6 for a Smarthub 2 with all settings preserved, fixed all my problems. Good luck to the OP in fixing his.

yes, it’s interesting to consider that my problems might also have been solved by swapping out the Apple AP. In my case I happened to receive a Smarthub 2 for free (as part of BT’s efforts to give me Ultrafast broadband, which turned into a fiasco that has resulted in me getting the same speed for much less money, but that’s another story). For me another bonus with the Smarthub 2 is that my Synology NAS is able to configure the port forwarding for WebDAV, Photosation etc. With the HH6, even with upnp enabled, the NAS’s attempts to configure port forwarding were always rejected, and I had to do it manually via the router’s management page. Not so with the Smarthub 2, which is proving to be less hassle all round.

For some years now I have been using an Apple AirPort Extreme, with Airport Express to extend wireless coverage, and it was very simple to set up, and reliable. I recently removed the Extreme, and continued to use the Express to extend the coverage from my Sky router. Although this generally works well, I have not been able to get smooth handover of mobile devices as I move from the range one WAP to the other.

I have been looking at the Smart Hub 2, and indeed that is a recent router as wellwith some nice options such as 4G backup, and optimised seemingly for connecting mesh solutions (though don’t know if it’s BT’s own).
So in short if it’s all working with you with Smart Hub 2… then great…you have a capable device there.

Hi Simon,

Thank you for your continuing help.

I have tried all those options (where relevant/possible). No Apple is involved, it is all Windows and Android.

I tried Mode 2 as well.

None of the changes made any difference to the behaviour.

I will have a look at the logs later to see if that sheds any light.



There seems to be a pattern looking at the logs. The last attempt was fairly typical.

Connected at 2:30. Closely followed by a DHCP confirmation of request and a list of DHCP options. At 2:31 Reports of eth4:IGMP join received for 2 groups. This was repeated at 2:33 and 2:35. At 2:36 the device disconnected and immediately reconnected.

At 2:37 the Core and Nova appeared. The Qb had been visible througout.

Does that help at all?

The multicast group of interest here has IP address, which is the SSDP group address used by UPnP discovery.
You should see joins to it on the interfaces that have devices using it…this will include Wifi interfaces.

However if you have disconnect and reconnect, that looks like roaming, which is good… I guess the thing is the time between disconnect and reconnect when roaming… and whether the host is able to smoothly roam.

To be honest, if you require roaming the simplest thing to me is disable the HH6 wifi and then use WAPs designed for the job such as a Ubiquiti WAPs that you connect together via a switch… that works perfectly and roaming is invisible.

The Smart Hub2 also has a roaming option via its mesh option, which is an alternative, though I haven’t tried that myself.

Hmm. I only have two groups listed i the log and

As you probably realise, I fall into the “blundering around in the dark” category. :slight_smile:

Sorry but the BT hubs are absolute junk and should be binned at the earliest chance, and replaced with a proper modem/router combo or separates.

The amount of problems we have solved doing this is almost 100%.

I couldn’t disagree more… if using BT services on VDSL, the amount of people I come across who have issues with performance and operability using third party router/modems is not insignificant. There is in my opinion a mistaken view that if use certain consumer brands that their products must be ‘better’. If using lesser ADSL services then sure use what ever… but on VDSL best use the provided modems…
Peeps really really under estimate the importance DCE/DTE modem matching, for reliable optimum VDSL (Superfast/Ultrafast) performance. Further if using BT services and you use a third party router/modem that brings unreliability you will be performance/speed capped by the BT management system.
The HH6 and above are advanced pieces of equipment that are needed to take advantage of certain BT services like IPTV. Sure occasionally there can be firmware upgrades that can bring issues, but on the whole the automatic upgrade process works well. I also would be inclined to disable the Wifi and use separate cooperating WAPs working as an ESSID or mesh.

1 Like

Nowadays, Openreach ship standard modems that are used on huwawei and eci cabinets so matching is not really the issue.

It’s the inferior components they use. Bare minimum.

They don’t spend money on stuff they are giving away for free.

I’ve decided to leave well alone. The current set up works well for all the various uses I put it to and is fast and rock solid reliable apart from this issue. But the the issue is minor and falls into the “mildly irritating” category. It would be nice to solve it but I am not going to chuck money at it nor disturb something that is otherwise working well.

Thanks for all the suggestions.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.