App on desktop

For Linn Kazoo to work you need to install BubbleUPnP server somewhere on your home network, it could be on your Mac or NAS or RPi etc. Once installed you configure it so that your Naim streamer becomes an OpenHome end point. You can configure your system with BubblrUPnP server to auto start so you only need worry about starting Linn Kazoo when you want to stream music.

I have Linn Kazoo installed on my Mac but it only shows my Linn DS streamers. I’m don’t really wish to install lots of software and get even more confused than I am.
There are many occasions, whilst working on my MacBook, I really wish there were a way to operate my NDX2.
Please Naim, a simple interface would be lovely :blush:

1 Like

I tried switching to landscape from the flyout menu and all it did was rotate the portrait mode window containing the Naim app round 90 degrees. The text in the app was vertical rather than horizontal so not a lot of use unless I tilt my head at 90 degrees as well :sweat_smile:

Perhaps whilst tweaking you managed to fix the orientation? I am sure there must be a way to do that from within android. I guess if its fixed in the android emulation then rotating in windows will cause what’s happened.

Mine works perfect, and infact if I open say roon within it, it rotates to portrait because that’s the only way roon works, then returns to landscape when I leave roon.

Don’t give up on it. Even though it has juvenile pictures when starting it up!

Also goto the settings cog, then interface settings. Turn off ‘Landscape Mode’ and turn on ‘Remember size and position’

Then restart it.

I’ve done all that but this is what I’m getting, infuriating! :joy:

Hi Blythe,

can you describe what isn’t working for you? I don’t have a way to access my presets, but I can browse to ‘Internet Radio’ or ‘Recently played’ (presets will usually be among those), or ‘TIDAL’ and then there’s ‘search’ in the top right corner.

If you tell us exactly what isn’t working I can try to figure out the issue.

All I can suggest is uninstall it and re try? Not much use to you I know but it does work!

ONe other thought is check through the settings to see if you can emulate it as a tablet rather than a phone?

I haven’t tried in, but with the new Mac software you can display your iPad or iPhone on your screen and use the Mac to control the App.

I think that is only for the soon to be released Mac’s with the new ARM processors and not the existing Intel versions :grinning:

Thank you n-lot,
When I start Linn Kazoo on my MacBook, the middle top shows the selected streamer or “room”. When I click on that, it lists all available “rooms”. Mine only shows two options; Linn DS A and Linn DS B (I have two for multi-room duties).
The Naim NDX2 isn’t listed, nor my Uniti Atom or Muso QB.
Therefore, I can’t control anything of my Naim systems.
If I go into the Kazoo settings, I see the Naim HDX & Uniti Atom listed under “Media Servers” but of course that’s I resume, if using the Atom as a source and not as a player.

Hi Blythe,

as you replied to my message about the web client I thought that’s what you were referring to. As I don’t have any Linn equipment I unfortunately can’t help you with Kazoo. Perhaps one of our other members can?


1 Like

Kazoo will control openhome compliant renderers. Linn streamers are already openhome compliant. Out of the box, Naim streamers aren’t and I’m not sure why. But it is really very straightforward, even for a network numpty like me, to install Bubble UPnP somewhere on the network (NAS in my case) and make my Atom openhome compliant.


1 Like

Yep … as per my previous suggestion

You must have three things installed;

  • Linn Kazoo
  • OpenHome
  • Bubble UpNP

It won’t work without Bubble! :grinning:

1 Like

You only need the first and third items on your list.


1 Like

Thanks for your help.
I had a quick look and it appears I have to install Java to be able to install Bubble, so I installed Java on my NAS.
I then downloaded Bubble and manually installed it on my Synology NAS.
I have also enabled “User Home Services”.
How do I now make my NDX2 and Uniti Atom “Openhome compliant”?

Desktop app is essential for me. One of the (many) reasons I use Room.

I’ve now managed to get it working!
Not only did I have to install Java and BubbleUPnP but I then had to go to the NAS IP address and add the correct port number to the IP address to access the Bubble configuration page, in my case
Within that page, I could select from all available players including TV’s and anything else listed.
However, I still couldn’t get it to work until I realised there seemed to be two seperate listings under “Media Renderers” for an NDX2. One showed a USB device and the other a different icon.
I selected the USB looking one and ticked the box next to “Create an OpenHome renderer”.
Then when I opened Linn Kazoo, my NDX2 was listed but when I clicked on it, I just had a swirling thing whilst it tried to do something.
While it swirled, I tried clicking on a menu button in Kazoo and could then see my servers, so I selected one and hey presto, it worked!
I wouldn’t exactly say it’s as straight forward as most of you suggested it should be!
Thanks anyway, as I have got there in the end :grinning:

Tidal Connect will solve this mess. At least for those who have new enough equipment to be supported… NDX will not support it so you’d need to get the NDX2. Or the cheapest way get a Chromecast Audio and connect optical out into your NDX then use Tidal native apps on Mac desktop or iPhone.

1 Like

But will using Tidal Connect (whatever that is) allow me to access all of my ripped CD’s on my server?
Anyway, as I can now use Kazoo to control my NDX2, I feel inclined to leave things alone!!