Asset on QNAP

I updated my QNAP NAS to the latest firmware and when I tried to stream from it the Asset UPnP server wasn’t found by the Naim app. I tried to access the Asset config page but no joy. Checked that the NAS was up and running and yes I could see my music files from Windows File Manager. I then logged on to the QNAP and looked in the message centre where I saw this error message:

Asset has an invalid digital signature. The app has stopped and cannot be installed on QTS. You can remove it in the App Center.

I then went to the app centre where the Asset app was visible but greyed out. Thankfully it gave me the option to start the program and it is working again, phew!

1 Like

Yes I’ve encountered that. Bubble upnp which I use to make my Atom Openhome compatible and Twonky also appear not to have valid digital signatures. I think this has been raised with the folks at Illustrate but not sure how things stand at the moment.


This digital signature business is a two edged sword. It’s a good idea to warn about apps that may be harmful but it is mostly being used as a tool to create an Apple style “walled garden” that forces you to choose from a limited range.
I have just bought a new laptop which came with Windows 10 S. The “S” part restricts you to only Microsoft approved products as I found when I tried to install Chrome, hardly a dubious app! It’s fairly easy to change back to open Windows but you have to get an app from the Microsoft store to do it.
I also run Asset on Qnap and had to do the same as the OP - this trend is very disturbing and benefits the manufacturer way more than the user.

There is a thread on this subject on the dBp (Asset) forum.
One of the guru’s, PeterP, posted …

This is once again a bug in QNAP firmware:
'- Asset doesn’t have an invalid signature, it’s not signed at all.
'- It didn’t stop Asset from installing , it stops already installed Asset from running.

That said, I have been trying to obtain a digital signature from QNAP with no success (no response at all to contact forms or emails). Just keep toggling the switch if Asset doesn’t work after an update.

To install, open QNAP app center, settings (gear icon in upper right corner), check “Allow installation of applications without a valid digital signature”.

The digital signature stuff is the same with Synology
But its a lot less hassle as the no signature popup warning box has an “install anyway” option


This is turning into a major pain in the neck. I thought starting the app would stick until the next reboot of the NAS but no, it just keeps stopping the app.
I’ve opened a ticket with QNAP to have a moan about it, let’s see if they say anything useful.

I’d say it’s at least very debatable where the bug is

Definitely a QNAP bug. By all means give me a warning I’m about to install an unsigned app but once I say install it anyway that should be that, it shouldn’t just stop the app running whenever it feels like it

True, but a nonchalant “we don’t sign our packages” is stupid as well. Operating systems doing weird things to unsigned packages is not new, and there’s a reason for why they should be signed. If we didn’t sign our Windows and Mac packages for our product at work, we might as well just not bother producing anything because it wouldn’t run on most people’s machines, or get deleted immediately after download, or run only after jumping through major hoops most people don’t understand. Just sign them, it’s good for everyone.

But the folks at Illustrate say they want to sign their app but QNAP aren’t playing ball. Is it entirely down to Illustrate to sign their app or do they really need input from QNAP too?

If this really is the case I take everything back, but I don’t know what the problem would be unless there is something very odd about QNAP. Normally you just sign it with a certificate whose root certificate is accepted by the target OS.

Interestingly MinimServer is correctly signed in. Not sure whey there’s a difference.


My QNAP buddy says that … open QNAP app center, settings (gear icon in upper right corner), check “Allow installation of applications without a valid digital signature” seems to have fixed his .

OK I’ve set that option, let’s see if it makes a difference. It is becoming a bit of a pain in the neck having Asset randomly stopped from running.

I also have Serviio running on the NAS for serving up video and it is having the same problem.

I have both minim and asset running on my QNAP server through manual installation without any issue. you just have to enable “non qnap” packages and it will be installed

I tried to update Asset to 7.3 on my QNAP TS221 yesterday, I usually perform a manual install but this time I can’t navigate to the down loaded Asset file, the “Browse” button in the manual install window is there but does nothing when I click on it. Computer is an iMac running Mojave.
Dos anyone have any ideas, struggling with this?


That’s working fine here. Maybe try a different browser or device?

The app is installed just fine, it is just that QTS keeps stopping it.
That said, I ticked the ‘allow installation of unsigned apps’ box and so far it has been fine, fingers crossed

I think this was the right thing to do. Asset on my TS-269Pro answers as fast as Minim to queries. I find that the interface is fancier than Minim and it is far less expensive at the moment… this is why I use it.

Asset 7.3 stopping - suddenly … this happened to us, this morning, mid-way through a play queue. Very annoying!

I’d upgraded the QNAP to last evening - all good - and used Asset for 3 selections; then, this morning, my wife selected three albums and it was during the last of these that it stopped.

Luckily I’d read this thread a few days ago and it guided me where to look. Strangely, though, when I installed the QNAP Security Counselor App a few weeks ago I’d identified this setting and chosen to Ignore. So had the firmware update re-set this? Answer: No … on checking it was still set to Ignore.

I have restarted Asset manually … so far, so good … but if this is a recurring issue then we have a problem!

We can only hope that Asset and QNAP are on speaking terms … presumably there is a fee involved. :grinning:

Asset has completely disappeared here, and took all of my music with it. My music suddenly stopped this morning. I can’t find the Asset server in the Naim App. How annoying, i’m not IT savvy neither. Time to fire the lappy up then…:face_with_raised_eyebrow: