Asset on QNAP

'morning @Stephen_Tate , have you set your QNAP to allow apps without a valid signature ??

… open QNAP app center, settings (gear icon in upper right corner), check “Allow installation of applications without a valid digital signature”


Hi Mike, thanks for your kind response. Yes, before reading your reply, and me being a bit dim when it comes to computers, and a bit gung ho, i un-installed Asset, tried to re-install it and failed. Then came back here, read your helpful reply and did as you suggested. I’ve now managed to re-install Asset 7.3 back onto my QNAP again. Thought i”d messed up big time. Phew!

P.S. One other thing here, when i tried to login into my QNAP via Windows i had a thing pop up saying that it was insecure, and that i was open to attacks and having my passwords and other personal information stolen. Not sure how i correct this?

1 Like

Hi again Stephen, I’m not a QNAP user, I’m Synology & it too has the same issue with digital signatures but when installing new software a Synology pop up warning shows telling you it does not have a valid signature, but it also has an ‘Install Anyway’ option. I do this more often than most as I test the beta stuff. Its always worked & no problems.
I helped a mate who had the same Asset problem with his QNAP, it worked as you found, & its seems to have stayed working OK.
I found the answer on the dBpoweramp (Asset) forum.
They are sounding a bit irate with QNAP as they do not respond to any communications.

1 Like

Thanks again Mike. All working again. Yay!

1 Like

same just happended to me when I tried to use NAS with Asset

spoke to my dealer
some screen shots of action

go into APP Centre on QNAP

top right corner click on Cog

tick box re digital signitures

RIGHT I’M OFF TO PLAY MY LP12 !!! - Many thanks to Phil @Cymbiosis for the 2 minutes of guide

1 Like

Re the Windows message about being insecure. Suspect this is Windows/Anti-virus advising that you are using standard ports (5000 http and 5001 https) to gain access to your NAS. They can be changed but not sure how beneficial this is. I get similar messages from my NAS (Synology). Happy for others with more knowledge than me to advise. Might be useful to start a new thread?

See my post above, this is absolutely normal, its nothing to do with Windows or virus, its a Synology popup window. Synology recognise that some software will not have a ‘signature’ & have provided an option to “install anyway”.
I assume you trust Illustrate Ltd’s Asset software? So just do it !!!

1 Like

Wow, not really sure what’s going on here, but local streaming is really sounding amazing. Obviously something else is at play here that i’m unaware of. I put some cans on earlier, turned the volume up and thought the music was coming out of my main speakers, such is the spread of sound. Unbelievable.

This is becoming more a problem than an irritant! Yesterday morning I found the App had been stopped so had to manually restart.

This morning, prior to setting up a queue of music I checked and the App was running. Second choice, approx. half-way through the first movement of Mendelssohn’s Violin Concerto the App stops … no more music.

I don’t want to drop Asset as I find it much easier to use than MininServer but this can’t continue … especially as my NDX 2 is only 6 weeks old :disappointed:

Have you set your QNAP to allow apps without a valid signature ??

… open QNAP app center, settings (gear icon in upper right corner), check “Allow installation of applications without a valid digital signature”

I did this over a week ago and it has been fine since then. The option is a bit of a misnomer though as it looks like it also applies to applications that are already installed.

1 Like

Thank you! I had thought I’d covered this by selecting Ignore in the Security Counselor / Basic Security Policy page … but it appears that this App does not talk with the App Center.

Fingers crossed this issue has been resolved … and, again, many thanks :grinning:

1 Like

I just ran into the problem of Asset & Bubble not staying running b/c of the lack of digital signature. Thanks @Mike-B for the heads up on the fix.

Is it just / in particular the Immaculate Collection? It was the first album recorded in QSound

1 Like

Just to report that I updated from 7.2 to 7.3 earlier today. I updated while music was playing and it didn’t miss a beat. The instructions are explicitly clear about the steps to follow, including ticking the box about certification before updating. Maybe Illustrate have updated things but either way, it worked perfectly.

Interesting. Thanks. :slightly_smiling_face:

1 Like

Illustrate haven’t made any changes, they are saying its QNAP that need to do something to make it clear/easier for the user. They are frustrated they don’t respond to communications from them.
I just installed a new Asset beta on Synology, the alert popup window with its clear script & OK to install is simple.
I get the same type of warnings with other apps & software

On a related subject: Illustrate have just released 17.6 dBpoweramp

It’s only a matter of following instructions and ticking a box. I had it updating in less than a minute and if I can do it, anyone can.

I noticed that dbpoweramp has updated, and I must get it done sooner rather than later. Thanks for the nudge.

1 Like

I think the problem is that for me at least I did that when I updated to 7.3 a while ago but the last firmware update blanked out the check box. So although the 7.3 app was already installed it kept being stopped by the OS until the box was checked again.

I had the same problem, the check was removed from the box so I wasn’t expecting the app to stop running.