Asset shows multiples for all tracks

Hi I was bored to today so decided to try uPnP out again this time using Asset. I cant work out why its showing each song about 8 times in every album I search and no durations. Anyone any ideas cant see why it would do this.

What else are you using ? Roon ?
The album has 11 tracks & your view is listing numbers in the 50’s
What did you touch to load the album, I’m thinking maybe a double touch on one of the three dots.
Have you tried clearing cache’s & trying it again?

How does is look on your PC/MAC through Asset?

Yes I use Roon normally and no issues therr. Looks the same via every control app. All I did was install on my QNAP and point at my music.

It looks like its also adding all the snapshot directories which are hidden. As there are 14 of those and it looks like each track is repeated 15 times so 14 for the backup and 1 for the actual file. This is a bit rubbish if it cant deal with how the qnap works. Is there any way to ignore specific folders?

I’ll duck out if you’re using Roon, loading snapshots is not in my keep it simple world. I’m using straight Asset on Synology, but have seen multiple track loads when using the three dots. Why not try without Roon?

Roon makes no difference to this its a completely different system that does not interact with other programs its also not running on the NAS. This is Asset being written badly for QNAP if its populating the library from the special folders that are actually hidden… Having snapshots is part of the QNAP operating system and is a quick easy way to recover accidently deleted files nothing special about it.

On any server I’ve used, including Minimserver, Unitiserve and Roon, you tell it which of the various folders it finds on your network you want it to access, and it only scans those folders. I don’t use Asset, but presumably it does something similar, so perhaps you have inadvertently set it to access more than just your music library.

Hi, I use Asset alongside Roon on the same library.
And Asset will scan the directories you specify in its configuration.
But it will start at the top of the directory and scan down through the folder system, it won’t scan up the directory structure.
If there are snapshot instances within that directory, as child folders, it will scan and index these.
I suggest you either point Asset down at a lower directory in your NAS, one that doesn’t contain any snapshots or reorganise your directory structure to have the snapshots in a different directory.
So on my NAS (ReadyNAS) Snapshots are taken at the root level of a folder structure. My mount point is then into that directory structure, and I have multiple directories that are listed

So ‘Music’ is the main folder, ‘DSD’ & ‘MQA’ are folders for format duplicates, for evaluation/comparison, and then ‘overflow’ is a folder on another NAS, when my main NAS is full and I am in the processing of buying new disks and expanding the NAS volume.
Hope this helps.

1 Like

Check the settings in Asset.
Click on ‘Edit Advanced Settings’:


Ensure the file location for your Audio Tracks is set to a folder which only contains the original tracks, not any backups. (As it says in the information, any sub-folders are also searched.)


If it is Roon related, although I doubt it, I can’t help.

Yes, I worked this one out last night. I had to create another parent directory and then move all of my library into this new folder and point it to that. Annoying as all my music was just in the root level as I dont separate into formats or genre as Roon does all the sorting I need so I dont need an organised folder structure. Did not really want to alter how it all lives, but hey done now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.