Asset UPnP 0 albums

I am running Asset R4.7 on a Raspberry Pi, with a library of approx 1600 albums. After a recent addition and rescan the count on the home screen shows the correct number of tracks but 0 Albums.

When I browse there are artists and albums missing.

I tried a complete rescan and restarting Asset, and rebooting the Pi, but no change. Missing artists and albums are definitely on the NAS and visible in another UPnP server running on the NAS.

This did happen previously and was caused by the storage on the Pi filling up, but I cannot remember which files I removed in order to resolve.

Any suggestions greatfully received, otherwise I will have to rebuild the Pi.


First, why are you using an old copy of Asset. The current version is 6.6. I would get that installed and see what happens. If no joy, post your issue on the Asset forum, you may get some help there. I suspect the first thing they will say is, update to the current version, then we can talk. I run Asset 6.6 on a RPI 4, no issues like that for me.`

Thanks dknk, I guess I never upgraded because it just worked, and there did not seem any reason to, I only use it to serve files from a NAS. Anyway I upgraded now to 6.6 resulting in 2 versions for a while.

Anyway I solved the issue, before installing 6.6, the Linux music player deamon is writing an mpd.log file every few minutes and had consumed all spare storage. So I added a crontab to delete it every week to stop it growing.

All the best

The other option is to edit the global config file /etc/mpd.conf

log_file syslog
(set log file to syslog)
log_level default
(“default” is minimal logging)

Normally, unless manually changed, syslog gets rotated by the cron system daily.

But, your method will work too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.