Asus mesh and Naim Muso

I have a Naim Muso 1st Gen and an Asus AX92 mesh system and my naim muso will not play airplay or be recognised in the app when my iPad is connected to the asus network but will connect to my virgin hub no problem and play, the reason I have a asus routr(s) is so I can use a VPN but this is not the issue as I have tried turning the vpn off and I also need the virgin hub on to connect to my TiVo box, some of my Ring devices have recently had problems saying weak connection on setup and ultimately not connecting I also previously had the Naim working on my Asus system but has not worked for a while not sure why this is the naim will play radio when connected to asus system even though in the setup process when trying to connect to asus it says an error occurred and I also have the naim hardwired to an asus router via Ethernet although it does not seem to recognise this as still works perfectly at the moment but only on virgin hub connection I have already spoke to naim tech dept. Who ran tests and could not get to the bottom of it only that my naim was connected to internet due to light at the front being white anyone has any ideas I would love to hear them?

Are you running the Virgin Hub in modem mode?
If you are using another router, ie the ASUS, the virgin box needs to be set to modem mode, allowing the ASUS to take on the DHCP role.
If your Virgin Hub is still on router mode, then you have two DHCP managers operating and this causes IP allocation issues.

If he can connect to the virgin hub then no its not in modem only mode.

That’s my guess, hence my post.

Yes my virgin hub is not in modem mode as the TiVo box needs it although not sure if the modem mode would help as it still seems to happen to devices that are out of range of virgin hub but not asus system

I also do not think my modem mode works correctly as I have previously had it in modem mode but my TiVo box still worked even though it needs it not in modem mode now after I reset the virgin hub.

To add to my previous posts as said I supposedly had virgin hub in modem mode and naim still had problems and the problem with the naim has gradually got worse over time from losing connection with my devices and then not being found in the app although white light at front still showed naim was connected to internet, the strange thing is I have had it working perfectly with asus routers but that was over a year ago when I first got my routers?

Sorry mate, you’ve lost me now.
Forget that things may have worked before, just change virgin box to modem only mode and link it to your asus router with a single ethernet cable. Run all your wireless kit from the SSID your Asus provides and report back if you can.

Sorry that I have lost you but I can’t put my virgin hub in modem mode without loosing my TiVo to box and I have already retried putting the it modem mode it did not work thanks

You just need to ensure that only one device on your network has a DHCP server running on it. It doesn’t necessarily matter whether this it your router or a network extender (mesh or otherwise). Problems sometimes arise when a consumer device does not allow you to disable its DHCP server so you can’t avoid having more than one running at the same time.
Whether or not this is actually your problem is hard to say, but either way it is good practice to address this.

We had a Virgin router in modem mode for about five years and the TV box worked absolutely fine. All the box needs is to be able to connect to the internet, which it can do quite happily with another router such as your Asus. You connect it to the Asus and put the Hub into modem mode.

1 Like

The point Im trying to make. My Virgin TV box works happily plugged into my TPLINK mesh router… which is served by my Virgin Hub in modem mode.

Exactly. If you have two wireless networks and two boxes assigning IP addresses, you are asking for trouble. That’s why setting the Hub to modem mode is so important.

I have TiVo and a virgin hub.

They do not communicate with each other and TiVo works fine.

This is not correct . The Virgin hub will run happily in normal router mode. I switch off the wi-fi in the Virgin hub. I also have a Tivo box and Asus router connected to the Virgin hub.
(If you change the hub to modem mode it uses a different base IP address …100… which is probably why the Tivo box then does not work. This is also why I use router mode.).

Do you have any other boxes in your Asus mesh?
Is your Asus also controlling DHCP?
Are you broadcasting 2G and 5G from the Asus and is the MuSo connected to the right one on the Asus.
Is your Ipad on the same broadcast SSID as the MuSo? It maybe connecting but on a different band.
Virgin also introduced a band sharing feature recently - I declined - Is this causing an issue?

Can you connect a wired connection from the MuSo to the Asus? Much better.

The V Hub may work in router mode but it is not the recommended method, as other posters have also stated. The Virgin guide itself recommends modem mode if using a 3rd party router.
It may not be your experience, but it is mine and others, so do not say its incorrect in such a blunt manner.
Im just suggesting a course of action to assist the problem. Even the OP has said that his Tivo works with his Hub in modem mode.
Anyway, enough on this…Chick…paul_C will sort this for you.

The V6 box will certainly work fine with the hub in modem mode. Whether other Virgin boxes won’t, I’m not sure.

Posters were suggesting it did not work/had to be in modem mode. I was stating this is incorrect.
My Asus box works fine in router mode as did my TrendNet router for 15 previous years.

So this is not the cause of the OP problem.

1 Like

It may very well be the OPs problem, having the virgin in router mode and the asus in router mode is not a good thing.

Either put the virgin in modem only mode or make the Asus a simple Access point, and turn of wifi on the virgin.

Hi yes I have a more upto date diagnosis I can confirm that I have just put my virgin hub in modem mode and the TiVo did still work however this is only till there is an update or if not wishing to use catch up services but regarding the virgin hub in modem mode and just tried minutes ago the Naim would still not connect to my asus system the app finds the network ok but then after trying to connect it says an unexpected error occurred I have just reset my virgin hub and put back to wireless for now as it is the only way I can connect my Muso and playlets perfect on virgin hub I will also say some but not all my ring devices will not connect to asus either and also says my network is weak which is not true I have ran speed test and all iPads, computers and phones connect flawlessly to my asus sorry for the long winded explanation and perhaps this should be on asus forums but since my Naim is one of the very few devices it happens to thought some wizzes on here could help