Atom -- Odd Router Issue

Hi! I recently picked up a new mesh router – a TP Link – and it works great with every device in the house, except my Atom. From time to time, the Atom disappears from the network, and the only way to bring it back is to unplug it and plug it back in; then it finds the network just fine. Is there some setting on the Atom that may be interfering with continued recognition on the network? As I said, this is the only device that presents this problem, so I don’t think it is the mesh network.

Any ideas appreciated! It is annoying to have to fiddle with the plug to make the Atom work.

Is the Atom set to sleep?

How did it connect before?

Do you have any switches in the network?

Network issues are often down to the network equipment rather than the connected devices I’ve found.

I have various switches connected to ethernet and on some the attached devices are rock solid connection wise, on others it can be hit and miss.

The TP Link is what’s changed so I’d wonder if that is causing the issue somehow.

Potentially the old Atom local IP address has changed but maybe the Naim app is still seeing an older one - what happens if you quit and restart the Naim app. (Naim Focal app for the purists - sorry!)

Thanks for asking these questions! The answers are below:

— Is the Atom set to sleep? I am not aware of a sleep setting.

— How did it connect before? It was connected to an orbi mesh network of a few years ago. I did not have trouble with the old network, but needed to extend it and went with the modern generation of routers.

— Do you have any switches in the network? No switches. Just 4 routers.

I did suspect the TP Link was the issue, but came to notice over time that every other device connects, and stays connected, just fine. The Atom is the only device with a problem, so I suspect there is a setting that creates instability. Quitting and restarting the app has no effect, and neither does rebooting my iphone. The only sure-fire fix is to unplug the atom. If I don’t unplug and try to reconnect to the network using the front panel settings menu, it will see the network but it will not connect to the network.

So strange!

Since you mention IP address, I am going to try turning DHCP off in the naim app network settings; maybe that will cause a change?

Suspect it’s best left on unless you have configured a static local IP in the router based on the wi-fi/ethernet MAC address, potentially no harm trying unless you can’t then connect via wi-fi.

Would not be surprised if a router restart helped the Atom being recognised again, possibly DHCP LAN IP leases timing out after 24 hours or so.

The Uniti series can be set to go to standby (sleep) after a defined time period.

Assume you Atom’s firmware is current.

Uses more power but enabling Server Mode (for attached USB/SD files) might help keep the Atom visible.

Good luck.

Potentially a problem if devices are connected to different routers but several are assigning their own local IPs - unless the devices are somehow bridged to see the whole network as one with a master DHCP server it could be an issue.

I’m no network expert!

Maybe @Simon-in-Suffolk could offer some tips.

Thank you, I very much appreciate your comments. I’m afraid the router reset doesn’t help, I’ve tried it. I will keep trying to find the solution.

If you genuinely have 4 routers, make sure only 1 of them has dhcp active.
Or do you mean 4 tp link units that together create the mesh?
Is there a broadband/adsl modem/router bringing an internet connection?

I’ve recently had a similar issue with a new TP-Link mesh and my Atom. Resulted in the same symptom but I cant for the life of me remember how I fixed it.

I do have some advice. Make sure that that ALL the mesh routers are running the same firmware. It gets updated frequently.

Definitely keep your Atom on DHCP, but what I would suggest is configuring the Router to assign the same IP address to the Atom all the time, so it doesn’t chop and change.

I found a link that seems to describe the process to do this, but not knowing your particular model, the process may be different. The basic idea however should be the same

Hi… yes you only must really have ONE router on your home network, and that connects your home network to the internet. Anything else is complex and will require extensive configuration that most consumer devices would not support.

The router on home networks typically manages the DHCP. This is the function that manages the distribution of IP addresses on your home network. I suspect you have only one router… but you want to ensure you only have one DHCP server running… and say you don’t have another running in in your wireless controller.

You mention your ATOM loses network connectivity… can you describe this. How do you know this? The device not appearing on the Naim app is not the same as it disappearing on the home network.

There is a free app called Net analyzer on iOS that can scan the low level MAC addresses on your network and map them to the IP address. If your Atom appears here, it has not disappeared from the network and your DHCP is working just fine.

But if still disappearing from the Naim app, that could suggest an SSDP interoperability issue with your new TP router. Here options get more limited, and one option would be to disable IGMP snooping on the router or wireless controller… assuming it’s an option on your devices.

If the Atom is not showing on Net Analyzer it has indeed disconnected from the network. This should never happen unless there is a fault. If this has happened through a DHCP failure, your Atom would/should give itself an automatic address that starts 169.254. This is likely only visible to the Atom perhaps on its display. This address would not work on your home network.


Is it this one?

I’ve used this for some time:

…, but it lost the ability to show MAC addresses after iOS 11 due to Apple saying there were privacy concerns tracking users via MAC addresses or something.

Thanks. When I say the Atom is lost, I mean the actual atom unit is not connected to wifi. It might “see” the network in the list of available networks in the front panel settings menu, but it will not connect after I type in the password. However, if I unplug the unit and plug it back in, it will seamlessly connect to the unit, and work fine for a few days, until it gets lost again.

Is it being put into deep sleep mode somehow and the DHCP lease for the IP maybe getting lost?

Equally if not might be worth trying deep sleep then powering on via the power button rather than unplugging the mains lead.

You might have tried some of this stuff before I guess.

yep - that is the one - Network Analyzer

1 Like

Strange how that is allowed to show the MAC addresses if the other one no longer can.

Is it being put into deep sleep mode somehow and the DHCP lease for the IP maybe getting lost?

DHCP is quite a refined and comprehensive protocol and so if the devices follow the protocol correctly (router and host) there should never be an issue as many non optimum scenarios are catered for. If there is however a complete and utter failure, ie the the router has failed, then the host (Atom) will, if it follow the DHCP protocol will use an automatic self assigned address at the end of the lease if it hears nothing back from the router. It won’t work on your home network - but will be very evident of a home network failure.

I do think until the OP can answer my questions on what exactly they mean by ‘disappearing’ from the network looking at DHCP is inappropriate. DHCP could be, and I suspect it is, working totally correctly - and there is an issue with SSDP and IGMP snooping on the home network through an unreliable consumer network device.


Thanks, didn’t mean to cloud the issues!

Just out of interest, if a device is assigned a LAN IP by the DHCP server with a ‘lease’ for say 24 hours, this presumably automatically renews while the device is still on the network.

Does powering the device off/full standby mean that the device loses that IP automatically after the ‘lease’ expires or only if the IP address is needed for a new device joining the LAN - I guess it would make sense for the router to maintain a table whereby the same device got the same IP address if it was still available. I used to assign static IPs years ago, but haven’t done so for ages, partly as I can’t get my head around an older Ubiquiti’s menu systems/configuration options !

Net Analyzer doesn’t show MAC addresses any more, at least not the IOS version. Nor does Fing which is another similar app which I have always preferred to Net Analyzer.

1 Like

Ah, thanks, looks as though Apple must have denied programmers this information for privacy reasons. A shame in some ways given rather cryptic names of certain devices on the LAN.

The DHCP server will keep the IP address lease even if the host device is powered off. If the host has not requested a new lease the lease will expire. The host should typically renew its lease at around 50% of the lease time such that it increases the likelihood of the same IP address being issued by the DHCP server - which in turn can give a small performance gain - as the ARP table/cache value for that IP address does not need to be rediscovered and learnt for home network devices (router, switches, wireless controllers ), assuming the ARP tables/caches on those network devices have not already timed out.

Whether you use static or DHCP assigned IP addresses - it makes no difference to the ARP tables cache timeouts. If you have a DHCP server on your home network there is no reason to ever use statically/manually assigned host addresses. If you have no DHCP server on your network then you have no choice.

1 Like