BBC sounds, alternative connection?

It’s a 172, I am in the UK and the on demand service I was trying to listen to was BBC Radio 4 More or Less.

Is your streamer firmware up to date? I can’t promise that would help, but there have been iRadio updates issued in the past.

Having said that, the On Demand and Podcast material available through the Naim app has always been a small fraction of what is available in BBC Sounds. Take More or Less as an example: there are 4 episodes in OD and no podcasts. In the Sounds app there are hundreds of episodes available - all of them, in fact.

If I still had a 1st gen streamer I would get an old AirPort Express and connect it to an optical input so that I could Airplay stuff to it from any app.

Hi all,

ref On Demand episodes exposed on Naim app.

On the BBC Ondemand files they define a date/time when the stream should be exposed and a date/time when its expired and should be hidden.

The system respects these and hence hides stuff that the BBC has flagged as expired. However, BBC Sounds is a law to itself and it contains material that is not exposed to 3rd party systems.



1 Like

Thanks for confirming that it’s a BBC issue Steve.

I didn’t update firmware as I don’t use Tidal or other music streaming services and as per SteveSkys reply this would appear to be a BBC on demand issue so a firmware update would make no difference.

David - can you try an play More or Less from OnDemand?

Hi ok I tried just now and you can see the offered programmes and one of them actually playing. But I tried them all and they all worked. This was on a 272 on 4.8 firmware and using the release IOS app running on an iPhone 12 Pro on IOS 16.3.1

So all ok here.

Hi @spile

Based on it’s failing to play (not browse content) then it indicates your unit is running very old firmware. About 4 years ago there was s fix to handle an update to the hls standard and it indicates your unit is running code before that update.



@spile You can check the firmware version of the 172 either in the Naim app or using the remote and the display on the front of the 172.

Upgrading the firmware is free and something you can do yourself. You should check the installed version first and then post here and we will explain what to do.

Thanks @davidhendon . The 172 is running 4.700 so it looks like I need to update. It looks like I am going to have to buy a serial lead as I threw all those away years ago.

Yes you do need to update and that will most probably fix your problem. You should be able to get a lead cheaply on eBay or Amazon.

Incidentally Naim have said that a further update is planned for legacy streamers later in the year, so put it away safely somewhere after you have updated to 4.8!

You just need a USB data cable with a mini plug on the 172 end.

Thanks. I have one of those. I thought the guide said usb d to serial. Good to hear that it’s usb to usb d

It depends how old your 172 is. You need to check before you buy by looking at the back panel.

It is a D

Good! That’s a mini-USB. The only thing to watch is that your mini-USB to USB A lead needs to be a lead with the data connections also made. Many power only leads were included with things like digital cameras back in the day and they don’t transfer data because those pins are not connected. I have three leads that look the same but only one of them works for this application, so I have labelled it specially!

Noted but I have more fundamental problems, the firmware updater requests the .NET framework version 2.0 but I already have version 4.8 installed. If I chose not to install the framework, the updater stops. If I chose to install the framework it takes me to a 404 File or directory not found link.

Just to confirm, this the 4.8 firmware updater downloaded from Naim’s website? I would have thought that it’s not that old that it would be asking for .NET framework version 2.0.

Have you read all the installation instructions? From memory they are very detailed and cover this issue. (It’s a year since I did mine)

I’ve just checked the instructions and this isn’t mentioned there. Nor is it an issue I have heard of before and I did beta testing on this update prior to its release.

I haven’t tried this but there is a fix described here that may help.

Or this fix, which is basically the same.