Bizarre NDX2 behaviour. Any ideas?

My system is UnitiCore, NDX2 and several MuSos, all hard wired to a rock solid BT router.

So, I just tried to play a new CD just ripped to the Core. Coldplay’s music of the spheres. When I try to play it from the NDX2, it sees the album artwork plus all the track listings, but it will not play any track. All tracks also have a duration of 0.0s, thus appear empty.

Initially I suspected an issue with the Core, but this doesn’t seem to be the case. I can stream the album OK to the MuSos, but not the NDX2.

Also, If I stream to one of the MuSos, and select the NDX2 using the “multi room” option, the NDX2 plays ok.

The NDX2 doesn’t seem to have problems playing other CDs or ripped music, I have only noticed this behaviour with the new Coldplay CD.

I have tried the following so far, to no avail ; restart the NDX2, reset the NAIM app, rebuild the database on the Core.

Utterly bizarre to my non IT brain, and very annoying.

Any ideas Forum ?

Thanks, Paul

Could it be that the NDX2 has discerning taste and is not a Coldplay fan? :wink:

More seriously have you powered down the NDX2, left ift unpowered for 20 mins and then restarted it?


Thanks Paulbysea, I was half expecting a comment about Coldplay !

Yes, I’ve tried powering down and restarting the NDX2, but not a factory reset, no luck.

Cheers, Paul

1 Like

Restart your router, wait, restart then the Ndx2, and finally delete and install the app again. In > 90% it works generally.

Hello Paul

I’d be inclined to delete the disc in the Core and then re-rip it. My thinking is that perhaps the ripping engine in the Core got itself out of sync and a restart won’t help as the damage is done, but a new rip should be ok.

If all else fails, bring your Core and the CD round here and we can try to replicate it!



Mentioning the execrable Coldplay and starting a sentence with ‘so’ is a sure recipe for disaster!


So are you saying you don’t like Coldplay HH?

1 Like

Hello David,
Thanks for the suggestion, great G’ford minds think alike ! I had tried deleting the offending album and re-ripped it, to no avail.

Just fascinates me how fickle the digital audio experience can be….


Did you re-rip it before restarting the Core or after?

Admittedly I have never heard of a problem like this with the Core.

Sequence was 1.) Restart Core, result=no change, then 2. Rerip CD, result=no change, then 3. Restart Core again, result=no change.

Meanwhile the 1st Gen MuSos can play it without issue.

If i go directly to the Core on the Naim app, I can also play all of the tracks, and each track has a defined duration.

Sounds like another glitch in the NDX2 firmware to me……

Would be interested to know if any beta testers able to replicate this one ?

Thx, Paul

There are no beta testers testing Core firmware at the moment as it’s about a year or more since the last Core beta release. (Although I have been on that old beta firmware all this time.) Anyway I can say that no Core beta tester has reported any problem like yours. Also I don’t recall a new platform beta tester reporting anything like that either. It would be interesting to know whether my Core/Nova sees the issue, although again I’m on 3.8 beta firmware on my Nova currently.

If you want to bring the CD round here we could rip it on my Core and see what happens. I have Nova, 272, SuperUniti and Qb we could try playing it with. Then I would delete the rip as you leave (it’s not my sort of music!)…

I’m not here this weekend as I will be on a business trip, back Monday, but I am around here some of next week if you felt like trying that, assuming you don’t solve it in the meantime.

Way back when i ripped my cd collection there were a few cd’s although perfect to look at would not rip. I wonder if this album which might be outside of red book rules. I shipped to Naim to investigate and Flynn managed rip with a “full width laser” and sent back the copies as a cd burn……just fine. The Core uses a slim width laser……i may have got the terminology wrong……but could be a clue?

I once had a CD that ripped on the Core with an audible crackle for half a minute on one track, although it ripped ok on the Unitiserve I also had at the time.

After some emailing, I sent the CD to one of the Naim developers for her to investigate and bought another copy for myself. That ripped on the Core OK without crackling. The developer suddenly left Naim for another job and I heard no more, so I guess no-one ever really investigated that.

But a CD fault is definitely a possibility with Paul’s issue I think.

1 Like

The only other instance was “High” by The Blue Nile……the first small batch was released with copy protection. It was being used internally in the record company prior to release to stop black market copies, but slipped through……had a copy which they replaced? Best of luck.

That’s an interesting thought Gazza…

Still strange that the 1st generation mu-so has no problems with playing the files …

Thank for all the thoughts……

As a further test I used a free iOS app on my iPhone, called Flacbox, this can see the Core as a upnp server, and has no trouble playing the troublesome Coldplay album……

Surely a glitch in the NDX2 firmware ? And yes, it’s running the latest firmware…

Have you tried unplugging the Core and then replugging and rebooting? I’ve had to do this occasionally with mine.

I have reported this in the beta group Paul.

If both the mu-so and iOS app are able to play the Coldplay album, I tend to agree that something is wrong with the NDX2