Bl**dy Apple

Last night I finally “upgraded” to MacOS Catalina. I’d been delaying the change while some of the programs I use were updated to Catalina compatibility.

Unfortunately, I didn’t realise that Apple, in their “wisdom” had removed iTunes and substituted Books and Music etc as separate programs.

Now … I use Audiobooks in my car, and have hundreds of them. Many are not from, and are ones I generated myself from cassette or CD. As such, they are in m4b format.

Prior to the latest MacOS upgrade, I just put these into a playlist in iTunes, and made the sync to my iphone with ‘books from playlists’ ticked. Easy, and no problem. Meant that I didn’t need to keep a very large library on the phone, but could just move things in and out of itunes on the mac.

Alas, the latest iteration of Books on Catalina won’t let me do that, so I duly tried to put my current read into the Music App on the mac, only to find that it didn’t recognise them.

Ok, next step - try to convert the files from m4b. dBpoweramp didn’t recognise them, neither did Music Tag Editor.

Eventually finished up having to download the “Bound” app onto my phone, and put the m4b files into Dropbox. (only found out about this after a lengthy websearch)

How cumbersome, and how thoughtless of Apple to remove something that is used by many. Don’t they realise how many Audiobooks are not available from Audible (or Apple iTunes store)? Even if they were available in the newer format, why should anybody have to buy them AGAIN just to play them on their phones?

Not good customer relations.



I’ve decide not to move up to Catalina on my own MBP, so I can still use 32bit programs and also to keep iTunes. I guess Apple feel they are always under pressure to move ever onwards and certain things get left behind. Such is life, particularly where technology is concerned.


Apple is a love/hate thing.

Many things continue to work perfectly, many others break due to unnecessary modifications/changes.

iTunes was long regarded as ‘bloatware’ but it used to be very good until they tried to simplify it.


I got stung by Catalina update.

I used iTunes as my music player (Macbook) and control it using the Apple Remote app on my iPhone.

After the update the Apple Remote app on my iPhone failed to communicate with MacBook/iTunes (now Apple Music). It took Apple weeks to fix the issue.

Next time I wont be in any rush to update macOS.

I wasn’t in any hurry either - had to wait for Sibelius and Photoscore to be updated. I use a QNAP NAS for my stored music. Just wish QFinder could ‘see it’, so that I could update Asset UPNP on it. Mac finder sees it, but not QFinder. Last time it happened (about 2 years ago) I tried all the suggested cures. Eventually did a factory reset of the NAS and resinstalled >3TB of files to it (took AGES). Don’t know if I can be bothered to go through that pfaff again.

You don’t need QFinder to locate the NAS, you can log directly on to a QNAP using a web browser.

You will need to know its IP address though, if you don’t then download a free network discovery tool and that should tell you what it is.

I know that, and that’s how I persuade my mac to find it when it has a temper tantrum and loses it. I normally keep an alias on the desktop so that when I want to add something (I only use the NAS for music files) I can just use Finder to do so.

Alas, to actually do the Asset upgrade, I need to get at the NAS via QFinder so that I can get at it’s apps.

If you log on to the web interface of the QNAP you will be able to open the App Manager program and perform the upgrade. This is how I do it all the time, never use Qfinder.

OK. I just discovered that the link I was using didn’t show the webpage. However, deleting the bit after the colon, and voila! There it is.

Just been to the Asset website and downloaded the latest version of Asset upnp QNAP.

Do I have to uninstall the old version before installing the new one, or does the upgrade just overwrite the old one?

No, leave the previous version installed. Installing a later version will upgrade and preserve your settings etc.

Thanks. Just done it. Will check to see if it works OK later this evening!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.