Blue Node 2i help!

My first foray into streaming has been a bit of a nightmare. I’m already on my second Blue Node 2i and this is about to be exchanged for a third by my dealer. Who, by the way, is also having connectivity issues with their demo model?

I have downloaded the BluOS app to my iPad and then get it to look for my player. It sees the player and tells me to go to my iPad wireless setting and install it as a blue sound speaker player. This I do and the installation progresses for about thirty seconds. I then get an “unexpected error” message come up. I go back to the app but there is no sign of the player. Even with a wired connection the app can’t see the player. I’ve tried reinstalling the app, restarting the iPad, doing a factory reset on the Node but all to no avail.

Any of you tech guys know what I’m doing wrong? I’m beginning to suspect that it could be a batch fault?

Sorry you are having problems but this would be better posted on the Bluesound support forums.

I had similar, but the ipad used bluetooth to find the 2i. I then had the 2i connected by cable to the router and it then found the network. I had to select the retry in the app which then allowed the 2i to download a software update and connect to the network. After I disconnected the cable, it then saw the network.

Yes, tried that but not had much response. I’ve seen posts with similar problems but no clear way to solve them if you can’t see the player via the app. I thought there might be a few Node 2i users on this forum that could help?

1 Like

@lhau and @Njb use Node 2i into Qtest. Should perhaps help.

Had no issues setting up mine going to the DAC of the 272 but used the iPhone app and not iPad. Have you tried the app on other devices? They have one for PC’s too

Do you have WiFi MESH points?

If you have a traditional Internet router connect the 2i direct via LAN cable, connect ipad to the WiFi from the router, factory default the 2i and try again.

1 Like


Thanks HiFiman. Tried almost everything I can think of. I have 3 iPads knocking around plus 2 iPhones. I get the “unexpected error” on all of them. A direct conection does not work either. I even tried setting it up on an Amazon Fire. This allowed me to link the Node to my router and input the router password. I thought i’d made progress but then I got the very familiar " an unexpected error has occurred" so still no luck. Lookimg like this Node will need to be returned! So far I’m very underwhelmed with this streaming lark!

I got the same unexpectd error message, but when i pressed the retry option on the 2i it downloaded and installed its software update. ( cat 5 connected)

Seems very odd indeed and I have never encountered any issues with connectivity.

I guess you have googled the error but I have stumbled upon this on the Bluesound forum

“Found that you must assign it a personal name for it to work–not optional”

Yes, think I’ve seen that one. Is this in the airplay set-up instead of the Nodes model number that normally comes up? I think I’ve tried that but still nothing? Will check again. Thanks.

What type of network infrastructure is within your home is it a simple internet router with built in Wi-Fi

I guess you have performed the following too

Steps to Factory Reset:

  • Disconnect the player from electrical power.
    • If you have a PULSE FLEX with a BP100 Battery Pack, disconnect the battery pack as well.
  • Wait 10 seconds.
  • Reconnect the power.
  • Once the LED turns Red, touch and hold the Play/Pause LED on the touch panel (It will immediately turn Green and then back to Red) - do not let go of the LED.
  • Once the LED turns back to Red, continue to hold the button for 30 seconds.
  • After 30 seconds, the LED will begin to blink red – then release the button.

All customization to the Bluesound player will be removed and restored to factory settings.

IMPORTANT: Removing your finger from the LED at any time before the LED begins flashing red will cancel the factory reset and leave the player in Upgrade Mode. Just start the steps again to factory reset the player.

You will know the factory reset is successful if the player returns to Hotspot mode (wireless connection - the LED will turn solid green). If the player is connected to your network through a wired Ethernet connection, it will simply connect as if it was a new player (LED will turn solid blue).

At this point I would connect the Node 2i direct into the router then perform the setup again.

Network is a very simple single router. Nothing fancy. Although I do have FTTP, which gives me a good 100mbps. I’ve tried the factory reset and get all the light functions as per the instal instructions. The direct cat5 connections takes the lights through red to green to blue, which should mean it’s installed. If I then go to the app there’s no player visible. It’s the visibility of the player that seems to be the problem. Whatever I do I can’t see it? This was slightly different with the first Node I had. I managed to get this working for a day before it suddenly forgot the network and wouldn’t reconnect no matter what I did.

Do you own a laptop if so can you install “advanced-ip-scanner” if not download “fing” on an Android device and perform a scan and see if the unit is detected

On the underneath of the Node 2i a white sticker should display the MAC address.

On the network scan look and see if mac is listed

Unfortunately it’s a works laptop, so IT limit any unauthorised downloads.

Strange that my dealer was having similar glitchy problems with their Blue Node. They got the same error message but it seem to get further in the loading process and allow the app to see the player? They also lost connectivity after a while.

Install fing and run a scan and check to see if the Node pops up on the network.

What make/model is the router, also and probably won’t make any difference have you powered off waited 30 seconds then powered on the router.

After the factory reset and with the node connected direct into the router is the light a solid blue if not its not factory reset.

It’s a BT smart hub 5. I will try switching it off then back on if that helps?

And yes, with a direct connection I get a solid blue light.

I have success connecting to my Node 2i via iPad (and any Apple device) using Airplay (I.e., skip the BluOS app, if that’s causing problems and stream directly from your music software). If you use TIDAL, TIDAL Connect is a dream with the 2i. Since it pulls directly from the cloud and you only use your devices to control what’s happening in the cloud, you skip the middle man, which I’ve found to be a cleaner connection.

Okay, I’m using Qobuz. How do I set that up?