Bubble Server Won't connect

I kept notes when I installed BubbleUpnp server on an RPi 3 using the Raspberry Pi Lite OS. You need to install java and ffmpeg too, here goes:
Log in to the Rpi as user pi via ssh:

Install java

sudo apt-get update
sudo apt-get install openjdk-11-jre-headless

Install ffmpeg

sudo apt-get install ffmpeg
mkdir bubbleupnpserver
cd bubbleupnpserver

Get the latest bubbleupnp server

wget https://bubblesoftapps.com/bubbleupnpserver/BubbleUPnPServer-distrib.zip
unzip BubbleUPnPServer-distrib.zip
chmod 755 launch.sh
./launch.sh > /dev/null 2>&1 &

Bubbleupnp server should now be running

Add launch.sh to crontab

crontab -e

Add the line below to crontab to get bubbleupnp server to start on reboot

@reboot /home/pi/bubbleupnpserver/launch.sh >> /home/pi/bubbleupnpserver/bubble.log 2>&1 &


Just remembered I also installed ffmpeg from QNAP club as well maybe that’s why your transcoding doesn’t work using their package try installing that.

The binary from QNAP club works perfectly fine, if you install ffmpeg from them as well they are both install qpkg. Containers are really nothing to worry about it’s just like installing an app QNAP looks after all of it except you choose one network option which you can change after its been installed if needed.

I’m getting a bit confused here. I installed the binary from QNAP Club and it doesn’t seem to do anything. I can see it installed in App Centre and this is what I see but if I click on Open it doesn’t do anything. Should it? Transcoding options in bubbleupnp server remain greyed out even after restarting the server. If not that package what should I try installing?

Also this looks a bit odd, zero bytes memory used?

Screenshot 2021-03-12 175226

Thanks but I don’t even know what the QNAP club is. Are you talking about the QNAP forum? Is there a particular thread there? I’ve been able to install qpkg files for Asset, Mininsever, and Bubble, and get them working with the exception of transcoding for Bubble. The Bubble site recommends installing binaries through a console command and after reading the install instructions I didn’t feel comfortable doing it. If you’re saying I can accomplish the same by installing a qpkg file that’s something I can do.

Here’s the thread I was using for the optware ng binaries.


Ok, I found the qnap club site and this ffmpeg download but I don’t know which one fits my QNAP TS-251


TS-NASX64_64. But I would go for using container station as there is no issues with ffmpeg as it will be bundled with it. My installed app version from QNAP club works with even QNAP club ffmpeg disabled I just can’t do video transcoding. So I can’t help beyond that. My recommendation is to use container station

Install container station

Create container

Type in BubbleUPnP in the search images box and select Docker Hub tab when it comes up.

Choose this version as it works there will be a lot listed fireplex/bubbleupnp . Click create.

Hit next at next window

In Create Container window click on advanced settings. Choose Network, set Network mode to host.

Click Create and wait

In the meantime disable your installed apps of bubble.

After this if you restart your Nas you will need to restart the contianer. Thats it very simple and no need to fiddle with ffmpeg.

Ok thanks, what’s a container station? Is this on the QNAP club site too? Sorry, I’m not up to speed on these things.

Its part of QNAP so its in the store. Its a virtual machine for apps. They run in there own environment with all the bits needed.

is this it? Oops. just saw you images, this looks like it.


I got as far as installing Container Station from the QNAP repository, opened it up and it said a minimum of 4GB RAM is recommended and just as it said that the stream from the NAS to the ND5 XS2 died probably down to insufficient RAM :rofl: Uninstalled Container Station and the NAS to streamer is fine again.Until such time as I add some RAM I’ll need to find another solution. All I really want it for is to downsample hi-res streams from the NAS to my Sonos speakers. They seem to handle 24/44.1 OK but barf at anything better than that.

I think it’s working it’s giving me the transcode option now.


If you dont have the ram then Qnap club is the one then. No idea why that doesn’t work for you.

Which one did you go for?

the one you said to use with your images above. I did exactly as you said. I don’t really know what all of this is doing though. lol

1 Like

All it does is createa virtual operating system and a disk image on your storage. Containers contain the basic os and code to run an application and can run on any computer that runs docker. Windows,Mac Linux they all can run the same containers.

Well it’s not liking something, Kazoo cues up my playlist but doesn’t play.

Ok that makes sense. I used virtual ware for my mac to run window years ago.

I only have 4gb of RAM so I wonder if I’m pushing my QNAP to the limit.

So it won’t play my Tidal playlist (Kazoo) even if I disable transcoding.

Possibly. I have 8gb on mine and it’s TX-451 pro so not a new model. You can reduce the memory allocated to the container but not sure that will help.

1 Like

Back to the drawing board I guess.