BubbleUPNP/Minimserver/Qobuz - older Naim streamers

I am running Minimserver 2 with the Naim app on my control point very happily with my Synology DS716 DSM 6. rendering primarily to a Naim NAC-N172XS, but also a first generation Mu-So. The server and renderer are connected on a wired ethernet. I transcode from Flac to Wav and all is well, playing up to 192.24.

Separately I had a rest from my Spotify subscription and looked at alternatives and decided on Qobuz. In order to stream Qobuz to my Naim 172 streamer I installed BubbleUPnP server on the Synology and use Android BubbleUPNP on my control point. All works well and I can stream up to 192.24 from Qobuz. A big improvement on Spotify and only £149 a year and although I haven’t tried it yet I understand that the Qobuz app will work with Android Auto for downloaded files which is good.

My problem is that I cannot transcode from flac to Wav using Bubble. On the Open Home settings for my Naim NAC-N172 renderer and the Mu-So in Bubble Server the Audio decoding section is greyed out. Initially I read some stuff about the Synology version of ffmpeg being older and installed the ffmpeg version from SynoCommunity but no joy.

Has anyone else achieved this and if so how please?

Once resolved, or even now as it’s streaming in Flac anyway, it’s kicked some extended life into my Naim 172, which is good news as I’m very happy with it otherwise (except for the dead display?!).

There has been a lot of discussion about this in the thread above albeit relating to QNAP NAS so it is not just a QNAP issue

Thanks. I prefer to keep it simple and would like to resolve the transcoding on my Synology. Minimserver is doing it fine using ffmpeg on the Synology, so I can’t see any reason why Bubble shouldn’t. Just need to find the key to unlock the greying out…

Did you restart the Bubble server after installing ffmpeg? The server is checking for it on start up only, I think.

Also you could enable logging in the settings (advanced) and see if the log file gives some helping information.

In my case the ffmpeg must be placed in /opt/bin/ on the synology NAS. I just have placed a symlink there which points to the installation path of the ipkg installations. The packages are installed in /volume1/opt/. So I have to set the following symlink:

ln -s /volume1/opt /

Now the packages are found in /opt, too, where the bubble server is looking for it.

I hope this helps a little bit?


Many thanks Gert. I’ll have a look at this.

Gert - I received this from Bubble, tried it, but it didn’t resolve my problem. They have gone on to say that there will be a new version of BubbleUPnPServer that will resolve this known issue within days. I’ll post an update once I have it.

To use the community Syno ffmpeg (which is very complete), you must
indicate its location to BubbleUPnP Server.
This will not be necessary in the next BubbleUPnP Server update which will
auto-detect it and use it if found.
In the meantime, you can do it manually:

  • login via ssh
  • go into /volume1/@appstore/BubbleUPnPServer
  • edit bubble.sh and add ‘-ffmpegDir /usr/local/ffmpeg/bin’ (without the
    quotes) at the end of variable BUBBLEUPNP_OPTS
  • stop and restart BubbleUPnP Server to make the change effective
1 Like

I’ve posted in the other thread about bubble that I’ve managed to get transcoding working on my QNAP NAS. I think the instructions may well work on Synology too

Many thanks - I did take a look but with the new Bubble release very shortly, have decided to wait for that at the moment.

Bubble Server release 0.9 39 has resolved the Synology FFMEG issue, happily transcoding to WAV now, albeit using the Syno Community FFMPEG version.

Excellent news!


Great news - QQ - assuming you have the latest v6 DSM running the Synology NAS - do you have the NAS firewall on or off?

If on, did you have to change any firewall settings?
What controller are you using?

I don’t use my NAS externally so no issue with the firewall.

Surely DSM 6 has been out for years - 7 is not far away, but I understand Bubble will run through a Docker container.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.