Any BubbleUPnP app users having issues with Tidal today? I’m getting ‘Authentication failed: Client not found’ error. Tidal app is fine as is website and access from Naim app.

1 Like

I got the same yesterday, looks like Tidal is tightening up their authentication method.

From the BubbleUpnp google group:

“The situation with TIDAL login is complicated.
Long story short: there’s 2 methods for an app to login to TIDAL: the old method (login/password based) and the new method (using OAuth2 via a TIDAL web form).
BubbleUPnP Server only supports using the old method which worked until now, but TIDAL pulled the plug on it today it seems. Not entirely a surprise as this was announced but when exactly it would happen was not known.
I’ll see how I can switch ‘BubbleUPnP Server’ to the new method but it is not entirely trivial.”

1 Like

Thanks for that, I thought it might be some sort of api issue.

I just tried Linn Kazoo app on my phone and got the same error. There was a message saying that the way Tidal logins work is changing and to upgrade my system to be able to continue using Tidal. I don’t have a Linn system but is this something that will trip up the Naim app or has this change already been implemented I wonder?

Yeah, thanks for that. What a pain!

“I plan on implementing the new login scheme but it is far from trivial (for making it compatible with Kazoo) and requires changes in BubbleUPnP Server and Android BubbleUPnP.
In the meantime, I will have an update to Android BubbleUPnP very soon that allows to play TIDAL to OpenHome renderers managed by BubbleUPnP Server but just not using OpenHome TIDAL support,
thus requiring to leave Android BubbleUPnP for as long as you play TIDAL tracks.”

I’m unable to login with Kazoo using a bubble container on my QNAP. No issues with the app or website.

Here’s the message I get.

Getting exactly the same. Tried a few times over the last couple of hours just in case it may have been temporary, but I guess the old system has now been properly switched off :pensive:

Not just Bubble. My A+K DAPs have stopped functioning with Tidal too.

Works for me, just logout and login again. They have added a new captur login now.

Hi everyone,

Tidal have been rolling out a new login system that is based on OAuth2. As close partners with Tidal we have agreed a whitelisting to ensure Naim products are not affected, but we will be releasing new firmware for older products later this year that will give them OAuth2 capabilities + we’ve sneaked in some nice new things as a little bonus.

Naturally on third party apps / products etc., we can’t help on that but it will come down to that they need to update their code and products to support this new login API.

Best wishes

Steve Harris
Software Director
Naim Audio Ltd.


Native Tidal still works on my 272. I didn’t even have to log back in. I wish it sounded as good as through Bubble. ;(

Hi Steve,

Thanks for taking the time to post an explanation here. It’s nice to know that Naim are already on top of it and as I type, the Tidal app on my NDS continues to work faultlessly.

For me, the dabble with bubbleserver is purely to feed the NDS with WAV rather than FLAC to give Tidal SQ a little uplift now and again, but I still prefer to use the slicker approach of the Naim app which integrates Tidal with my own music, so it’s great to hear this is being future proofed. Thank you.

BubblUPnP 3.5.1 pushed to my phone today and the fix for Tidal login is in. Well done to the developer for such a quick fix


That’s good news. Hopefully a new bubble container with the fix is forthcoming.

I guess Linn Kazoo won’t get updated to allow the new sign in as there is a new Linn app now? I’ve just checked the bubbleserver on my Synology NAS, there are no updates on that, although as the app is the only place it appears where sign in is required, it may seem that this approach to get transcoding may now be thwarted - unless of course there is an alternative to Linn Kazoo?

Nice, thanks for the post. And definitely impressed they turned that fix round so fast!

I don’t think Kazoo is the issue as Qobuz is working fine currently. I think the issue is on the bubble soft side of things and there is apparently an update now so you should be good. I can’t use the bubble app without a container b/c I don’t have the proper ffmpeg functionality on my QNAP so I have to wait for new container with the fix (I think).

Ah, ok. I assumed it was with Kazoo as that is where I signed in to Tidal and it still only offers the normal sign in option. I did have a quick look to see if there was an update available via my Synology NAS but it said it was on the latest software already. I think bubble works slightly different on Synology, I just installed bubble upnp and then an ffmpeg add on and it worked fine, so didn’t need to set up the container. Maybe an update will follow later for Synology🤞

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.