Cannot transfer downloaded FLAC album to Core via USB

When transferring a downloaded FLAC album to my Uniti Core, I have always done it by copying the album folder to the Core’s downloads folder via my PC (Win 10).

So today I thought I would copy my latest album to the Core by a USB stick plugged into the Core’s front USB socket. I went into the Manage Music setting in the Naim app & to the Import Music setting. I then clicked the Continue setting to search for attached drives. The search began (with a spinning circle shown) & just continued spinning for several attempts, the longest of which was 15 minutes. The drive was never recognised &, after several attempts, & I then gave up.

I tried again using a different USB stick & got the same result, nothing.

No major problem as I then transferred the album via my PC in my usual way. However, I am curious as to why the attempted USB transfers failed.

Does anyone have any ideas they would care to offer?

Thanks in advance of any replies.

I never tried to do that! I always transfer using my PC to the downloads folder.

Did you try a power-off restart of the Core?

Did you try using the rear USB socket?

I’ve copied a few albums (flac) recently via USB stick to front USB, as you say go to app, manage music, and import music. The core see’s the usb straight away, click and away it’s goes, no issues whatsoever. Could there be an issue with the USB stick ?

1 Like

Same here done as described on occasions.

I doubt it.

As I said I tried another brand USB stick with the same results.

A while back I did transfer 30 or so CDs from a USB stick with no problem at all. I seem to recall this drive was actually plugged into the rear socket of my Nova at the time. I did try with the USB stick plugged into the Nova but, again, it was not recognised.

Hi David,

I believe you are running the same Beta firmware as I am & am wondering if there is an issue with it.

I may mention it on the Beta forum in the next couple of days if the issue persists.

Yes mention it in the beta forum straight away I suggest. If I get a chance tomorrow, I may try the same import myself.

Hi David,

I have just sent Will a PM.


I have had experience of Naim being very sensitive to the format of USB sticks.


From where did you download the file?

It doesn’t matter where the file came from. Or even whether there is one. The OP’s Core is not recognising the USB sticks. It should see the USB stick regardless of what files are on it.

Heard from Naim.

It’s a known issue with the Android app. (which I am using) & will be sorted in an upcoming release.

Doesn’t affect iOS users, which I guess all the people on this thread that haven’t experienced this problem, are.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.