Canon A3 printer

Sorry, this post is not about a Naim product - it wouldn’t happen with Naim…

I have been using a Canon Pro-1 for a number of years now; it’s produces beautiful A3 prints, but I’ve just had a notification “Ink absorber almost full, contact your service centre”.

I have contacted the said service centre: there’s only one for the whole country, there are no approved agents. This means sending the printer (about 40-50lb) to that centre (250kms) for something which is not even a technical issue - it’s part of the normal servicing. Sending something like that is going to be very expensive - and the printer is not worth that much, it’s not as if I was sending a NAP500. So, really, I have little choice but to throw the thing away. which is utterly stupid from an environmental point of view.

Has anyone met the same kind of problem? How was the problem solved?
If I have to get a new printer, obviously I won’t buy another Canon, as I’ve just discovered that Epson has a network of agents (one 5 miles from where I live) that can sort out that kind of issue.
Which model would you recommend, in the Epson range?

If you are going to scrap it anyway, it might be worth trying to sort it out yourself. I have in the past (although not on your model) and it was easy if a bit messy. There are bound to be guides on the internet.

1 Like

Thanks for your reply - unfortunately, no guide on that particular model, which is not that common.

I have had a quick look and there is at least one site with a guide. I am not sure if I am allowed to post a link and, in any event, it would be unwise as my AV software warns of a Trojan. BUT using a well known search engine allows the cached version to be accessed. I searched for “canon pro 1 ink absorber empty” and it was the second article. It looked as if there might be some other useful articles on the same site. But, with the trojan warning, at your own risk…

Thanks, I’ll have a look.

I have an Epson A3 printer, something I need for my work, which after 18 months, the feed wheels stop working. I am on my third printer after 3 years. I have done the maintenance Each time as You find in youtube etc for this problem and it hasn’t worked. The service agents cost almost as much as a new machine to ‘maybe’ fix it. A scam frankly. I just feel that all printers now have a very limited lifespan


The Epson Eco Tank ET-16500 is A3 and uses cheap bulk ink, its great. I have 2. Phil.

A quick update: Canon are aware of the issue (i.e. the lack of a network of approved agents) and are in fact paying for the cost of sending the printer back to the service centre, regardless of whether the printer is under warranty or not.


hopefully canon will also cover the cost of sending it back to you!!

Postscript: the Canon employee who replied to my email made a mistake - Canon does not in fact pay for the cost of sending the printer back to the service centre.
I pointed out that I’d been told this would be taken care of; the reply was that they would make an exception and pay for the cost, provided I sent it back in the original box (which is absolutely enormous) and I made sure the box wouldn’t be upset in anyway in transit, which I obviously couldn’t guarantee.
This means the printer - which is still in perfect working order - will have to be scrapped. It’s obviously a waste - financial and environmental, and all because Canon doesn’t have a network of agents to service their printers.
Needless to say, the next one will be an Epson (they have an approved agent 4 miles from where I live); the choice of A3 printers is rather limited.
I wish Naim made printers… the good thing about Naim is that you know you can keep their stuff for ages, and still have them repaired (well, I don’t know about streamers, though…).

I have an Epson ET-7750 A3 printer which has enormous ink pots which look like they will last for a very long time. They are also very reasonably priced as replacements. I had loads of problems with it due to ignorance on my part - I tried to connect it to my laptop using ethernet connection which proved very hit and miss. Problem solved by using the usb alternative port. I didn’t have the courage to try and figure out the wi-fi option!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.