Can't connect wirelessly?

I’ve had a ND5 XS 2 for a couple of weeks now and I haven’t been able to connect it wirelessly.
I’m using plug in adaptors at the moment but it’s far from ideal. I will be sorting out a ethernet cable running outside the house to my system up stairs in the near future.

All other devices connect to the WiFi without issue but the streamer can’t find it. I have a BT Home Hub 6. BTW.

I’ve taken the streamer back to my dealers and it connecteds to his WiFi without issue.

Any tips?


A strange one, I have a BT HH6 & it finds everything. Is the ND5 set for DHCP & have you tried re-booting the hub? Switch it off & leave it off for 5 minutes & restart.

Are you using the Android version of the Naim app by any chance?

Yes Android 9.

What is DHCP? I have reset the hub without any success.

Try using someone’s iPhone. I tried with my android phone and no dice. Switched to my wife’s iPhone and the app first used Airplay to get it on the WiFi and then it worked.

1 Like

Or indeed other iOS device :slight_smile:

If you log into your router, you should see a list of all devices connected to it. Is the streamer on the list?

I’ll look into this, thank you.

No worries. I have found a bug in the Naim app in Android 9 getting the ND5XS2 on WiFi on initial discovery and setup. If you do the same thing on iOS with the Naim app it works first time.

1 Like

OK if you don’t know what it is, it means you’ve not changed it. Its the factory default setting for the program that manages your networks IP Addresses.
Its the acronym for Dynamic Host Configuration Protocol & is a program thats on all network hubs & devices. With DHCP the network hub (router) assigns & manages all network IP Addresses.

1 Like

Thanks for the explanation, much appreciated.

The streamer is showing on ethernet port one.

That means it is/was connected over ethernet. For wireless it should be showing on “Wireless Connections - Devices (number)”

1 Like

I’m guessing you’re using some sort of ‘Ethernet over mains’ devices, and the streamer is connected to one of these over a wireless connection? The router probably doesn’t see it as a WiFi client as it’s a client if this third party device.
You might be able to coax this setup to work…but my suggestion for a long term solution is - it’s the weekend. Go out and buy a long Cat5e Ethernet cable and a drill. Connect it up, and ditch the adapters.
Good luck.

I have good news…It’s not going to be easy to try to explain how the problem was fixed. It’s more ‘’don’t question why’’

My dealer popped over last night to try to get to the bottom of the issue. The ethernet plug-in’s were removed (something I was doing previously when trying to connect wirelessly BTW) and tried to connect using his Samsung mobile phone.

Again the app couldn’t find the device. He ran through the set up again and for whatever reason when he got to ‘Chose Room’ it came up ‘Lounge’ (the second box from the top of the options) instead of the box which usually pops up marked ‘ND5 XS 27575’* (this is what I’ve been using when the streamer was connected via the ethernet plug-in’s).

He tapped ‘Lounge’ and the streamer connected straight away. Clicked on Tidal and it played straight away. My dealer couldn’t really explain* why this happened but I was just happy and relived to get it connected wirelessly. The streamer was switched off and I opened the streamer using my phone without issue.

BTW No settings were changed with the router.

*Now there might be a few reasons why it couldn’t connect.

I use the OnePlus 6T mobile phone running ( their version of) Android 9.
My dealer was using a Samsung mobile phone (don’t know the model) running ( their version of) Android 8.

With both phones running different versions of Android and each company running their own ‘skin’ over the top of them there could be countless reasons why it wasn’t working.

Initially when I couldn’t connect my streamer I took it back to my dealer. It connected straight away at the shop and he also used the ‘Room’ marked ‘ND5 XS 27575’. Maybe there was a conflict when I was using the same ‘Room’ back at my house?

I wish I had a simple answer to what seemed to be a simple fix but I can’t. I hope you can make some sense of all the above?

I will get the streamer ‘hard wired’ in the future and more than likely buy an ipad but I’m skint at the moment so needs must.

Thanks for all the advice and tips, it’s much appreciated.


like I said, there is a bug in the Naim app on Android 9. I use a Google Pixel 3 XL with bog standard Google pie. Wouldn’t work at all to setup either the ND5XS2 (even after resetting it to factory using the rear pin hole switch) or the NDX2. Minute I used the Naim app on Apple iOS, it sprang to life.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.