Can't get NDX2 to work with external DAC

I’ve got a Chord TT2 with MScaler on demo from my dealer but I’m damned if I can make it work despite lengthy calls for the very helpful support teams at Naim and Chord so was wondering if the collective intellect here could possibly help out. (my dealer is on holiday so can’t speak to him).

Connection path is correct - digital out from NDX2 to digital in on the TT2 (via BNC to BNC cable), signal to MScaler via given BNC cables (and the DAC is working as is showing me a sampling rate on the MScaler), back into TT2 via aforementioned BNC cables and then out of TT2 via RCA into CD RCA input on 282.

If I turn the 282 to max I can JUST hear the track playing but at normal 9 o’clock levels there is nothing (I’ve also tried going to high gain on the TT2 and trying Amp mode to boost amplification. Same issues oocur).

I’ve selected Digital BNC output on the Naim app (both Native and PCM) and made sure the NDX2’s firmware is up to date.

I’ve taken the MScaler off the TT2 to create simplicity and no change but when I plug headphones in to the DAC they work perfectly (and sound rather good!) so the DAC on it’s own is working. I rang Chord and they said I’m doing everything as they would expect.

It’s driving me to distraction that I can’t make it work. Am I missing something blindingly obvious…

Did you switch the NDX2 to using the digital out instead of analog? There is a setting in the app

Edit: it seems that you did

1 Like

Yes - tried both Native and PCM modes

Just to rule out input mapping on the 282, if you set RCA output from the NDX2 and connect your cables from NDX2 to 282 RCA input do you get sound ? I take it you’ve set up the RCA input on the 282 - see section 10.2 of the manual….

The input selection buttons select the source input signal to be routed to the power amplifier and the loudspeakers. The NAC 282 and NAC 202 have six DIN input sockets and two alternative pairs of RCA Phono sockets. The RCA Phono sockets can be assigned individually to the cd and aux 2 input buttons in place of the DIN sockets. Input assignment setup is accessed through preamplifier program mode. To switch into (or exit from) program mode press and hold the prog key on the remote handset (with the handset in preamplifier mode). Program mode is indicated by a flashing indicator on the front panel volume control and, on the NAC 282, the record selection button indicators extinguishing. Note: If no function is operated within five minutes of entering program mode the preamplifier will return to normal mode automatically. Once in program mode press and hold the remote handset 1 key to select or de-select the RCA Phono socket input for cd, and the remote handset 6 key to select or de-select the RCA Phono socket input for aux 2. The corresponding front panel input buttons can similarly be used to select or de-select the RCA Phono socket inputs. The appropriate input button indicator will flash three times on selection of the RCA Phono option and once on selection of the DIN option. To exit from program mode press and hold the prog key on the handset until the record select indicators are restored and the volume indicator stops flashing.

1 Like

Edit I would test the RCA outputs and the xlr outputs from the TT2 using another amplifier/speaker set, this could be another stereo or a basic device such as a radio with aux input to see that line level signal is being output from the TT2.

I recall that I did have to fiddle about with settings to get my demo NDX2 and TT2 working in my system. Even when i did, I found that I needed the TT2 on high output.

Good luck!

I thought the Source (NDX) should be connected to the MScaler not “ Connection path is correct - digital out from NDX2 to digital in on the TT2”?


It sounds to me like you need to sort out the input socket assignment of the 282 to use the RCAs, as per the manual as quoted by James above.
Trouble is, I cannot believe that Naim support wouldn’t already have covered this when you spoke to them.

I think the MScaler is digital in, digital out? So this should be NDX2 connected to MScaler, MScaler connected to DAC and DAC connected to 282 shouldn’t it? You can’t use an upscaler on an analogue signal!



1 Like

Yep, hence my comment, it appears that isn’t the case from the first post…

Indeed I see you got there before me!

Sounds like Streamer to DAC is working correctly as headphone output is working.

Have you unplugged headphones from DAC as this sometimes mutes analogue outputs?

It sounds as if programming of RCA inputs on pre-amp is somehow wrong.

Note to self only buy Naim if I am prepared to use only Naim!

Correct Kevin, have done this but explained incorrectly, apols

So have you changed the input assignment to use the CD RCA input on your 282 ?


As James pointed out RCA on the 282 needs to be enabled.

Also digital out on the NDX2 set to digital BNC.

From the NDX to the MScaler use BNC1 input ensure MScaler input light is green.

Mscaler use 2x BNC outputs to 2x BNC inputs on TT2, on TT2 select this input.

TT2 to 282 check first step.

Hi James, no I haven’t (although v. surprised that Naim support didn’t suggest this)

I’ll do so tonight once I get home. I suspect you are absolutely right as I wasn’t aware you had to reconfigure the 282 to use the RCA’s

Will let you know how I get on

1 Like

It’s a bit of a faff to enable the phonos. What I mean by that is get the manual out. I had my 282 all nicely set, then it went back to Salisbury to have the illuminated naim logo changed ( bleed issue). When it returned it had been factory reset. So the manual ( for that read book) was required again.

A 13 pages book :wink:

I reckon this bugger is a book.
You just need to find the right chapter!

I have the Mscaler and TT2 … Digital out from your NDX2, to Mscaler, Mscaler out to TT2 Do not use amp mode you can seriously foul stuff up. TT2 should be in Dac mode. Do you have the quick setup guides?? you can get them from Chords web site. I’m really surprised your dealer didn’t help you

They write owners manuals for a reason!!!

I know how it looks :slight_smile: Still 13 pages that apply - but yes, I’ve overlooked things in there, too!

1 Like