Can't see downloads or music folder on Uniti Core with Mac

I’m setting up a Uniti Core to serve music to my NDX. I had all my music on a usb drive previously but some rips were poor so my plan is to copy my library to the downloads folder then as I rip my cd’s to the music folder delete them from downloads so I don’t have duplicates. I have the Uniti Core set up and transferred all my music to an internal SSD and I’ve ripped a couple of cd’s just to make sure all is working well. Everything works as it should except my Macbook won’t recognize the Uniti Core on my network. I’ve found the IP for the Uniti Core however whenever I try to connect it I get the following error:

"There was a problem connecting to the server “192…etc”. Check teh server name or IP address and then try again.

Oddly I can see the name of my music room (the internal SSD on Uniti Core) on my network but whenever I try to connect to it I get a failed connection message.

I’m using a Macbook Air with Catalina.

If anyone has advice on settings on the Naim app or my computer I appreciate any advice you can offer.



I had the same problem when I first got the Core. Just couldn’t connect to it via my Mac. Eventually I gave up and I now use the Core without an internal drive. Set up my NAS with Store and Download folders.
I think there is a flaw with the Core even if there are others who don’t have this problem

Thanks TNC. I’m going to give Apple a try as well as Naim I’m hoping to get this working. From what I can gather some have. If I find the work around I’ll post it here. Cheers

It’s working on my new up to date Mac, but I’m running beta software on the Core, so I’m not sure whether that is relevant or not.



Thanks David that’s good to know. At least I know it should work on a current up to date Mac so the issue is with Naim. I’ll reach out to them to see if they have advice to offer. Cheers, Dave

Where are you looking on your Mac? My Unitiserve shows up in the column on the L side of a finder window, most of the time. If it’s not there, clicking on Network in the same column shows it.

Hi Chris thanks for checking in. I’m using finder to detect the Uniti Core and by using the IP address is recognizes that it’s on the network but it won’t let me mount it as I keep getting an error message as per my post. I’ve successfully mounted another music server using the same process described in the Naim instructions however the Uniti Core won’t allow me in. It’s very odd.

A friend of mine says fully restart both the router and the Core.


1 Like

David thank you so much for asking your friend it worked! At first it didn’t but when I fully removed the power from everything in the chain including the router/macbook/uniti core/ndx and then re-built it with router/uniti core/ndx/macbook it appeared. I also noticed a novice mistake when it appeared again that I had an " ’ " in the name of the room name. I changed the name in the app and it worked. Appreciate all the feedback from everyone I’m quickly learning how valuable this forum is!

1 Like

TNC see in this thread my fix thanks to David. I did a full re-start in order. I also noticed that I had the room name with a possessive " ’ " in the title. I’m thinking this convention wasn’t allowing MAC to authorize access even after it finally showed up thanks to the re-start. When I changed it the room shows up in my finder along with the two folders downloads and music

Thanks Dave. It didn’t work for me. I did shut everything down (router, switch, NAS, Core) and restarted working my way from the router first - following the order that was given to me by the service technician at the Naim distributor.

This is reminiscent of the problem many of us had with the Unitiserve back in the day. It seemed to have a mind of its own, and you never knew from one day to the next whether or not your computer would be able to see it. For Windows users there was a suggestion that mapping the drive would keep it discoverable.
It’s a problem I no longer see, but I have no idea what changed to make it so.

Interesting ChrisSU…hopefully my issue is resolved. If it gets wonky again I’ll post back. Cheers

Lets hope you don’t need to! I am, on balance, a fan of Naim sources, but I have to concede that of all the network discovery issues I’ve ever had, I’ve had far more problems with Naim devices that I’ve had with all other networked devices put together. Not nearly a big enough problem to make me look elsewhere, but if only their products were as reliable as a Sonos Connect, this discussion forum might be less plagued with support requests from frustrated users than it is.

Yes it’s appearing to be a little tanglier than I was anticipating but hoping it settles. I had a NAS with a media server platform but it was so unreliable I figured that Naim products talking to naim products should be stable. Fingers crossed when I get it sorted it’ll behave! Cheers.

Glad it worked Dave. I didn’t actually ask my friend - he mentioned to me some time ago that he had fixed the problem that way and I just remembered it.

My MacBook Pro sees my Core ok and I noticed yesterday while I was idly playing with my iPad that that can also see the Core music and download folders. Over the years Naim have made a number of Core firmware changes to improve the network visibility of Core shares and it seems fine to me now, although as I mentioned in another thread I am running beta software currently.

I think keeping room names (and indeed usernames and passwords for audio) simple with no special characters is always a good move!



1 Like

Thanks David I haven’t noticed the rooms on my iPad I’ll have a look.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.