Can't update Mu-so 0530 to v4.3.2

Good evening, everybody. I have a question about my Mu-so 0530. I am using it with the latest Focal/Naim app on my iPhone 14. Whenever I start the Mu-so, the app goes to the room search screen and says it cannot locate the Mu-so, even when I’m standing right next to it. Everything is logged in to the correct network. The only way to get the app to recognize the Mu-so is to unplug it and reboot completely, then it works. This has been going on for a while, even with the old app, but I’m prompted to write because I got a notification of a firmware update from v4.3.0 to v4.3.2. The Firmware Update screen comes up in the app, but when I choose continue, the outer rings circles and the first two segments of the volume indicator go out as they should. After that, the update shows no further progress, and the Mu-so has to be unplugged again to reboot it. I’d appreciate any help you can give me to get this update done and to have the app recognize the Mu-so without having to reboot each time. Thanks!

Your phone communicates with the Mu-So over your WiFi network, it’s not point-to-point so your position in the room makes does not affect connectivity.

I’m not sure what Mu-So “0530” is?

Do you have a mesh WiFi system or any ‘mains over ethernet’ devices? Is the Mu-So wired or on WiFi?

1 Like

My Mu-so is the second generation device. It is on WiFi, and the app tells me that it is on the correct network. I don’t understand why, after the Mu-so automatically turns off after playing an album, it has to do a hard reboot before it will function again. Just tried the update again with my iPhone in the same room as the router, and the app still says it cannot find any rooms. The “0530” is the designation the app gives to this particular Mu-so, I guess.

The “0530” will be part of the unique MAC address of your device.

It may be worth doing a factory reset to make sure that nothing else is awry.

So no mesh devices or suchlike then?

1 Like

There is a box connected to the router that sends signal through the house wiring to two other boxes in the other end of the house. One box provides a wired Ethernet connection to another computer, and the other repeats the WiFi signal to the garage area. Is that considered a mesh system?

Through the house electrical wiring, or dedicated ethernet cable?

It isn’t but that is likely to be the source of your problem. Some mesh systems can be problematic too but I remember from reading on here that BTs is good.

The Naim App is well known for this issue. Indeed it sometimes doesn’t see my QB but Roon and Tidal connect see it no problem. And without touching the QB, if I try again later or the next day it will see it. Having said that it always sees my Atom HE that is hard wired…

1 Like

Through the house electrical wiring. I will try unplugging the box that connects to the house wiring and see whether that makes a difference. I don’t mind so much having to reboot the Mu-so, since I don’t use it every day, but I would like to be able to update its software.

1 Like

Is it possible to hard wire a Mu-so with Ethernet cable?

Yes of course.

1 Like

Thanks!

Tried disconnecting my router from the house wiring, but this had no effect on the problem. App still can’t find the room.

This sounds like it could be a problem with your Wi-Fi setup and phone.

I had a similar issue with my older iPad and NDX. Once the NDX was hard wired into the router the problem went away. Although never had the issue with my iPhone

1 Like

I wonder if I should try uninstalling then reinstalling the Mu-so from the app.

No harm in trying