Cant update N-Serve easily

Hi all,

We have an N-Serve setup that feeds 3 unitiqutes dotted around the house. Originally when we purchased the setup, we used the built in CD Ripper to take music directly from CD’s onto the onboard storage of the N-Serve. This worked really well and has been pretty stable for us for many years.

Now we are looking to update our music library with songs from youtube, spotify etc. We originally downloaded (Lets say) 100 songs from Spotify, and only captured the first 3 minutes of each Spotifysong (We were using a trial version of a software). We put these 100 songs onto a harddrive and plugged it into the back of the N-Serve. The Harddrive showed up and we were able to play the first 3 minutes of each song. We then decided to buy the full license of this software to get the full songs - This is where the error has occured. We took the harddrive out of the N-Serve, deleted all songs, added the new songs back and put it back into the N-Serve. The N-Serve will still only play the first 3 minutes of each song. I have confirmed that these mp3’s are the full songs (Sometimes up to 7 minutes) by playing directly from the harddrive on my PC.

I’ve tried clearing the N-Serve cache and it still doesn’t work.

Any ideas? And also looking for easier ways of managing the N-Serve. The desktop app is pretty poor.

I’d be interested in any 3rd party attachments or hacks that would allow direct playing from youtube/spotify (Perhaps via a raspberry pi?).

Thanks in advance!

I don’t think you can download and store songs from Spotify, so that’s probably why it won’t work.

As you have a UQ2 it’s easy to play Spotify directly through that, by using the Spotify app.

When you say N-Serve you seem to actually be referring to a UnitiServe - nServe is the Naim app for controlling it.

You should be able to get Spotify directly in the Unitiqutes but you need the updated firmware and if you are talking about the Unitiqute rather than the Unitiqute 2 then they need a hardware modification that would need to be fitted by Naim, assuming they still offer that modification.



David, the profile says UQ2.

Good point. In that case ensuring the UQ2s are on at least firmware release 4.4 and preferably 4.7 is a next step.



Hi All,

Thanks for your replies, I really appreciate it.

Yes you’re right, I meant unitiServe :slight_smile:

RE: UQ - I’m not sure if these are UQ2 or UQ? I connected to internal IP address and it says:

|Firmware Date:|2013-08-28|
|Firmware Version:||

Can’t see how to update firmware version though?

Hi the firmware can be upgraded via a computer connected to the usb socket on the back of the uq2. More info here, you’ll find the software and instructions.

To check the current firmware:
Use the Naim app for iPhone/Android
Click cog for settings
Click about
Mine is still on 4.4 I keep meaning to update myself!

It looks like you have a very early firmware version there. You should not attempt to go straight from there to the latest version in one go, so I suggest you get on the phone to Naim support and ask them what to do.

Also, using the remote, go to Setup > Factory Settings > System Status. Look for the line that starts BC SW… If the number starts with 3D you have the latest streamer board that can, with a firmware update, stream Spotify etc. If the number starts with a 1 or 2, you have an early model that would need to go back to Naim for a hardware update in order to use Spotify.

Thanks everyone.

I will check these today and get back to you with how I go :slight_smile:

FYI the firmware version shown on the web enabled display is not the same as the true firmware version displayed by the Naim app. I very much expect yours is 4.n
As an example mine is 4.4 but I see this via the web server:

|Firmware Date:|2015-09-15|
|Firmware Version:||

You need to use the Naim app to see the correct current firmware version. If I had to guess, “2.0.nn” etc is for the Ethernet and/or WiFi adapter.

I did wonder about that 2.0 firmware version, although ifI look at my streamer via its IP address in a browser I see the correct firmware version and a recent date. To be sure though, checking on the app or front screen would be the best bet.

With the remote:
Press the spanner
Up one, select factory settings
Select system status
Press up to get to number 29 and you will see the firmware version

Finally doing it myself!

Finished, now on 4.7
The web display has updated slightly;
|Firmware Date:|2018-12-11|
|Firmware Version:||

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.