CDS3 rather strange skipping issue

This doesn’t look like a mech fault - it looks much more like a disc pressing or mastering issue. Is the disc longer than 74mins?

Nope. The disc is not longer than 74 mins.

OK thanks. Probably a pressing or mastering fault then. Due to the narrowed and focussed read area, Naim players are not forgiving here.

I had a similar problem with my CDS 3 if i played a compilation cd with more than 20 tracks or around an hour of play, i knew it wouldn’t play properly and usually skipped at the beginning of the cd (this was same case as my CDS1 i used to have). The problem now i have with my CDS3 is the right channel has failed, concluding that DAC is the problem and i hope it can be repaired.

Hi Super
That happened with me except it was the left channel DAC. All repaired and checked over and sounding just great.

My DVD5 handles handles problem cds better.

Good to hear that it is repairable then.

1 Like

I must confess to not having any problem discs. Only some that refuse to be ripped.

Can i ask you Mtuttleb did you send your CDS3 to be repaired to Naim or someone like Class A Audio in Sheffield ? Thinking that they might do a quicker turnaround.

It was sent back to the Naim distributor in Germany who sent it back to Salisbury. It took a while but that was probably more to do with the customs traffic. In the end a patient wait is not so bad when you have other sources

1 Like

Oh okay, thanks for that, i just presumed you were in the UK. I’ll get it sorted in the new year now.

I have only heard of class A and that they do a good job, but if in the UK I would ask my dealer to send it back to be repaired and serviced.

1 Like

Had these issues with a CD5X. Ik took a few mech replacements before discovering the ribbon cable was the cause. For the S3 I don’t know if it contains such a ribbon but…anyway, maybe worth checking.



I tried the sellotape method again. It made things worse. The affected disc can’t even be loaded.

Many years ago, I did have a S3 with the 1250 mech (puck w the 3 rubber feet) and the sellotape method worked for me on some discs.

Many years ago when I had a CD3 (not CDS3) one solution for the unreadable discs was a thin disc of paper under the CD. mounted over the spindle and narrow enough not to cover the readable surface of the CD.

Might be worth trying

In summary, there are 2 problems I am facing.

There are some CDs that just cannot be loaded properly on the CDS3. For such CDs, I will face problems with the last few tracks. It will either skip badly or those tracks cannot be read at all, showing an ‘err’.

Then there are some CDs that load properly, but it skips on certain tracks, not necessarily on the last few tracks. And the skips are just a quick 1 or 2 seconds skip, but the skips happen at the same part of the track if it does happen. I can see some scratches on these discs but a couple look pristine. So I managed to get another of the same copy of 2 of such discs and it does NOT skip.

Anyway, all these I encountered are with the Chinese CDs (those made in Hong Kong, Taiwan - South East Asia).

And so far, even if the US or Europe made CDs are scratched, they do NOT skip.

So I guess my issue is a combination of the CDS3 being really sensitive (because all those discs play well on my bluray player) and the pressimg and physical condition of the discs.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.