CDX2 Problem

I’ve just tried to play a CD on my CDX2 this morning and there seems to be a problem. It was working fine last night, but today it seems unable to read / play any CDs. I’ve tried a few different CDs. The CDX2 was bought new in 2008 and has worked perfectly since then.

It looks like I may need to visit a dealer to see what the issue is. I’m wondering if the problem is that the mech needs replacing. I would appreciate any views on this from the experienced members of this forum.


I could be as simple as the laser (lens) needs cleaning.

Try a power down, then power up again.

1 Like

Blimey, just powered down and powered up again and it’s working! Thanks very much, Richard. Does this mean that the mech might need replacing in the near future, or is it a bit like a computer where a power off/on sequence mysteriously corrects a problem?


1 Like

It’s can happen if there’s a power blip or static discharge. Power cycle clears it.

I see. Hopefully, I don’t have any further issues. Thanks again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.