Connection problems with new QNAP

I have a SuperUniti which has been working fine for years with an old Netgear NAS. That’s getting close to full now, so I have upgraded to a QNAP (TS-431XeU) with Asset. Although it finds all my music fine and will start to play, it will only play for about 10 seconds before it says “Connecting… Please Wait” and then “Stopped”. Pressing play will restart the track from the beginning and it will play for another 10 seconds before the cycle repeats.

I’m pretty sure it’s not my network or cabling - I have even gone as far as swapping the Ethernet cable around between the QNAP and the Netgear, and the problem stays with the QNAP.

Any ideas?

Have you tried turning the SU off and on again? That usually fixes it whenever I get that message.

Do you also have twonky running on the QNAP if so disable it.

I tried turning it off and on but with no luck.

As far as I know I don’t have Twonky, unless the QNAP comes with it pre-installed. I certainly haven’t installed it in the few days that I’ve had it, and it’s not in My Apps.

Looks like the TS431 model is a recent edition from QNAP.

QNAP have removed twonky by default. Worth checking if DNLA is enabled but you may also use this to stream movies etc from the QNAP

How are the QNAP and the SU connected to the network? It sounds like the QNAP is connected to the old Netgear NAS - that sounds a bit odd.

I checked DNLA but it does not appear that this is installed, it’s not showing up under Apps. I have several other servers listed (Web, SQL, LDAP, etc) but not DNLA.

Apologies if I wasn’t clear about the cabling. I didn’t mean that there was a network cable between the Netgear and the QNAP. I meant that the Netgear is connected to my switch, as is the QNAP (and the SU). I swapped over the cable that went from the switch to the Netgear with the cable that went from the switch to the QNAP. The problem remained with the QNAP.

Any other suggestions gratefully received.

Do you get the same problem with other servers? My QNAP has an inbuilt server (called Multimedia Console) and, using the Naim App, the QNAP appears as a server and I can play tracks from this. If you do this, do you get the same cutting-out problem?


It doesn’t appear as though I have any other servers. There is no sign of Multimedia Server in Apps (I assume that’s where it would be) and nothing shows up when using the Naim App.

When you go into the Qnap, is Asset showing as running? If so, turn off the Qnap, SU, switch and router. Turn on the router. Wait a bit. Turn on the switch. Wait a bit. Turn on the Qnap until it’s fully booted - mine beeps loudly when it’s ready. Turn on the SU.

I have tried turning off and on in the sequence you suggested without success. In fact I had tried almost the same previously, albeit with the SU up before the QNAP.

I think maybe it’s an issue with Asset rather than the QNAP. I have noticed that the Asset server continually disappears and reappears every few seconds without any intervention. See attached photos - these were taken a few seconds apart with no intervention in between. This happens continuously - it’s there, it’s not there, it’s there, it’s not there, and so on. This is the same in both the Naim app and on the front panel display. This theory is supported by the fact that my Sonos system plays fine from the QNAP, and this doesn’t use Asset.

Is there another media server I could try on the QNAP?

It looks as if your NAS, being much newer than mine, has a different set of Apps, but I would still be surprised if some basic media server was not amongst them and I would expect it to be enabled by default.

As a first step (with only the QNAP running), I would suggest opening the Naim app, clicking on upnp, then keep tapping the left-pointing arrow towards the top left of the screen until the app displays a list of servers. If I do that on mine, it shows Asset, MinimServer and QNAP. (I installed the former two but the QNAP server was just there.) I can play tracks with the QNAP server, though the interface is pretty crude. Does your setup show something similar, or does it only show QNAP? If the former and you play a track using the QNAP server, does it also cut out after a few seconds?


You should see this.

Whereas I get this (ignore the Marantz):


I would turn off upnp on the TG582 and see if this is conflicting with Asset. Also looking at the screen are you sure you dont have another upnp server running on the QNAP

Thanks everyone for your suggestions. It definitely seems to be a problem with Asset rather than the QNAP.

PeakMan - All the other servers displayed on the SU are from elsewhere, not the QNAP, eg; Sonos, TV, etc. The QNAP server was not started. I started this and tried it. This works fine, it does NOT cut out.

HungryHalibut - I can see the Asset logo in the Naim App (among others), but as mentioned, it keeps disappearing and reappearing.

HiFiman - The TG582 is the router supplied by my ISP. I have turned off the UPnP server here, but the problem with Asset remains.

OK Perhaps there is a problem with your Asset installation. I would suggest removing it and re- installing. If the cutting-out issue persists, it would probably be worth flagging up the issue on the Asset upnp forum. You’ll find people there very helpful if my experience is typical.


I took your suggestion and started a post on the dbpoweramp forums. After various suggestions similar to what was put forward here, one of the guys from dbpoweramp got involved. After several builds of a new Beta release of Asset, both to try and fix the problem and log additional diagnostics, problem was solved. So some sort of bug in Asset, or at least in as much as the way it was reacting to something strange with my set up (he said that the Asset was incorrectly reporting no network availability).

Absolutely superb support from them though. Although I haven’t had the chance to explore Asset much yet, there support really is second to none and I would certainly recommend it on that basis alone.

Thanks everyone for your help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.