So I love my Naim Muso cube of joy! But getting it playing is a perpetual pain:

  1. I have to log on to Bluetooth each time if I want to listen toTIDAL direct from phone. This is fine - but it doesn’t always work.

  2. So I log into the Naim native app which is often successful. About a third of the time it gives the error message unsuccessful. After a few fiddles it usually works.

  3. Sometime the native app just doesn’t play any music. I always check the volume is up. But usually the only solution is unplug the cube and start again.

I always get their on the end, but I really want an easier experience? Any advice? My WiFi Is good and I have installed a booster.


Have you tried running a wire? The WiFi capability of the original muso is somewhat lacking.

Thanks - so I’ve just switched off the extender. And its carried on playing happily! Which suggests it was never connected to the extender? Hmm?

Well its a new MUSO, I bought it in April. But actually when its being a real pain, I would like the option of a direct line to my phone. I’ll have a go, although I’m quote sure how to! Guy

I meant to wire it with an Ethernet cable to your network.

Ah OK. I don’t have an ethernet cable, but it could be a back up option. But the router is in the bedroom and the MUSO in the sitting room with the kitchen in between. The booster is int he kitchen,

Well my WIFI coverage is actually really good. I have no problems with anything age Netfilx etc. So I’m guessing that isn’t the root of the problem.
Thanks for your advice - it is appreciated!!

If you prefer to use the Tidal app instead of the Naim app, I would use AirPlay or Chromecast to stream Tidal over your network. This should be better than Bluetooth, which is a low range point-to-point connection from phone to streamer that is more likely to drop out, and probably has lower sound quality.

1 Like


If you’re using 5GHz try 2.4GHz. 2.4 has better range.

It should work perfectly well without the need to connect with an ethernet cable.

It’s marketed by Naim as: The Premium WIRELESS Speaker Your Music Deserves.

Chris - I’ve just tried AirPlay - it works!!! Never heard of it before. THANKYOU!!!

1 Like

It is falling again. Unfortunately AirPlay just stopped working. Blue tooth was working ok - but hot and miss.

I’ve now attempted to re establish a connection and I’ve lost connection entirely. The set up process notes tells me NAIM can’t connect because of an iOS upgrade so I have to do it via the AirPlay in settings. I’ve tried this and it gives me an error message.

This is really depressing. I’ve had this for seven months and it’s never worked reliably.

My guess is that there is something in your network setup that the Muso doesn’t like.
You mentioned before that you have some sort of WiFi extender - can you tell us what exactly this is, and how it connects to your router?

It’s a TP Link connecter. Should I try without? My TV works perfectly well without the connected. I only bought it because I was have problems with the NAIM. I can’t connect it at all now. I’m thinking of taking it back to John Lewis! Advice really welcome.

Hi Guy, can you ensure you are on iOS 14.3 and the latest version of the app (5.19.4). If you still have issues then please have a chat with support on
Thanks, Tom

TP Link make a whole range of network products, can you say what model it is? That might help pin down any issue that it’s causing. I see Naim support have picked this up, hopefully they can help too.

I’ve just uploaded a photo of the TP link. It’s a plug in gadget. RE 205. AC750 WiFi range extender.
Thanks for your help!

Hi Tom
I upgraded from from 14.2 to 14.3. And it all seemed to work better than before.
I played successfully from within the NAIM app. i then tried through airplay but it failed. Then I tried through blue tooth and it failed. I went back into the Naim app and that now failed too. Sadly another false Dawn.
I’m fairly certain the Naim app is the latest although I don’t know how to check. But if I go to the App Store it suggests I already have the latest.
I’ve had this since March and it’s never really worked - very depressing.
Can you suggest anything else?! Or should I take it back to John Lewis?

Ok so my muso cube has a nights sleep and this is what happened this morning:

  1. All working fine in the app.
  2. All working fine on Airplay
  3. Not working on Blue tooth

Just to be sure, I’ll do the cycle again:

  1. All good through the app on Tidal
  2. All good on Airplay
  3. Still no good on Bluetooth

If this remains, I can live without blue tooth. Progress or a false dawn. I’ll keep you posted (sorry!)


I asked when you first posted if you’ve tried running an Ethernet cable. Have you?

Not sure if this will help at all, but I have been having connection issues between the app and my Naim Musos (Gen 2 and a gen 1 Qb). Suggestions from the forum and from Naim support that have helped (I wont say fixed until I have used everything for the whole weekend!):

All of my Apple devices are on IOS 14.2.

On every Apple device I have turned off the “Private Address” option on the home network.

I have upgraded the Naim app to 5.19.4 on all devices.

In addition I have turned off the “Smart setup” option on my router (BT).

I have also turned off “extended UPnP” security on the router.

Not sure if you can apply any/all of these if your setup, but it might be worth trying?