Core not Backing up to Synology: Driving me nuts!

Hi all,

I’ve been using my Core for streaming through the Atom for a few months now and pretty happy with it.
However, since I have it, I was able to back up to my Synology DS215 only once in last December.
Since then, I’m having trouble with the Core seeing the NAS on my network and then backing its internal storage up to de NAS.
Nothing has changed on my network and the NAS can be seen by the Atom and my other devices (TV, i-devices, etc.) with no issue at all. The Core won’t see the NAS consistently and when it happens to do, i cannot get it to back up to the Syno.
I did the usual restart, network reset including the router and the NAS itself.
The Core is wired to an Apple extreme Time capsule that itself hooks wirelessly to a “master” time capsule who distributes Wi-Fi signal to all the devices of home, including the NAS (connects wirelessly to the network aforementioned).
Both have been operating flawlessly for years now, and everything is set up into the same room.
I don’t want to mess around with cables everywhere in the apartment, hence the convenience of using a solid wi-fi network, allowing me to store the NAS into a more discrete place, at around 3 meters from the Core and Atom.

I went into the NAS settings and made sure that the shared file I created specifically for the Core’s back up carries the same workgroup as into the naim’s app (I simply called the later “Naim”) and also made I entered correctly the credentials for allowing the Core to connect to the NAS with the right workgroup, username and password.

I also created a specific Usergroup as shown below. t

I also checked that the NAS settings for file sharing allows SMB1 up to SMB3 protocols.

But now I’m clueless, I still don’t get why the Core can’t see consistently the NAS while the Atom shows it everytime I go into the server menu on the Atom. Core only sees its own internal storage. And when it happens to spot the NAS, it won’t back up.
I shall specify here that the 1st and only back up I’ve been able to do in last December has been triggered by myself when the app gives you the choice to immediately perform it or set up a back up schedule.
But after that, I could not program a single back up.
Now I’m speechless and clueless. I don’t want to hook up a hard drive through USB to my Core while I still have plenty of space left on my Synology.
I wrote to Naim through the support menu of the app and the only answer I get from the support team was to make sure the workgroup name and the password in the app and within the Sync was consistent and the same.

Can anybody here could help me finally getting this to work ? I’m pretty sure it has nothing to do with my network itself but is there anything else, anywhere else into the settings of the Core or the Synology I should dive into to make it work.
This is literally driving me crazy right now.

Do you have a Guest User set up in the NAS and does the User have read/write access to the Naim Backup folder under both the User section of the Control Panel and the Shared Folder section?

Yes the NAS has a Guest User account set up and that account has access to the Naim backup folder and read/write permission as well. I just checked that again on the NAS, although I don’t know how that would affect the Core accessing the backup folder.
I have to specify that within the Naim app, under username and password, I entered there my own account’s name and password that I use to access the Synology (as admin), which I think are both different from the login details that I set up for the Guest account, otherwise I don’t see the reason why I’d bother creating a guest account at all.
But anyway the Guest User can access the shared folder to be used for the backup.

I backup my Core to a DS215j. You mentioned you’d called your workgroup ‘Naim’. I don’t if it’s significant but on my Synology the workgroup name is capitalised (ie. ‘NAIM’). Have you also configured the NAIM workgroup name in the NAS Control Panel | File Services | SMB/AFP/NFS tab?

Hey linq,
Within the Naim app settings my workgroup name spells “Naim” so not capitalized, not sure that’d make a difference but will try when i get home tonight
Within the Synology app though, under the Files services subsection, i let the default workgroup name’s to “Workgroup” as I did want the NAS to keep operating normally for some other purposes and other services provided by the NAS.
Am I wrong in thinking that changing that to “Naim” like within the naim’s app itself would affect those other services (like browsing into the file directory remotely when out of home or some other things) ?

I did not get it that beyond creating a specific usergroup and shared file specific to the backup I also had to change the name into the SMB/AFP/NFS tab.
Could this be the reason then for not been able to backup ? can somebody confirm?
And what if I want to use some others media like say my Plex or Minim Server also installed on the NAS? Would this change also affect those ?

I thought workgroup wasn’t actually a valid concept since the demise of Windows XP? So maybe a concern if you have a Unitiserve but not if you have a Core?



Well my router and the whole network itself including the devices distributing the WiFi signals to core and NAS is through Apple devices (namely time capsules extremes, 3 of them) and these all works through SMB I think
Hence activation of the protocol within the NAS itself for file sharing. And I do think that workgroup in this case has to be set up
And as far as I know thats not a problem for the core to handle. So don’t think the problem is that

It’s well over a year now since I configured my Core to backup to a DS215j so details are a little hazy but I’m certain I read somewhere that the Core needed to be part of a Windows workgroup called NAIM. I recall trying many different configuration options and the two things that finally got backups working for me were configuring read/write permission for the Synology Guest account (on the file share being used for backups) and setting the workgroup name to NAIM.

I don’t use Windows workgroups for anything else so I’m afraid I can’t advise on the implications of changing the workgroup name (although as David mentioned it’s a very old concept now and I’d be surprised if it did affect anything else).
Regards, Ian

Under SMB, my Workgroup name is “NAIM” not “WORKGROUP”. Which may or may not be relevant.

Well, I’ll try that this evening. For now, being out of home, I’ve just replaced “Workgroup” under SMB tab of the Syno. with “Naim” (same as within the Core settings then) will check once back home if the Core connects well to the NAS and is able to back up.

Can anybody tell me this: within the core settings for accessing shares should I put under users & passwords the credentials I use myself for logging to my Syno. Or just the guest user name and its relevant password (which I already created in the NAS and have set up rights for write/read in the specified back up folder) ??

I also noticed the date of this file below within the shared folder which I specified to be used for the core back up has now changed to 05.01
Does this mean the core back up successfully ?
Sorry I’m out of home right now so I can only access to the NAS for the time being

When the Core performs a backup, I’m reasonably certain it automatically attempts to access the NAS shared folder (the one you select in the Naim app when you configure a backup) using the Synology Guest account - you should NOT use the credentials for your own NAS login account.

I also have a file called .naim in NAS shared folder that I use for backups. The ‘Date modified’ for this file is updated every time a backup is completed. It sounds like your backup may now be working.
Regards, Ian

Hi linq,
well this has been very confusing and the naim’s website support page is not informative at all regarding back up procedures. Then so far, thought that the app’s user and passwords fields should include and apparently I thought wrong. I changed those yesterday to include the guest account information instead and set up a new backup plan to once a month.

So based on your saying about that .naim file, should I assume that the Core did perform a backup then? But when looking within the app backup status section it sounds like nothing happens though because the backup entries are all empty or at 0, the system display that last operation was “standby”.

Something that I forgot to mention earlier is that I set up the Core to go into standby mode after 30 minutes. So will the Core still back up under network standby mode ?

Also, I have to specify that since the initial backup in last December (triggered by me before setting up a regular backup plan) I did not add any new music files into the Core internal music-store.
So my question is : does the Core perform an iterative backup, e.g. will backup only newly added file since the last backup?

If yes, I assume this will be the reason why I thought so far that the naim’s backup Music and Download folders date of last change remains on “December 2018” within the Synology. Is my understanding correct?

I called Naim on the phone by the Uniti support team was not really helpful. And as mentioned the support page is not more helpful and doesn’t provide any details on how to do this

The backup is iterative so no further backup will occur if you have not added any music. For future reference, the quickest way to check whether it has worked is to look at the backed up files on the NAS and see whether it holds any of the newly added music.

thanks plenty PW42. I’ll do a proper test during the week end and report back on here
My apologyzes for all the questions sounding a bit stupid but I found the Core much less intuitive to use then the Atom, and naim’s poor specific support page does not really help.

Not stupid at all. I’ve also had my problems with backing up my Core to a NAS although to be fair most of the problem lay at the NAS end. Backing up to a USB drive has been seamless.

Hi Bouba,
A quick way to test backups might be to to temporarily delete a ripped CD from your Core, perform a backup, re-rip the CD and then backup again. If you check the Backup status screen (in the Naim app) after each backup, it should confirm that a number of files have been processed (ie. removed or added). The .naim file timestamp should also change after each backup.
Regards, Ian

Hi Linq,
that’s a very good idea, I’ll try this this afternoon and see what happens.
Thank you so much to all for your great help.

I’ve got the same issue - have tried everything. The synology nas is not being seen by the core - have tried all of the usual things re permissions. And as you say the naim website is hopeless


Hey Nick, welcome on the forum.

@Linq and @PW42, I made a test the day before yesterday but still with no luck:
I ripped a CD on the Core, set backup plan to weekly and the Core showed that 1st backup was planned the day after at 2.00am. This morning though when I looked at the shared backup folder, I did see the .naim file modified date has changed indeed to 10/05/2019, but still, the album I ripped was not there in the MQ folder.

Really strange and very annoying.
The only positive point now is that since I changed the user/password and Workgroup settings, the Core seems now capable to spot the NAS on my network all the time, but still no luck with the automated backup

And even stranger, once I set up the backup plan to perform weekly or monthly, the app will show a “next scheduled backup date” but once I go back to the “Backup status” section within the app, that section is empty and the app just keep saying “No backup unit found” or something alike.

I’m speechless, and It’s now really getting me mad.