Does my Muso 1st Gen Have Covid?

The Muso stopped streaming mid-play on Friday night. It doesn’t show up in the App and I can’t add it as a new device. I can see it on the “select Muso” screen and occasionally see a pop-up saying it’s going to connect to the correct wi-fi but it never gets any further. Mostly I have a solid purple light (flashing when trying to set-up) but occasionally, I get a red “hardware fault” light. It doesn’t show up on the network when I plug it in with a patch cable. I have short and long reset it, with no effect.
Is there anything I have missed?
Looking at this Forum for the first time in a while, I see about the firmware update. Could that be involved somehow?

It needs a double vaccine: restart your router, wait, then restart your Muso. Eventually install the app again.

On top of the decent advice above, I would ensure you are running the latest version of the Naim app (Apple iOS 5.22.1 or Android 2.22.1), and then fully power down your phone/tablet and back up again.

Try those and we can go from there re Firmware etc.

Rebooted modem and Muso (not Ubiquiti access points); reinstalled App. Muso sat with purple light flashing while the App tried to connect it. Failed. Solid purple light now. Suggestions?

Unplug it from mains power for at least 15 minutes and then retry

Will do. And I forgot to say I had also powered down the iPad as suggested.

Powered off, retried connecting. After 30 mins on flashing purple the Muso went to solid purple.

1 Like

Have you tried moving the QB Mk1 near to the router. Connect to router with a cable and try to set it up.

Have you considered setting up your email to auto reply

to every email you receive. Save a lot of time. :grinning:

1 Like

I just did a speed test on my phone (sitting right next to the Muso) and I get 275 Mbps over the wi-fi so I don’t think it’s that. I will try with a patch cable into the switch but I’ve tried that before, so I’m not hopeful.

1 Like

No luck with the wired attempt. Still 30 mins of flashing purple followed by a solid purple light.

I would suggest you contact - link to this Forum thread so they have all the background to help

1 Like

I received a suggested fix from Naim via my dealer and it worked. Fix pasted below for information:

  1. Get the unit to the flashing purple stage
  2. Go to the Apple device’s settings, then into the WiFi networks menu
  3. There should now be a network listed with ‘Mu-so’ in the name - tap to connect to this
  4. The ‘set up new Airplay speaker’ window should appear, simply press next and wait for it to do its stuff
  5. ​Once it reports that it’s been set up, head to the Naim app and check for its presence & network functionality
  6. If not there, go to set up a new product, head through and select the ‘white’ option for the LED colour - the unit should appear in a list from where it can be selected and the setup completed.
    So it looks as though it was an App problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.