Firmware update 3.8.4

I just updated the firmware of my NDX2 to 3.8.4. (5453) Does anybody know what the update contains?

Isn’t there a firmware history log on their home page anymore?

I saw an update was available for the ND555. Not going to update yet, will await feedback from others first. Normally more of a buzz around updates so maybe a small fix…

Can’t remember precisely, but something about a potential issue with dimming - nothing major

Just updated my ND555. Smooth and without problems.


Done dat, all good.

Is it playing louder than it was before the update?

Nah, don’t be daft, not possible. :man_shrugging:

1 Like

Same here … found nothing on changelog. Will wait until it is fine to update - strange that there is nothing as a changelog. In the app the dimming problems are mentioned

This update has fixed the issue I had of not being able to dim the lights :clap::clap::clap:

1 Like

I just updated my NDX2 to 3.84 with my iPhone. All went well but the NDX2 disappeared from my iPhone and almost never to return. However, the NDX2 was happily working on iPad. In the end, I had to delete the Focal/Naim app on my iPhone and re-install. All is well. Still really don’t know what it fixed, but it certainly used up a lot of my time trying to return things to normal. Oh well…

You probably didn’t need to delete the app and reinstall.

These are other things you could have tried:

  1. pull down and release the rooms screen. This makes the app look for rooms again. It may solve the problem.

  2. stop and restart the app. By this I mean go to the app switcher screen and swipe the app away. Then restart it by selecting it normally This is almost certain to solve the problem.

  3. Restart your iPhone. This will also restart the app.

The only thing you do extra by deleting and reinstalling the app is that the phone will forget all of the associated data. But then once reinstalled it looks for the room the same way as the earlier methods.

I had the same problem on my NDX2, because the update stopped half way. After I pushed the power button on the NDX2 it continued. The app came back with no problems after that.

Well I am not too sure about that. I did 1,2 & 3. Nothing. That was why I deleted the app. All the data went bye-bye. But when I restarted the newly installed app, it was still there. This might be because the iPad app was still running. The only difference was that the order of the Sources Layout changed but my customised list was still there. Also, I use Qobuz and all that information was still there independent of the Naim. The annoying thing was I got a bluetooth error saying it wasn’t active. The iPhone was set up with bluetooth active. When you try to activate it on the NDX2, it says you can’t do that because I have wired connection to the internet. Maybe that was the problem. Poor error checking after the update. Anyway, all seems well. A lot time spent for no noticeable change. Such is life in the fast lane I guess. Thanks for the comments.

Oh well glad you sorted it out.

The Bluetooth warning is something we have reported to Naim in beta testing, although we didn’t test this tiny release. Apparently it’s because the Apple system takes a while to respond to Bluetooth being there and inform the Naim app. So nothing Naim can do about it since they need Bluetooth to be on for the Focal Bathtub earphones (or whatever they are) to be found by the app.

I had exactly the same updating my ND555. The streamer’s ‘room’ disappeared and was hard to get back with any method using the app. A restart of the streamer fixed it for me.

Tried that, too. No luck. Such is life. At least it came back from the ‘dead’.

1 Like

For me the NDX2 has disappeared but then it has appeared again in about 5 minutes after the setup was completed

Is this a recent update if I may ask?

Yes. Released this week I think

I had the same problem with getting the NDX2 to reappear in the app. All the usual tricks with the app didn’t work. Eventually I unplugged the NDX2 for 10 seconds. All fine.

1 Like

I haven’t had this update with an ND5 XS 2, should I have done?

I’m also confused maybe the update is something to do with the screen we don’t have