Firmware update has bricked my Mu So Gen 1. Help!

Can anyone help.

I tried updating the firmware but it has bricked my Mu-so QB. I have tried rebooting, it shows the blue light on the rear while it powers up, on the volume dial it loads the lights (3 ‘bar’ lights at a time until 9 lights are on, finally then lighting up the remaining 3 bar lights so all 12 bar lights are on). After a few minutes the 12 lights go off to be replaced by a single bar light and the blue light on the rear changes to orange.

When I go into the Naim App it is stuck in a loop.

It says it still needs to download the firmware update but when you click on download it again instantly switches to say download is done and the Mu-so is rebooting and loading software (it’s not).

I spoke to Naim technical support who suggested connecting via Ethernet cable directly into router which I have done but it makes no difference. I have turned it off unplugged overnight and tried again but it just starts working through lighting up the bars again (with blue light on rear) but finishes the same.

After the process, apart from a single bar light, lit up it is dead - the App just says it needs to download firmware update.

Anyone had a similar problem and know the fix. I’ve tried pressing reset button with a pin but it made no difference.


Can you confirm you have nothing plugged into the USB port? Also, that you have the latest version of the Naim App installed. Have you restarted (power off/wait/on) your router?

Hello, yes there is nothing plugged into the USB port. The only thing connected is power and Ethernet running directly into router.

I updated the App before doing the Mu-so update. I have tried deleting and reinstalling the App.

I can’t think what else to try. It worked perfectly before I did the update.

I tried rebooting the router but it didn’t make any difference. Each time I reboot the Naim, it powers on with the blue light and slowly lights up the ring on top but eventually reverts to a single bar lit up with the blue light changed to red. On the App it finds the Qb eventually in the room list but just keeps saying it needs an update but when you click to do the update it just acts as if it has downloaded and sent it to the Naim (this happens instantly suggesting that it isn’t doing anything - nothing changes on the Naim - the light at the back remains red and a single bar is lit up on top).

Just to be thorough, did you dump and re-load the app also?

1 Like

Looking at another thread about the same issue it seems Naim support sent an update file that could be installed locally. So, best to contact support again in the New Year.

Yes airedog I deleted the App and reloaded it. thanks for the thought though.

1 Like

Thanks for the info XMB, I hadn’t seen that. I will wait until the New Year and try technical support then. I am sure it is a software issue to do with the update, so hopefully they have the file and can help me instal it. Thanks for your advice though - very much appreciated. This is my first time on the Naim forum and I really appreicate the advice.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.