First time post...weird AirPlay issue

Hello all,

Firstly, apologies for jumping straight in with a question! I have done a search and cannot see anyone having quite the same issue as me. It’s a little complex but here we go…

The basic version is:

My Uniti Nova is available as an AirPlay device when using my computer. It is not, however, showing up via my phone, nor can I add it to the Home app.

What is odd is that this was working fine until recently. The Nova was part of my ‘home’, and could be controlled via Siri etc.

OK so this is where it gets a bit more complex…It is wired, as is my computer, to a power line system. This means that it is not on Wifi. To complicate things even more, the wifi within the house is via a second router as the Sky one I have is totally awful and in a terrible part of the house for signal. So the network in the house is more complicated than usual.

However, as I said it was working fine until recently. The only recent issue I have had is with the unit not powering down properly. A call to Naim support suggested turning off UPnP, which on rare occasions is known to cause this issue. I cannot honestly say whether the issue started with this change or not, but I cannot see why it should. I have tried reenabling it but that hasn’t fixed the issue.

Another odd thing is this: I tried resetting the unit to factory settings but had to manually enter the IP address to get it to show up in the app.

So to recap: I can ‘see’ the unit via my computer’s AirPlay function. I can ‘see’ it via the app. I cannot see it through either the Home or Music apps on my phone…HELP (please…it’s driving me nuts).

There’s your answer. You most likely have 2 competing networks. Make sure the second one has dhcp disabled.

I raised something very similar a couple of days ago. See below, where the fix was to change the mode of my second router to AP (Access Point)

Thanks both for your (very prompt!) replies. I have connected the Uniti via wifi and then restarted my phone and it is all now on the same network and can be added to Home and use Music via iOS. However, ideally I’d like to use the ethernet connection so will have a look at the network settings on the routers and see what is going on…

As mr gadget says, we both think your WiFi router is creating a second competing network, very likely with a different 192.168.x.y numbering. If you can get into this router control panel and switch off dhcp / set it to access point mode (depending on the router make) it should fix it.

1 Like

Thanks again. On the main router, the wifi is switched off. Wifi is only being generated by the second router. Feel like I need to draw it out or something to better-explain what I am saying…

It’s not about the wifi. Every router by default will assume it’s the only one in the house, so will be set up to assign IP addresses to every device that connects to it. You need to stop your “wifi router” from doing that, as it is competing with the Sky router. Anything connected to your wifi router believes that is the only network in the house. Anything connected to your Sky router believes that is the only network in the house. To fix that you need to tell the Wifi router to stop dishing out IP addresses by either disabling dhcp, or switching on AP mode. Your wifi router needs to be wired to the Sky router and then anything connected to Wifi will pick up an IP address assigned by the Sky router. You will then have one unified network, and your phone connected by wifi will be able to see your Nova connected by wire.

1 Like

That is exactly how I have it, although I did enable it with a different SSID and enable it when I turned the second one into AP mode so that I always had a way to get back onto the LAN, however I didnt need it in the end, as AP mode fixed everything, as @robert_h said it allows the main router to dish out all the addresses (DHCP) and your second router becomes properly part of that network rather than create its own separate network

Thank you all so much for taking the time to reply. I have turned off DHCP on the router generating the wifi network and reattached the ethernet cable to the Uniti. I’ll see how that shakes out…!


Unlike some of the other discussion, I don’t think this is related to having two dhcp servers or two separate networks in your home (one for wired and one for wifi) since you can control the (wired) Nova via the Naim app on your (wifi) phone. If you had two networks, you would lose all contact, not just Airplay.

As it happens, I’ve had a very similar issue with Airplay connectivity and did some deep dive debugging with @Will, a Naim development expert. The Bonjour discovery protocol is at the heart of this and there isn’t a problem at the Nova end… but it can be tricky to figure out where in your network things go awry.

My situation is similar, with some Airplay connections working and some not, including success when both devices were wired or wifi, but not when one was wifi and the other wired. I even had an issue not being able to discover the Nova from a Mac mini located on the same switch…

I believe it is related to the Bonjour beacon function where Airplay devices advertise themselves on the network, and then get populated in the list of end points when you go to choose Airplay (from your iPhone, say).

In my case, I have Uniquiti UniFi switches and access points. It turns out to be a known problem in that ecosystem… and in several others as I found when I read up a bit more. I definitely would not be surprised if your power line adapters did not work reliably, for this particular function, for example.

To check if your issue is similar to mine, try using the Naim app to disable the Nova Airplay input (Settings → Input Settings → Airplay) and then re-enable it after a few seconds. Go immediately to the app you’d like to use to Airplay (RadioParadise, whatever…) and watch the list of endpoints being built. Do you see the Nova? If you select it right away, does it play? In my case, this workaround functions… but the entry in the list of endpoints does not remain. I think this is related to mDNS broadcast / re-broadcast problems so that’s another Google topic for you to scope out. It’s a wide world of “works sometimes, fails sometimes” out there!

If this (force re-broadcast from the Nova) works, then you can start examining your network equipment one piece at a time. If it doesn’t, perhaps you can strip right back to basics (temporarily) and use wired connections to your ISP modem/router, and your ISP wireless, etc. For sure the Nova works well on Bonjour (it is Apple Certified), but it’s not always the most reliable protocol out in the wild … as you’ve discovered too.

Anyway, sorry for the long ramble as I stumbled to share my own experience. Best wishes.

Regards alan

OK so now I am totally confused as Alan, what you say about the visibility of the airplay target makes sense, even if DHCP wasn’t set up correctly. I am still messing about with settings…fun and indeed fun.

OK so…whatever I have done we have a fully working Uniti that is now happily part of the wider house sound system. Thank you all for your help. Brilliant stuff. To recap, this is what I have actually done:

1 Connected the Uniti via wifi rather than ethernet
2 Altered wifi router settings to make it an access point rather than a DHCP server
3 Reconnected the Uniti via ethernet

It started working at step 1, and steps 2 and 3 seem to have allowed it to play along with the rest of the AirPlay devices. I wonder if this at all relates to Alan’s post. Suspect it does.


It’s doing number 2 that has sorted it. Prior to that, your wired and WiFi networks were separated. You could use airplay from pc to nova because they were on the wired network. Moving your nova to WiFi meant your phone could see it.

Glad you are up and running as those router control panels can be confusing to navigate (yes Fritzbox I’m talking about you!)

Glad all working - isn’t this Forum great for things like this. It’s the sort of issue that you may have struggled with for ages to get solved, and here you are working in a couple of hours. There is a lot of very helpful people on here

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.