Forum iPad problem

I’m just getting a blank white screen when I try to log onto the forum with my iPad all my other favourites load ok including the main Naim site.
Even tried accessing the forum via the main site but still get the blank white screen.
I’m getting withdrawal systems any ideas as I’m a bit useless with all this computer stuff.

I’m reading you post on my iPad, so it’s all fine. Try rebooting it. That’s what any help desk would say.

I have seen one or two other people in the forum reporting this problem. They were running old IOS operating systems. @Richard.Dane has reported it to the web developers. So I suggest update your IOS if you can, otherwise wait and it will probably get fixed soon.



Are you using an old iPad with old Safari? I’m still waiting to hear backf from our Web Developer if there’s any fix beyond a new iPad…

Hi Richard
Yes it is an oldish iPad and is probably running an old version of Safari, the thing is it has worked fine up to this point!!
I’ve tried turning flight mode on and off which was a quick fix which did’nt work I found on the net even tried emptying the internet cache (whatever that is) but still no luck.

Have you tried using the ‘DiscourseHub’ app?

You could try another browser like Chrome for example. I have no idea whether it would work but it’s up to date and free so wouldn’t cost anything to try.

Yes, david makes good point - if you can’t update any further with Apple then you may need to use a new separate browser. There was a Discourse update a couple of days ago and it may well not work properly with old browsers unless they are updated. Have you got the Discourse App for the forum?

Hi Richard

I wasn’t aware I needed an app for the forum, I think it sounds as if the Safari needs updating and if that doesn’t work then it will have to be Google Chrome

My sons coming over tomorrow and he’s a lot more clued up on this type of thing so hopefully he will be able to sort it out.

This is why I’m sticking with vinyl and an LP12 !!

Yes, there’s a Discourse App that you can download for free. However, if you cannot update your iPad or Safari, you may find it unworkable as these things are developed and updated to work with the current latest builds.

Yikes ! This means we might all have to keep buying a new Mac, i-Pad and a new i-Phone every couple of years, just to keep in touch on the Forum !

At this rate, some of us won’t have any pension/income left over for hi-fi…and Naim and the Forum will be out of business !

1 Like

Both the Discourse hub app and Google Chrome app need IOS 11 or later. So you can check what your IOS version is and know immediately whether either of these will work.

Maybe it’s obvious, but just for clarity, the Discourse hub app is an alternative way to access the forum. You don’t need it if you use a browser instead, but if your browser won’t work with the Discourse server on which the Naim forum sits, then you need a browser which does work or the Discourse hub app. It doesn’t hurt to have both but you will only be using one at a time.


There doesn’t seem to be an iPad2 app iOS 9.x is the highest it supports, where folk can view the Naim forum.

I think something has been introduced in the latest update that stops it being displayed. Hopefully it should be possible for Naim forum site to detect the version of iOS/Safari and skip this something for those users.

I have the same problem; Ipad 3 latest IOS allowed is 9.3.5 and forum will not run on that.
Had to log onto my laptop to check it was the Ipad that the forum host had the problem with and clearly it is. My laptop gets little use and I don’t intend firing that up every time I just want to check the forum!

Oh well, won’t be able to keep an eye on things as often now…at least I’ll save some money :wink:

1 Like

I have now realised that I am unable to load the required version of the operating system on my IPad which will enable me to run the correct edition of Safari or install Google Chrome to enable the Naim forum to run.
To be perfectly honest I do find these so called up dates that leave perfectly good kit behind a bit annoying to say the least.
As my IPad was the way I kept in touch with the forum it looks as this little avenue of pleasure has now been denied me and her was me thinking that the new forum was better than the old well it’s not if I can no longer access it !!

Any chance of a fix Richard ?

Unfortunately it looks like it affects everything Discourse related. Even the Discourse help pages won’t load on Safari on my old iPad 2. The only solution may well be to use a different browser that is supported on earlier IOS. Apart from that, I’m still awaiting word form our web developer if he has any other ideas.

There is a free browser called Aloha. It requires IOS 9.0 or above. I just installed it on my iPhone and I can read the forum on it (but my iPhone is on IOS 12 and I don’t know whether the problem people are having is a browser issue or an IOS issue). Anyway you can run Aloha on an iPad 2 so no doubt someone who has the problem can check if that solves it. @Richard.Dane maybe your iPad 2!



Thanks David, I don’t use my iPad 2 much these days - I have a much newer iPad mini that I use more, and of course my MacBook Pro and iPhone that I probably use the most for the forum.

However, if anybody with an old iPad wants to try Aloha, please do let us know how you get on - i.e. does the forum load?

Sure. But I just meant to check if it works for others who rely on an old iPad. My wife’s old iPad 2 which the grandkids now use to watch peppa pig et al is 500 miles away at the moment so I can’t check myself.


Unfortunately I can’t do it right now either as it’s 70 miles away…

1 Like