Forum not readable using Android

Is it just me? Browsing the forum from Android using Firefox or Chrome, all up-to-date, became nearly impossible. It started a while back and now has reached a point where I’m unable to read almost all (but not all) threads from my cell phone.

When opening a random thread it just shows headers and footers but no message at all. The message counter displays [ blank / n+1 ] when the threads overview shows n messages (I hope you get my IT lingo). Some threads display correctly incl. the message counter within the thread, at least sometimes…

And clearing the browser cache did not help.

Are there others that have the same experience? Is there something that can be done?

Thanks in advance!

Yes, but not Android. I raised it as a support issue a couple of weeks ago, exactly the same issue on an up to date iPad on the Safari browser. The response was that it wasn’t something they’d seen but would keep an eye on it (or similar, I binned the reply once I’d read it)

It stops being an issue for me if I log in, and so far is only on the iPad. On the W10 pc it’s fine.

I often read on a Pixel3 without any problems.

I use Chrome as the browser (80.0.3987.162)

Ok, it’s the same issue with Android. When I’m logged in threads are displayed correctly, at least the few I’ve just tried.

However, browsing without the need for a login is so handy, especially from a cell phone (that’s why we Germans call them cell phones ‘Handy’ ;-).

Maybe somebody will fix it someday, time will tell. Being a software developer myself I know that such issues can be a real pain to find and fix…

Thanks for the hints and replies! Cheers!

If using a mobile phone then it’s best to use the Discourse App as this gives much the best user interface for small portable screens.

I did notice that threads that fail to render can be made to appear by moving the count slider around a bit, presumably as the event that’s triggered when doing that mimics the usual loading of posts that weren’t visible until then. It’s a bit hit and miss, but does suggest that the page load doesn’t always successfully trigger the content download.

The other point to make if Support do see this is that once the browser fails to load content it happens on all threads. Once it happens - usually after looking in no more than 2 or 3 threads - it’s not going to resolve itself of its own accord.

That’s not what I experienced. The slider just did not work in such circumstances.

I want to add this: I just had a blank thread on my cell phone and after logging in it displayed fine.

Thanks, will give it a try.

I’m rather tempted to say that the issue is caused by the message counter being one count over the actual message count causing no load at all. But for proofing my theory one had to look into the implementation and see if that can be caused when browsing without being logged in…

Another funny thing is when I log off on my mobile I’m logged off on my PC as well and vice versa. This is security taken seriously!

I have to use Edge on my Pixel 3xl to make it work properly. Doesn’t like Chrome at all.

Very strange, that’s exactly the same device I’m using without any problems using Chrome.

I wonder if also using Chrome as my browser for use on desktop/laptop (running on a Mac Mini/Macbook Air) has any impact here?

Android user here and I’m not experiencing any problems: it has been a seamless experience. Big thumbs up to the developers working on the these little niggles for the benefit of the community.

Exactly the same here, from PC Windows 10 Professional and all updated. All problems disappear when I log in.

I would expect it to be reviewed, as it is quite annoying for forum users, and a trade crack if it affects visitors.


Thanks Newcomer. It appears to be a platform-agnostic issue then; Android, Windows, iPad. This forum is a commercial product that Naim have chosen to use, so I wonder if the providers are aware of this. My experience is that 90%+ of all s/w problems are data related once the full test & release cycle has been completed. Not that that helps here.

That trick with moving the side-bar counter a bit isn’t a fix. Sometimes it works if there are enough posts to be able to move a long way from the default last post to force a reload; usually it doesn’t work esp when the post count is low and there’s little wriggle room or no slider at all.

In Chrome there’s an option to inspect a part of the page (element) with a further option to view the page as if using different devices - numerous phones, iPads etc are listed - but I can’t replicate the issue in that. Over to the support team then.

1 Like

When it started on my Android device, I realised I was not logged in. Logging in solved it.

Yes, it’s platform agnostic and also somewhat browser agnostic… I had the problem today for the first time using Firefox (68.6.1esr (64-bit)) on an up-to-date Gentoo Linux/x86_64 box. I’ve never ever noticed this on Linux at home and on Windows 10 before (during “pre-home-office” times). On Linux it occurs very, very rarely. Just a very few threads appear to be affected where it is a regular annoyance on Android.

I really do hope this helps to get rid of this problem to make this fine forum even better!

It’s happening again, though inconsistently, on both my Android and Macbook.

It’s always like this on my iPad - the first 2 or 3 threads open fine then it goes pear-shaped and fails to render the thread content.

@Stevesky - is this on the developers’ radar? I flagged it as a support request 2 or 3 weeks ago, but it was treated as a “We’ll keep an eye on it”…

The forum software platform is provided by Discourse and not by Naim’s own software team. Our web developer handles the nuts and bolts but so long as you’re properly logged in on your devices and using the Discourse App if on a phone or tablet, you shouldn’t have any issues.

If you are using the App and still getting issues then please just let us know the specifics here and I’ll point it to our developer who will then try to replicate it.