HDMI ARC on Samsung TV stopped working with my Atom

Hi everyone!

I bought my first Naim (atom) a few months ago after running Hegel for several years. Overall I’m super happy w the Atom.

I decided to plug in my TV to the Atom with HDMI ARC. Worked fine for a while, except that the Atom freezed/required a hard reboot every time the TV went in to standby mode. Went to the reseller where I bought my Atom to get help. They mentioned that a new version of the software probably would fix it (version 3.5). I waited and waited, but it never came. So I asked again. They reached out to you guys (Naim support) if I could get the beta version of 3.5 installed, which they managed to do. Went to the store and got the new software installed in the Atom. Went home and everything worked perfectly. That was in late May 2020.

Now and for the last two-three months, no sounds at all via the HDMI. Have been waiting for more beta-updates and installed every single one, w/o any success. The Atom says “No input signal” and gives a beep sound every 30 seconds or so.

Samsung model: QE55LS03RAUXXC TV (The Frame, 2019)
Samsung software version: 1361
Digital output audio format on TV: PCM
Atom software version: 3.5.1.4970
HDMI connection on TV: ARC

I have tried:

  • Three different HDMI cables with both ends in the Atom
  • Unplugged both TV and Atom for several minutes
  • Updated the latest software on the TV

Anyone with ideas on what to try next? So annoying that it worked perfectly for a while and now no sound at all.

Thanks!

A friend had the same sort of problem with a Muso…solved by using an optical link instead…I think there have been quite a few reported issues like this with Samsung tv’s.

1 Like

I actually tried the optical link too, and it worked, but no possibility to adjust atom volume via the tv remove/Apple TV remote :confused:

Good evening,

Same problem here with the HDMI connection between a Uniti Atom (2019) and a Q80 Samsung TV. Problem (no sound via the HDMI port) appeared after the firmware upgrade to the 3.5.0 (4967) version which is the latest available in the Naim app. Tried all the possible fixes with no success. All the other ports are OK, no issues with the TV sound via the optical port.

Sent an e-mail to Naim support, will let you know if they have a solution.

Thanks @vdonev

Yes, this is probably the best option and just slum it with the lovely remote for the Atom, which is hands down better than the Apple TV remote. That’s what I did with my Nova and NDX2.

1 Like

Have you been in touch with Naim support? It may be that your TV has updated its firmware and that’s now what has stopped it working. Samsung TVs have a particular way of applying HDMI ARC, so I’m told, that can make compatibility quite tricky. However, I believe that Naim have an ex Samsung tech working with them…

Hi Richard,

In my personal case the problem arose the day I moved to the new NAIM firmware without changing anything else (my Samsung TV was already upgraded to the latest firmware) so the issue was clearly triggered by the Atom firmware update. In the past I was also given the “particular Samsung ARC technology” as a possible explanation for HDMI issues…having said this I see a number of comparable issues with Sony, LG, etc. brands reported on the forum and therefore blaming Samsung here seems a bit too easy…

I really hope that the NAIM support will find a fix!

You’re right, it’s an HDMI issue (thank the copy-protection), and, to make matters more difficult, ARC just adds more complication. However, you must get in touch with Naim support, otherwise they may be either unaware that there’s an issue here, or unaware of a particular circumstance which creates an issue.

I already sent a very detailed e-mail to the NAIM support guys and I am sure that they will look into it…they have been very responsive in the past!

OK that great. Thanks.

There have been a lot of fixes in the 3.5 release for various TV models for HDMI-ARC.
(Seems to be a real effort to support different vendors, models, generations, … so much for “standard”.)

Sad to hear, they broke it for your cases… hope they get it fixed soon.

Thanks for you reply @Richard.Dane

Just reached out to Naim’s support too.

1 Like

Thanks @vdonev

I just sent an email too, to their support. Do you know which version and build that worked? I’m thinking if we could get hold of that version and run that until it has been fixed :smiley:

Unfortunately I didn’t keep track of the previous version, sorry. I am therefore sentenced to use the optical cable until our friends from NAIM fix the issue… :wink:

1 Like

There is no mystery about the previous version of the firmware that worked for you. It’s almost certainly the previous release version.

You may be able to persuade Naim technical support to tell you how to roll back to the previous release, but they mostly don’t do that so would need an overwhelming reason. Anyway the only gateway to the previous version is Naim support.

Best

David

1 Like

Just heard back from Naim support. Seems to be related to the new Samsung software running on the TV.

“This issue was something that was introduced by Samsung with its latest update, here’s link to a thread with people having similar issues,

https://eu.community.samsung.com/t5/tv/q90r-audio-broken-after-1361-firmware-update/td-p/1855497

From what I understand, Samsung is aware of this and are currently working on a fix.”

1 Like

Thank you @gudding, this is very interesting. Indeed, the 1361 is my current Samsung firmware as well…let’s hope that Samsung will be responsive on this…

Just a quick update here, @vdonev . Just hang up with Samsung Call center. They remotely reseted my HDMI ports while everything was unplugged from the tv. Not sure exactly why, but that was step one. This did not solve the issue.

Step two, if no success, was to roll back to the older samsung software version or “deploy a fix” (not sure actually what the support guy said, but got the impression that they knew how to fix it), which they also could do remotely from their call center support.

Too bad I called five mins before closing hours, so I had to reach out to them again tomorrow morning to get help with rolling back the old version/new fix.

1 Like

Thank you so much for the heads-up @gudding! I’ll try to do the same tomorrow but given that I am based in Paris I’ll need to reach out to the French call center…very curious to hear their feedback. Could you please do me a favour: if your issue is fixed tomorrow, could you ask the Samsung technicians about the firmware they used or the reference of the batch they applied? This is for the (highly likely) case if the French call center tells me “we can’t do anything”… :wink:
Many thanks again!

1 Like