HDX issues Windows 10 File Explorer/ BT Smart Hub 2

A long shot but is anyone running an HDX on a network using the BT Smart Hub 2/ Windows 10 ? Sry if this is a long rambling question. After years of trouble free use I am suddenly unable to connect to the HDX in Windows 10 File Explorer under the Network Tab. Only physical change is recent switch to BT smart Hub 2. I was advised by Naim support to check windows had not disabled SMB 1.0 (which it sometimes does by default under recent windows 10 updates). This seems not to be the problem but disabled and enabled again to be sure. . I have completely disabled all features of my Security Software (ESET) and confirm that is not the issue. All other methods of connecting to the HDX work fine eg Naim Desktop Client for windows, N-Serve APP, and the HDX even pops up as media server in Windows File Explorer .
However if I try to connect to the HDX under the Network Tab it just times out, and says unable to access the HDX and displays the Path not found error code( and HDX does NOT appear under Devices and Drives)…Have tried assigning a different IP address to the HDX in the smart Hub setup with full reboot of HDX/Hub/Laptop but again not solved the problem. Have even tried to access File Explorer/Network/HDX on an old desktop and my wifes Laptop (all running Windows 10) and have same problem on all 3 machines. So dont think it is anything specific to the Windows 10 setup on my laptop as the same problem exists on the other 2 machines. HDX is wired to the hub via ethernet usually via a switch but have also tried connecting direct to the Hub. I the mists of time I seem to recall issues with Routers allocating DHCP correctly effecting the access to the HDX but cant remember details.
Much appreciate any thoughts on this.

Different router, different subnet on the network device? Assuming no static IP address set, a reset of the device?

I cannot remember when I last managed to use explorer directly. Usually I use the ip address shown in the dtc or the nnetwork name either in the search box in windows or in the run dialog.

I suspect the BT SH2, it should be foolproof, it’s as easy to set up & use as any hub I’ve owned.
It sets the network IP addresses with DHCP & is designed to discourage users messing with this, once you have an IP & connection, set to ‘Always use this IP’.

I would try turning everything off, power up the SH2 & reset, once that’s completed, then turn each of your devices on, one at a time.
Then go to the SH2 UI screen on your computer, look in “My Devices” and it should show all & how each is connected, ethernet or wireless & which wireless band.
If that doesn’t work, I suggest a call to BT, they can run on line test to determine if the hub has a defect.

fully agree with @Mike-B suggestion. You might also repeat the test, but with one of your PCs hard wired, as there was chat a while back about WiFi connectivity issues on SH2’s which needed a firmware update (something BT will be able to confirm)

The BT corrective firmware v0.26.04.04227 was updated on mine 24/5/21

Thanks for all suggestions, unfortunately I have already ticked those boxes.
I have connected my laptop via ethernet instead of wireless, then full reboot of router/ laptop/ and HDX.
I tried going back to my old BT Business Hub 5 which always worked fine but strangely even with everything hard wired and a full reboot I found I now have same issue even with .
I have always run the HDX with same IP allocated so that I can configure my ESET security software to exclude the HDX IP from scanning.
Did however try a different IP to see if it would make any difference which did not.
As you say Smart Hub 2 very simple to set up and can see the HDX under Ethernet connections
Using Adobe Flashplayer standalone I can access the HDX front screen without any problem , so this combined with the fact that Desktop Client is working fine confirms that the HDX is definately running with the correct IP address as allocated by the smart Hub.
Confirm Smart Hub running latest firmware since 28th May.
Unfortunately with the HDX the only way to install and manage downloaded content is via Windows File Explorer.
Very frustrating…

Perhaps you could try connecting your PC to the HDX downloads folder using the IP address and two back slashes in windows explorer (not a browser obvs).



Also can you ping the device via it’s iPad address?

yes tried that and once again it just times out the same as clicking on the HDX when it pops up under the network tab.

yes i tried a path ping to the IP and got reply . Seems IP address based response work everywhere except in File Explorer

Unfortunately I dont know much about an HDX, so not sure what should work and what shouldn’t, but if it pings, then I’m wondering if there is some sort of firewall issue. Is it possible to stop the windows firewall service temporarily? Also have you installed any additional firewall or anti-virus software recently - perhaps you can also stop that service temporarily? Failing that, perhaps try Naim support

Could this be a “Workgroup” issue? I vaguely recall I had to set something on mine, or rather Naim did it remotely.

I don’t think the workgroup stuff applies with Windows 10 (although I could be wrong) but anyway all he has changed is the router, so the workgroup settings, if there are any, will be unchanged.

1 Like

Are you sure you’re using the right IP address here? The HDX is slightly unusual in that it uses two IP addresses, one for the main controller for CD ripping and play, and another for the display controller. Maybe some scope for confusion with your router here?

1 Like

Good question Chris!

Hi. I have the HDX main IP and the Front Screen IP identified and named. Strangely have notice that the Front Screen of the HDX is showing as not connected to the router. In the past have always been able to access the internal HDX menu via the main IP address. Before Microsoft banned flash player from their browsers was simply able to type in the IP adress into the browser and access the Menu. now have to use the standalone flash player as advised by Naim support. You actually type in

UPDATE ! Possibly getting somewhere or maybe deeper into confusion… I noticed that after rebooting the laptop and opening file explorer under the network tab I can see the HDX with the name I have allocated to it in the router setup ie NSHDXDAO5.
Seemed like File explorer was still trying to make connections even before I clicked on the NSH… to open it up. I have previously tried to delete the existing drive mappings for the HDX without success (I use two, one for Download folder and one for Music folder ) . but tonight I managed to delete them. I then found that I could connect to the HDX. I then reinstated the drive mappings to the HDX folders. All was ok. Restarted the File explorer and the problems returned ie unable to access the HDX. I again deleted the drive mappings and after restarting the File explorer I found that I could no longer see the HDX at all or indeed mthe other media servers such as the NAS under the network tab. However with the mapped drives deleted I can now connect to the HDX by typing its IP address into the Network Tab Address bar. Left it alone for a while refreshed the network tab and now all the media devices are visible again. No idea why all the devices were not visible on rstarting file explorer but became visible after about 15 mins almost as if everything was running slowly. At this moment in time i have the 2 HDX folders mapped to the IP adress and are opening up fine. I can also see NSHDXDAO5 under the network Tab and also can expland it and browse the 2 shared folders. I have to try and reboot the laptop and see if I can still have the same functionality. Fingers crossed.

1 Like

UPDATE. For any who may be interested. I realised that as soon as Windows File Explorer started up and I clicked on either ‘This PC’ or the ‘Network’ tab it went into the never ending attempt to update. As it seemed the App was trying to connect to something I deleted the mapped folders for the HDX, re started File Explorer and found I could then connect using the ‘IP address’ allocated by the SmartHub. Shared drives all accessible… so able manage the HDX downloads again.
However File Explorer still not displaying the HDX under Network devices with its Device name (‘NSHDXDA05’ that I have assigned in the router settings)
Duncan from Naim Tech Support then sent a youtube link with a whole variety of solutions for Network connections issues in File Explorer . I was reluctant to try some, like messing about with regedit. However I did try Control Panel / ManageCredentials/ Windows Credentials, where I found there was a saved login for NSHDXDA05 . I deleted this . I then found on refreshing the Network Tab in File explorer I could see the HDX as NSHDXDA05 .
Unfortunately this success was short lived, as having been away for a few days I started up File Explorer again and NSHDXDA05 no longer appears and strangely I also cant see my QNAP NAS either. So there is some intermittent issue. If I type in the HDX IP address that still works so I can live with that. (Also the mapped drives for the QNAP are connecting without problem, so dont mind not seeing the QNAP in Device list.
N.B. As I’m typing this I just hit the Network Tab again and refreshed and NSHDXDA05 and QNAP have decided to display again having not done so for past 24 hrs… Very random…Next call will be discussion with BT support and maybe requesting a replacement SmartHub to see if we can fully resolve all the issues. Once again many thanks for all your suggestions.

One workaround might be to first set the router to always give your device the same up address, then in addition add that up address and device name to the hosts file on your PC