HDX reading from NAS, BUT won't accept it as a Store

Hi there.

I Have a SSD HDX, that can read from my QNAP NAS, but if I promote the NAS to being a Store rather than a Share, it tell me that there is an error. If I try the same with my Synology NAS there are no problems - can it be a setting in the QNAP that is wrong?
Both NAS’s are in RAID configuration and have the same music and same folder structure as they work as back-up for each other

The HDX needs SMB1 enabled in any NAS it’s talking to. I wonder whether that’s the issue with the QNAP which the maker has locked down consequential on all the NAS hacking they have suffered from. SMB1 is strongly deprecated now for security reasons, but the HDX (and other similarly old Naim servers based on Windows XP) can only talk SMB1.

I think I understand what You’re saying - but what puzzles me is that it can read from the NAS when it is set as a Share, but can’t write to it when it’'s set as a Store for rips.

Indeed. But it may be that reading a file has different settings in the QNAP than writing to it does. Anyway it’s the security settings in the QNAP I suggest you look at.

Did this used to work and has stopped recently or is it the first time you have tried to do this? The reason I ask is that firmware updates for NASs do sometimes cause these sort of issues because of services that are turned off or permissions changed in the update, in the search for better security.

Maybe @ChrisSU can help?

It used to work back when I used my HDX as prime source - the last two years I have used a CORE through the N-DAC, but I have some ripping issues with the CORE - it seems that the CORE label’s the files differently than the HDX - all files ripped on the HDX can easily be copied to a USB or a SD Card for use in my car - but files ripped on the CORE, need’s to be re-named with number and .flac before the car intertainment system will read them - this is why I tried some rips on the “old” HDX again.

Probably a permissions thing in the QNAP then.

I don’t understand your Core problem. Is it set to rip to FLAC?

Set to rip to FLAC…but I also tried with WAV - same issue. I don’t understand either…

Any folder you want to rip to has to be totally empty including hidden files. Try creating a new folder within a share and using that. Create it within the qnap software and do not open it. For instance if you open it on a mac, it will automatically have a hidden file created within it.

What you may have missed is that he had a store but it got demoted to a share by accident while he was sorting the HDX out. So he doesn’t want to create a new store, when what you say would certainly be true, but rather to revert the old store from being a share to being a store again. I’m not certain that the same rules apply in this exact case.

Correct…I’ll try asking around locally…my son is in IT but the problem is that the HDX have it’s own laws when it comes to reading and writing - and Since Phil Harris left Naim, NOBODY there are clear when it comes to IT issues on the HDX software…so there most be at lot of “abandonned” HDX owners out there. I do have the CORE, but to some extend I prefer the sound from the HDX through my Naim N-DAC…

Hi David, sorry, I missed this at the time. A couple of thoughts:

Are you using the automatic backup that runs from the HDX? One set up, it works very well, but whatever backup process you use, do you really need your HDX to access both of the identical music libraries? I’m not sure it would be able to do so without getting confused.

It’s possible to have multiple music stores, one of which will be active in that it’s where new rips are saved, but all of them will be playable. If your two NAS drives are backups of each other, surely you can create a new one on the Synology which the backup process would then copy onto the QNAP?