HDX won’t start up 2022

Help please! My HDX “disappeared” from the remote app but was still playing. Shut it down as per proper procedure and on re starting it now hangs with “starting” on the built in display.

Have connected monitor and mouse and I can control the unit BUT it looks a bit sick from a settings perspective as you can see on the attached photo. HDX is connected to a live internet connection but it does not get as far as to see that I think. With lots of !! not set !! Parameters how do I move it forward from here?

Is it like some suggest in this post HDX won’t start up a case of waiting for a database to release build itself?

N.B. I can see and play all CD’s which have been loaded onto the HDX but cannot see (or play) any of those downloaded onto the unit via internet ??

Thanks in advance for your help. K


Try to disconnect the power cable, even if it’s not the best way, it may help here.
Or @ChrisSU should know.

It looks like it’s stalling at the point the HDX tries to get a lease from the router. Maybe your current lease just happened to expire while it was playing.

I would be inclined to turn it right off, also restart your router (and any relevant Ethernet switch), find another network cable to exclude a faulty cable, and restart it. If you have the display connected as you do all of this, what else does it tell you?

Your HDX has clearly failed to connect to your network as it has no IP addresses. This could be a temporary glitch which could, as David says, be remedied by a restart. I would turn off the HDX and your router, leave them for a few minutes, start the router, wait until it’s fully up and running, then restart the HDX.
Is the HDX running static IP addresses? This is usually best avoided, but presumably it has been working properly until now?

For me it helped to start the HDX one time without internet connection and then restart it with the internet connection again. Hope it helps for you as well.

Hello @davidhendon I have shut down, un plugged and restarted both router and HDX. Started up Router after 5 mins then when network / internet up restarted the HDX. Same outcome, no change on the HDX except before the “starting” message on HDX there was a message " starting streamnet…" ( or something like that)…Nothing much shows on the VGA monitor it seems to lag behind the HDX display when the system is starting up.

@ChrisSU how do I check if running static IP address?

You should be able to log in to your router to check, Assuming your HDX has connected.

Google the IP address for your router or it may be written on it. Type that in your browser.

As per photo the HDX is not connecting to the network. Using the external monitor to access setting page the first set of information is

Name Value
Host Name NSHDX3899
IP Address !! not set !!
Subnet Mask !! not set !!
Gateway !! not set !!
DNS !! not set !!
Address Mode DHCP
MAC Address :::::
Front Panel IP Address
Internet Accessible False
Size of database 150.00 MB

I am sorry to say that I think your HDX has a fault and you are probably going to have to send it for repair.

Unless @NeilS has any other suggestion.

Giving the HDX a static IP address has to be done by using the SetIP tool on a Windows computer. (It actually uses 2 IP addresses, the additional one being for the front panel controller, but your screen shows that it is receiving neither of them).

It’s entirely unnecessary to use static IP addresses in a regular home network, and if your HDX was working normally until now I doubt it is set up to do so as it would probably never have worked. I just wanted to eliminate the possibility that a previous owner might have done this.

The fact that there is also no MAC address showing is a bit suspicious, so it could be a hardware fault rather than a network issue.

Could it be that the CMOS battery is due for replacement? (Easily done by the dealer.)

No Dave. The messages in the attached display are completely different!

just had a look at mine

looks bad to me, you don’t have mac address :disappointed_relieved:

MAC Address :::::

this is a hardware low level address, without it its not going to work. its not a user setting its hardware.

even with it, you still need the gateway/DNS address of the router so it finds a IP address from it. eg

sorry back to base with it


Thanks all. I will contact dealer and book it in for service. Had a bit of a bad run over the past few years with this unit! It’s had a new HDD and PSU. Getting close to having to replace all key elements now it looks like the networking is duff. I run the unit on conditioned power, always switch on /off in proper sequence etc. still it sounds amazing when working !!

The motherboard has lost all connection with the network, there are a few points of failure within the HDX that could cause this, but the give away here is that the unit cannot see the internal Downloads share, which is accessed via the loopback address through the motherboard NIC, so I’d imagine that is where the problem is.
Could be the Ethernet controller IC itself, or a problem with the power supplies to it.
Investigation & repair required I’m sorry to say.



Corrupt boot sector or dead CMOS battery are the most likely candidates, if you can’t get it to start. A dealer visit will probably be in order.

Just got unit back from dealer. They said was a HDD failure and replaced it. Seems to be working fine now but I suspect was a corrupt boot sector rather than the HDD itself. They have restored all music including burned CDs and Downloads but I’ve lost all my playlists which is frustrating! Got the old HDD back so might get dealer to have another play and see if they can recover.

Notice although all music is there the HDX doesn’t see or find all music with search function. E.g. two The War on Drugs albums are on the unit but are not in the artist list.

  • If I search by album title I find them in search
  • if I search downloads folder via pc the albums are in folder War on Drugs (missing the)
  • they appear on the IPhone Naim app as would be expected.

I’ve re scanned the library to no avail. Only thing I can think is that the HDX is slowly rebuilding its database and I just need to let it do its own thing and all will sync up eventually!?

You perhaps need to consider moving on from this device. In the mean time of you music is in wav get the hdx to convert to flac for future proofing?