Help! NDX 2 Stopped Working

Hello all,

The strangest thing has happened to my NDX 2. I was streaming Radio Paradise when I had to mute. When I tried to unmute, it just refused to do so.

The NDX 2 is connected to my Supernait 3 through System Automation (with a 3.5 mm cable) and has been working fine until now.

I have tried restarting the both the NDX 2 and Supernait 3 (thrice) without success.

The Supernait 3 seems to be fine. When I select the turntable input it plays music.

The mute light on my Supernait 3 is off (unmuted) but I simply cannot stream anything through the NDX 2. I have tried to stream internet radio, Tidal and my music collection from Uniti Core- nothing works. The NDX 2 screen shows the music selected (the album cover from the Core for example) but no music is being played.

All cables and connections are in order.

Has anybody experienced this? It seems the NDX 2 is stuck in mute? Can somebody please help?

Stag, it’s a streamer… ATB Peter

Has the output somehow changed from DIN to,RCA (or vice versa), it might be worth having a look.

Had this with my ND555 try a factory reset using your remote via the screen.

I am sorry @PeterR, I may be missing something from your reply. Do you mean such things are supposed to happen? I am ok with it happening, I get that it’s a streamer; but I would just like it to play music again.

Should have added via settings on the screen.

I was just being cheeky Stag :wink: ATB Peter

Oh sorry Peter. I obv missed that in my frantic state.

Thanks @Eoink and @pcd.

The input had not changed from Din to RCA.

I am attempting the factory reset as we speak. It is taking some time to reset.

If the reset doesn’t fix it, then I’m afraid it might be stuck relays and you’ll need to speak to your dealer to arrange an rma back to naim.

Factory reset fixed it. Not very confidence inspiring. Thank you all for your help.

Please do report to, they are looking for strange cases that need fixing

1 Like

I will.

In the meantime, I’ll think twice before using the mute function.

I realize I assumed you were using the remote, but actually not sure. Did you try the mute button in the app?

@Suedkiez Yes, I tried both mute buttons in the app and remote. Neither worked.

I was asking because on the Beta thread an issue came up where the app and remote mute buttons go out of sync and you have to do some gymnastics to unmute, but on re-reading it is not what you were seeing. (This is already being fixed by Naim).

@Suedkiez In the event it happens, what are the gymnastics one must go through on the remote and app?

Could you try switching off system automation and revert to muting/adjust volume using the SN3 remote instead?

Far simpler setup and less things to go wrong.

It is possible that this only happened in the Beta version and not in the release firmware that you have:

“If I mute the volume with the mute button on the remote, changing the volume through the app (volume up button or slider) does not work. The only thing that works (other than grabbing the remote) is unmuting the volume in the app (by tapping the volume icon), then muting it in the app, then unmuting it again in the app (yes, three taps).”

Hi, glad the factory reset restored the sound this looks exactly ike he problem I was having with my ND555 very frustrating indeed.

Naim have been involved and being one of the Beta testers a Beta Firmware update about three weeks ago has resolved the problem.