Help - Updated QNAP software, now can’t see Asset

I did a routine (?) update of the QNAP HS251+ software yesterday. All seemed to go well, but now I can’t find my Asset server in the Naim app. I’ve rebooted the NAS, stopped and re-started Asset but nothing. Anyone any ideas what’s up? What can I check or try?

(Internet radio and Tidal are both working okay.)

Not familiar with naim app but how is asset defined to it… static ip address? Did the nas get assigned the same address following its reboot? Do you use address reservation on your router to prevent it picking up a new one or rely on dhcp and auto discovery?

No, none of that. It relies on the router to set IP addresses.

There was some malware protection function in the latest qnap firmware versions. Can it tinker with the Asset?

So the router assigns the nas its address… how is asset then defined in the app? By address or some form of auto discovery?

Will have a look at this, thanks

Auto-discovery in the app.

Hi @GavinB, I suggest you ask the question on the dBpoweramp / Asset forum. The same or similar question about QNAP software updates has been raised before. I’m not familiar enough with QNAP myself but I recall the problem is with QNAP & not in stuff like IP addresses

Okies, couple of things to try…

  • do you have another control app available, can that find asset ok?
  • if the other control app find asset, can you delete asset in the naim app and redrive the discovery process?

Apologies for the vague nature, this is just general trouble shooting, as mentioned i know neither asset nor the naim app so if someone else has more detailed knowledge, follow their guidance :wink:


Hey same with me - any solution? Yikes no music.

Although I only did a check disk following unexpected power cut during last week but all ok after power cut just acted today on Asset warning to run disc check and that’s when server disappeared from app.

I can see the QNAP 251+ on my PC and play from there but no server on the app.

Powered down router, NDS and QNAP but still nothing on app.

Ah spoke too soon - back again on app - maybe power down of all items did the trick - the old power down trick works again. Phew!

@AndyP I’ve re-booted all three - router, NAS and ND but no success. Did you do it in any particular order? What about a switch? Would you suggest doing that too?

1 Like

Router NDS then QNAP

I do have a switch but didn’t think about that - worth a try.

Can you see your QNAP music files in windows explorer - firing up a track from there gave me confidence that the QNAP was OK with over 14,000 albums residing on it it’s very precious (backed up of course).

Will give this a go. I can see the music files via a couple of other PCs. They seem to play fine. And Asset re-appeared after this?

I’ve posted on the Asset forum to see if that adds anything.

No it re-appeared after I had rebooted the QNAP

Hope you get it sorted.

No success last night after the carefully orchestrated re-boot sequence, but…

I tried my iPhone this morning and all was good. Still nothing on the iPad but a re-boot of that has now worked. Sounds like I should have just tried that last night!

Thanks, everyone, for your input.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.