Help with installing LMS2UPnP for Roon to 272

Hello, im really having issues with the installation of the plugin, even with the help of the thread on this forum and also the help file on the github page. i want to try, for now, having Roon setup along with the lms2upnp service on a windows laptop before building something more permenant but i cant for the life of me get lms2upnp installed, its either my ineexperience or not all the files are present in the download, maybe both.

my issue is that while i have got as far as being able (i think) to actually launching the windows version of the plugin file it comes up with an error that there isnt a config file present. the terminoligy of “launching in console” is also a bit new to me.

The explanation of launching it from a console i took to mean that i need to launch it from cmd with the “-i config.xml” tag on the end of the specific binary file, i.e. “squeeze2upnp-x86-static -i config.xml” however there isnt a config.xml file anwhere in the files downloaded and it gives me an appropriate error in command prompt.

I may just be an inexperienced idiot but does anyone know of anywhere that there is an actual idiots guide to installing this? literally a “download the files, extract to a directory, open cmd, type exactly this…” kind of thing? id really like to experiment with the upnp option into my 272 and see if Qobuz and Roon are worth investing in while i can get a free trial.

Thanks in advance

so to put some further detail on the steps im currently doing ive attached some screenshots as below.

Run command - I run the binary file, in this case the x86-64 version from the file location with the “-i config.xml” suffix

Open with - i select to open the binary with the .exe within the same folder

Cmd - the file runs, warning for lack of config file and then it sits there and never exits after 30s or otherwise, its also not visible in Roon.

thanks in advance

Have you checked out the iFi UPnP bridge for Windows? I’ve not used it personally but some people on here have. Google it and you will find a YouTube video. Also search this forum and you will find others have used it.

I’ve got Roon running on a 272 but a more permanent and costly solution, so I won’t go into detail about that.

I would edit a brand new text file, then rename it to end with dot bat. This when run will auto run in a console aka terminal, if youre not familiar with doing such things.
In the bat file, put the command to execute
Full path … \squeeze2upnp-x86-static -i config.xml
That means “run and make me a config file”
You can then edit the config file and follow the remainder of the instructions.

V. probably better instructions than mine!

This is easy when you know how!

The process is

Download the file

Unzip to a directory on your computer. Say c:\upnpbridge

You should have something like this

Open a command window (use the windows key and R together, type cmd and press enter)

Enter the following in to the command window


Enter the following and press enter

squeeze2upnp-win.exe -i config.xml

This will run the program which will scan your network for UPNP devices (make sure they are switched on!) and create an initial config.xml file which will need to be edited.

Now type the following and press enter

notepad config.xml

This should open the config.xml file in Notepad

Change the following lines




Click on File > Save

Now return to the command window and run the program, i.e. type


You should be able to see your devices in Roon now. It may not be obvious which is which so you will need to experiment or lookup the MAC address and compare to the entries in the config.xml file.

In the config.xml file there is a section for each device, you can edit the friendly names here. Here’s the section for my NDS which is in the sitting room.

If it doesn’t work then try disabling the firewall in Windows temporarily


Thankyou very much, ill give it a go.

Best regards

Thanks again for the assistance, it worked in the end, I think I may have actually managed it earlier via different means however it seems to be stable now. O ly issue I now have is that the android app is crap :joy: ill just have a play using roon on the laptop for now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.