Help with Superuniti (screen burned)

Hello, first of all greetings to all and thanks for letting me write here. Recently the screen of the uniti has died. I have been able to use it with the app in the iPhone, but recently i have changed the internet company then the configuration has blow out. and its imposible to connect with the app.
I could change the screen but i thing that isn’t a wise idea… only to make the new configuration.
I wonder if would be possible to connect the uniti in maintenance mode with the usb conection to the computer and ‘see’ the configuration parameters and change it to the new values of the router (it make possible internet radio connection…)…

Thanks in advance…

Hi! SU it’s a fine system. Do it some justice and change the screen. It’s worth it.
As for your question, I’m afraid I can’t help.

thanks… :slight_smile: !!

The SU has a breathtaking sound, but the screen is really bad… i think streamers would be commanded by any app in your tablet or phone. I dont like new ‘nova’ ‘atom’ star’ screen concept, its necessary the image in the unit??

The screen in SU it’s not bad. It’s the longevity that’s not enough.
But in screen ‘s concern (or aesthetic in general) I’m with you: I do prefer the older Uniti generation. I don’t need a screen to see artwork or whatever. Just tto navigate and do the essentials (like define network).
But time doesn’t go backwards, so when time comes to upgrade my UQ2 I will go Nova

I’m guessing Raul is using wifi to connect his SU.
You probably need to work out the full set of key presses to get you through the menu structure to the point where you put in the network password. I guess this is possible using the remote but it’d be tough to get through such a long string of key presses without making a mistake! The sticking point could be when you need to select which network you want to select - I can’t remember whether you have to scroll through a list.
A better alternative might be hard-wire it using an ethernet cable - this should just work - it doesn’t ask for a password etc. If you can’t hard-wire directly, perhaps you could use something like an Apple Airport Express which will handle the connection to wifi, and then hard-wire from that to your SU.

1 Like

But you still end with an crippled SU.
I just think it’s a waste . He should arrange the system.

thanks 4 your help. I am using ethernet but i am not using DHCP (if you use dhcp = Yes) you connect the wire and have instant access to internet, but i have the ip values fixed…(gateway, dns, …) :frowning:

Probably using the keys in blind mode may work!! i only need the touchs to access.
Setup. navigate to:

language / inputs / Speakers / headphones / net configuration (Y play down arrow 4 times) or left arrow? to access net configuration. Then

net options -> name / Wireless / Status / DHCP (y push ok to enter this menu) and navigate with down arrow 3 times, then y push ok and select (YES) :slight_smile:

sorry i am near the solution but i need some help :frowning: , with the blind touchs…

I seem to recall this issue coming up a number of times over the years and I seem to recall someone posting the step by step button presses to accomplish some stated goal though I don’t recall exactly. Perhaps a search on the old site would yield some useful information.

I have a SU and can try to replicate the steps but even though I set up a new router a few months back I don’t recall what I did. lol If someone can tell me what I need to do I can give it a go.

1 Like

Hi raulcv,

If you do a factory reset, it will default to DHCP.
Switch the unit on while pressing & holding the front panel stop button (hold it for at least 10 seconds).
Then press the front panel play button. Leave the unit to run through the reset procedure - 2 or 3 minutes.
Then you should be good to go.



Neil (who is the expert) has crossed with my email.

If you didn’t want to do a factory reset for any reason then it’s:

Press spanner
Press down on the four way button 5 times, then press ok

Press down on the four way button 3 times, then press ok

Press ok again to select Yes to DHCP

Then press spanner twice to get back out again.




ohhh… it works!! first i try yo change to dhcp (thanks David…) with no success. then i follow the steps to factory resten and … yessss. I am listening internet radio again.

I am very happy, the procedure to reset in the manual is more dificult…

Thanks neil you are a máster…
I have SU for next years :heart_eyes:


I think you probably would have needed to restart your SU after performing my DHCP changing set of key presses in order for it to take effect. The old streamers have a DHCP bug that was introduced in an earlier firmware update (4.3 I think it was) that Naim never sorted out.

Anyway I’m glad you have it working again.




This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.