How do I get my Atom HE to read disc numbers on albums with multiple discs

I’ve now had my Uniti Atom HE for 6 months, and I’m very happy with it, including the Naim app.

My only issue is that I have some of my files attached on an external SSD via USB. They mostly play fine, but unfortunately the Naim app seems to read the “disc number” for albums ripped from multiple CDs, and just plays them by track order, i.e. in a total mess.

I’ve spent months on the tagging of all of my music, and I’m just surprised that Naim is ignoring such a simple tag. I’ve found some older threads on this site referring to this issue, but haven’t found a solution yet. While I understand the concept of disc number is quite useless in the streaming age, this shouldn’t be a hard thing to solve for Naim.

One solution could be to just retag all of my multiple disc albums, but I’d really love to avoid that as we’re talking about at least 50 albums.

Any suggestions?

Look under Servers/Local Music and you’ll see a tag view instead of the basic folder view you get in the USB input.

Thanks but just to be clear I am using the Server view exclusively, and still have the issue.

Not a direct answer, but in my filing I number tracks from multidisk albums with an added 1,2,3 in front, so first disk track nos are 101, 102… second disk 201, 202 etc. That way they all seem to play in the correct order.


Thanks, that’s an option.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.