I am not able to play to Naim Uniti Star from Jriver after upgrading the firmware to the latest version


I have a Jriver server on my network. I have Naim Uniti Start linked to the Jriver as a Zone. I was able to play music from Jriver to Uniti Star, where the Jriver was controlling the Uniti Start as a DLNA render.

After upgrading the Uniti Start firmware to the latest version, Jriver cannot play music at Uniti Start anymore.

I can only play music from the Jriver server, If I use the Naim app on my mobile and select the Jriver server from the app. Although this method is working, I don’t prefer it.

I did reset for the Uniti Star to the factory default settings, but it did not work also.

Appreciate your help.


Have you tried these things?
Restart router
Restart switch if you have one
Restart jriver

Can you see the star as a play zone?

What options do you have ticked here?


Dear robert_h,

Thank you very much for your kind reply,
Yes, I can see my Uniti Star on the list. When I chose it for playing, I could see the track information and the cover art are displayed on the Uniti Star display screen. But the sound does not play, so I got an error screen that the Jriver cannot control the Uniti Star.

Regarding the options, I have checked the same as those in your screenshot.

Just for information, everything was working fine before the firmware upgrade of Uniti Star.

appreciate your kind help

Have you restarted jriver so it re-detects devices on your network?

I re-installed the Jriver from scratch. Even I installed Jriver on another different computer, same issue.

Uniti Star now only works with Roon (Which I don’t like). I don’t want to use Roon, because of the following.

I don’t like its sound.
I have a huge library at Jriver where I have organized, tagged, and saved notes over years, where I cannot redo all these efforts again.

Roon compared to Jriver is way more costly (119$ vs 18$ a year).

Paging @tomvamos
Similar to above, cant play to an ndx2 but can play to a qb gen 1.

Thank you, Robert, for your kind help, I really appreciate it.

I hope that one of Naim’s staff can respond to this. I am really surprised about purchasing such expensive equipment, and there is no direct support from the company.

You need to contact support, this forum is not for raising issues, it’s not monitored by Naim.

There are a v small number of staff, primarily Clare who is head of PR for Naim/Focal, Neil who works in servicing, Tom is software, Steve software director, couple of others, but that’s it.

For help with all Naim product installation and operation please use the following details:

T: +44 (0) 1722 443405

Hours of service are Mon-Fri 9:30am-5:30pm GMT/BST

1 Like

I discovered this problem about a week ago. I had tested JRiver and JRemote as controllers when I first got my Nova last summer - it worked, but then switched to the Naim app. I tried it again recently on both my Nova and my Muso-2, while troubleshooting an unrelated issue, and found it didn’t work on either. JRiver gives me a generic “Problem with DLNA” message.

Edit - I reported it.

1 Like

Dear Robert,

Thank you very much for your kind efforts in helping me to sort the problem out.

Also, thank you for the Naim contact you have listed. I will try to reach them for a resolution.

Best regards,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.