Importing songs from a wd mycloud to core

HI, this is my first post and I am looking for some help.
I have a new uniti core, set up with SSD. I have trialled one cd rip and it works, I can play from my NDX2, all fine and dandy. But I have a number of tracks on my previous NAS, a WD Mycloud that I downloaded from HD tracks.

When I go into configure music stores on the app or input music, the WD cannot be seen - in fact no network drives are seen. They are all on the network properly as I can see them from the NDX2 or my PC, but not the core.
I also tried going into the file explorer on my PC and the core doesn’t appear on the network, but it does appear in media player and I can play the ripped CD. Finally when I go to the IP address, the page is just a black page.

I have followed some advice about checking SMB settings - but they are all configured as advised. I am not a network expert, but not a novice either - but I am confused………many thanks

There are several versions of the WD MyCloud drive - do you know the exact device/model number?

Where are the files stored on it, in Public shares or elsewhere?

Does it run a DLNA server eg Twonky or something more recent and if so is this enabled/configured?

If you can see the files on a PC I would strongly recommend you provisionally copy them for backup purposes to a locally attached external USB drive or similar assuming the download service does not offer unlimited redownloads, and you’ve not done so already.

I don’t have a Core so can’t say if it’s possible to copy over directly over the LAN, but it’s very important you have backups of files on the NAS which could fail at any time unexpectedly.

You should be able to navigate to your Core’s downloads folder in the way described in the on-line support guidance for the Core in Naim’s website.

Basically rather than going to the ip address of your Core with a browser, which gives you the blank black page, you have to use Explorer and navigate to the network connection using \ip address or \UNITICOREserial number, the latter being the name of the Core if you haven’t renamed it. For some reason the two backslashes in each case are showing up here as one backslash and it won’t let me put in two, but it’s two you need.

Once you can see the downloads folder then you can drag and drop the files from your WD device using your PC.



1 Like

Hi there. Yes it is a twonky based NAS, and I have been happy with it for a few years, my previous Nova and now the NDX2 links up no problems, with music stored in a public location…it is just the core that I am having problems with.
I don’t understand the Naim structure, I can get the basic attributes (such as version and serial numbers etc) of the NDX2 at the IP address webpage, but a blank page for the core…Is this normal ?

Thanks - I tried internet explorer (instead of Edge just in case) and used \ core IP address, and still black, blank page - just the page name comes up as NAIM.
I am still flummoxed why I cannot see the directory from the PC, or the WD (or any other network attached drives, such as my PC) in the Naim app for the Core…V V strange.

I also tried the unitcore serial number address and the same results.

I’ll have to defer to Core users here as I don’t have one.

Suppose you’ve seen these and tried to create a Downloads folder - I’m assuming you’d need to copy from NAS storage to there via the PC unless the Core can see the NAS currently:

You need to use Explorer, not Internet Explorer! You can’t use a browser.

Which Windows version are you using?


1 Like

Also it’s two \ \ followed by the IP address or name. But you need to do this in Explorer and not Internet Explorer.

I use Windows 7,and I had a problem with the core showing up in media player too.By pulling the plug on the Core,it solves it for me.The core then appears under network,after I plug it back in.I can then access the downloads folder.

1 Like

Oh good I am glad you solved it. A full power out restart of the Core often solves these sort of oddities.


For future reference, Explorer is the screen in Windows 7 that you get when you select Computer from the right hand side of the start menu. It shows a map of all the drives and network resources connected to your computer. You write the two backslashes and the IP address of the Core or its name into the bar at the top, just like it was a browser and it will then look for the Core. It should give you a screen with the two folders and you can then navigate those as usual.

Thanks - I am using windows 10.i
When I type the IP address into the explorer (not internet explorer) I get the message cannot access the address. When I diagnose, it says the device or resource ip xxxx is not set up to accept connections on port “the file and printer sharing smb”…
Is it something I have peculiar on my setup or is this a problematic or faulty device to configure properly ?

The Core is set up to receive SMB. Assuming that it is in the latest firmware, which is quite a few months old by now, then the first thing I would try would to restart the Core. By this I mean take the power off completely for a few seconds (to make quite sure you aren’t just waking it up.
You also need SMB activated on your PC, but presumably you checked that.



Firstly apologies for the delay in replying but combination of work and some hardcore ripping have consumed me.
Firstly thanks for all the advice.
For information what finally fixed it was probably a combination of restarting, confirming network sharing and finally removing the device from the file explorer and then restoring it…now all fine and dandy. Everything transferred and new downloads completed . :blush:

Glad you sorted it!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.