Infra-red remotes stopped working!

Strange one for you all to think about. This morning most of my infrared remotes stopped working, this although I can still use everything from the front panel controls on the preamp etc. My Harmony Elite has been a bit flakey for a while, so at first I put the blame on that. However the original remotes for the affected equipment are not working either (I checked the batteries, to make sure that wasn’t the problem). First thing this morning I was using my PS4 to play a game, and the AVR remote was working OK. It all went t*ts up after lunch, when I returned from being SWMBO’s chauffeur.

SWMBO’s TV, DVD, Bluray, Humax, Panasonic PVR working OK, so the problem must be something to do with my study (where my hifi/AV lives)

I have set up using : Sony 40" TV, Arcam AVR 850, NAC552, Humax PVR, Oppo 103, PS4 (plus a couple of other bits which I haven’t tried yet (including XBox360 and wii U - so I’m a bit of a gamer - sue me!)

Sony TV, NDS, nSub and NAC 552 still working OK with their own remotes. Humax PVR also working OK, but a bit “sluggish”.

Equipment not responding to remote control (including power toggle) :

Oppo 103
Arcam AVR 850
NDS also not responding to the pause/play button on the Naim App (iPad), although it does that occasionally!

The only other thing that went wrong this morning was that my NDS decided to have a tantrum and not connect to my NAS. Cured that by the usual power off/on of the NDS. That seems to happen about once a month, but I’m used to that.

I’ve tried all the obvious cures :
Batteries checked
Switched everything off for a while (including unplugging the Oppo from the mains)
Checked that we didn’t have a power cut last night, and that there weren’t any thunderstorms.

Any ideas, or do I have to live without the remotes in future?

More info. I checked the infrared of the remotes using my Lumix camera, and the Arcam one seems OK, but the Oppo one had the infrared permanently stuck on, but the light went out when any button was pressed. I’ve tried all the suggested cures for this on the web, and can get it to switch off, but the minute I press any button it gets stuck on again.

I also tried removing the Oppo remote from the viewing room and unplugging the Harmony Elite hub. Arcam remote still not doing anything.

I think I may need a new bluray player, and have posted on the Home Theatre forum for suggestions.

I have encountered similar problems with various remotes and have had some success by dismantling and cleaning with isopropyl alcohol. Bright sunlight can also cause problems.